I've recently had a look inside "ping.c" and "ping_group.c". It wasn't a great surprise to find some commonality. I guess one was derived from other. It means that we've got considerable code duplication, potential unnecessary divergence and potential "one-but-miss-the-other" bugfixes).
Might it be worth attempting to merge them into a more-or-less common codebase? If you think this is worth investigating, then it's probably something I could look at, low priority, in the coming months. -- : David Lee I.T. Service : : Senior Systems Programmer Computer Centre : : UNIX Team Leader Durham University : : South Road : : http://www.dur.ac.uk/t.d.lee/ Durham DH1 3LE : : Phone: +44 191 334 2752 U.K. : _______________________________________________________ Linux-HA-Dev: [email protected] http://lists.linux-ha.org/mailman/listinfo/linux-ha-dev Home Page: http://linux-ha.org/
