On 10/10/2009 11:38 AM, Stefano Franchi wrote:
Problem solved,  but I am even more confused than before.

I did install biber and tried it out (after a rather unpleasant time spent
fighting with perl dependencies..). The problem remained.

As Richard guessed, there was a problem with the encoding of the LyX file.
Switching to Unicode UTF* in the Document>>Settings>>Language pane solved all
the problems. After the switch to UTF8, the references were formatted
correctly, both by standard bibtex and by biber.

I am happy but confused. UTF8 (for bib files) should not be supported by
bibtex and Lyx (since it just calls bibtex). Yet it works. I am wondering if
there is some magic going on behind the scenes.

As Lehmann said in the post I copied, bibtex will in some cases work with UTF files, but only by accident. (My sense it that the problems arise with sorting and labels.) So you got lucky with this one. Using biber, if it's functional, and ALSO changing the document encoding will give you a chance of having it work all the time.


Reply via email to