On Saturday 10 October 2009 11:41:39 am rgheck wrote:
> On 10/10/2009 11:38 AM, Stefano Franchi wrote:
> > Problem solved,  but I am even more confused than before.
> >
> > I did install biber and tried it out (after a rather unpleasant time
> > spent fighting with perl dependencies..). The problem remained.
> >
> > As Richard guessed, there was a problem with the encoding of the LyX
> > file. Switching to Unicode UTF* in the Document>>Settings>>Language pane
> > solved all the problems. After the switch to UTF8, the references were
> > formatted correctly, both by standard bibtex and by biber.
> >
> > I am happy but confused. UTF8 (for bib files) should not be supported by
> > bibtex and Lyx (since it just calls bibtex). Yet it works. I am wondering
> > if there is some magic going on behind the scenes.
> 
> As Lehmann said in the post I copied, bibtex will in some cases work
> with UTF files, but only by accident. (My sense it that the problems
> arise with sorting and labels.) So you got lucky with this one. Using
> biber, if it's functional, and ALSO changing the document encoding will
> give you a chance of having it work all the time.
> 
> rh
> 
Thanks Richard,

so I am going to follow your suggestion and switch to biber. 

I have installed it and it works fine from the command line after exporting 
the lyx (UTF8-encoded) file to .tex. If I want to use it directly from Lyx, is 
it sufficient to specify "biber" instead of "bibtex" in the preferences (i.e. 
in Tools>>preferences>>File Formats>>BibTeX)? As far as I can tell from the 
output in the console, lyx  seems to be calling biber. Is that all that's 
needed? You seemed to imply in a previous message that some work on the 
developers' side is required.


Cheers,

S.

______________________________________________________________
Stefano Franchi
Department of Philosophy          Ph:  (979) 862-2211
Texas A&M University              Fax: (979) 845-0458
305B Bolton Hall                  fran...@philosophy.tamu.edu
College Station, TX 77843-4237

Reply via email to