On 7/03/2014 11:51 a.m., Denis Navas Vega wrote:
El 2014-03-06 02:39 p.m., STF escribió:

I came across error while trying to install LyX 2.0.7 in Windows 7
64-bit (actually I have tried in many computers with the same error).
I'm using the setup called "LyX-2.0.7-Bundle-1.exe" downloaded from LyX
official website.  As to Windows, to be exact, I have tried Windows 7
Professional & Enterprise SP1 64-bit but I don't think the *editions*
and *SP1* parts are relevant.  I think the problem would still happen in
other 64-bit Windows O/S, eg XP, Vista, etc.

The error I got are shown in the attached image: the upper dialog
appeared first.  But almost immediately, it's grayed out and the lower
dialog appeared and LyX installation simply was aborted and failed.  LyX
setup then tried to roll back but it got stuck on "Remove folder:
C:\Program Files (x86)\LyX 2.0\" and I had to press the Cancel button.

I went a bit further and described here below:

I took basic-miktex-2.9.5105.exe and run it in another Windows 7 64-bit
and it still crashed! I then downloaded basic-miktex-2.9.5105-x64.exe
from MiKTeX official website and tried it but that crashed as well!
Seems like MiKTeX setup has very serious problem installing in 64bit O/S!

(Off-topic 1: Maybe it's some known bug like
(Off-topic 2: I have heard from some other friends of mine that MiKTeX
is actually a big piece of $h!t and their developers, being very
arrogant, didn't care about their installer not working in 64-bit O/S
and I quite agree with them after finding a lot of mails in their
mailing-list which are never answered!)

But I found out that if I run basic-miktex-2.9.5105.exe the second time
with the option "Reinstall using recommended settings" (which is *only*
available when the setup is run outside LyX) after deleting "C:\Program
Files (x86)\MiKTeX 2.9" folder, the installation went through the end!

Then at this point, if I used "LyX-2.0.7-Installer-1.exe" instead, it's
fine.  So, it might be nice to warn 64 bit O/S users to download the
"LyX-2.0.7-Installer-1.exe" on the download page and give them a little
bit help on installing MiKTeX.

Hope this helps.

That's a problem that I have suffered in the past with different programs, after windows actualizations. This is a windows problem.
I've never tried installing the LyX bundle. I've always installed MiKTeX first and then LyX -- and without problems. Recently I installed the 64-bit version of MiKTeX 2.9 on a new(ish) 64-bit Windows 7 computer without problems, but discovered that biber was missing from that distro -- evidently the 64-bit distro is still "experimental" -- so I went back to the 32-bit MiKTeX 2.9 (the Basic distribution of 160 MB or so, and then added the packages detailed under LaTeX Configuration in LyX's Help menu). It too installed without problems.

As for MiKTeX being a " big piece of $h!t", I haven't had problems with it (and it certainly doesn't give me the kind of conflict between package managers mentioned in a recent thread on this list that users of TeXLive on Ubuntu systems face).


Reply via email to