On 03/03/17 19:30, DJ Delorie wrote:
> Also, you can use "msp430-elf-gcc -mintr ..." to minimize the runtime
> support.
Thanks DJ,

I tried -mintr and at least one project produces code that could fit, 
thanks (should have RTFM - but finding this was not intuitive).

Now the linker doesn't want to play with me - it cannot find the 
"msp430g2231.ld" link file. Curious because the compiler fids "msp430.h" 
in the same directory.

It looks like the dir info is not being passed to the linker.
I have tried forcing it with -T<linkscript abs path>, but no joy.
I have my compiler installed at /opt/msp430-gcc/ (I don't want to 
clutter /usr/local/bin) and wonder if a hard coded path has been set 

I am running on OpenSUSE42.1 (which is 64-bit).
I have tried compiling from source and also installing TI's installer - 
the results are the same.
Any one have any ideas ?



The Sun is out, the sky is blue, it's time to drive the MR2.

Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Mspgcc-users mailing list

Reply via email to