On 06/03/17 16:58, Ben Green wrote:

>>From my understanding the .h files and the .ld files are not supposed to be 
>>in the same directory. When in installed msp430-gcc-support-files-1.198.zip I 
>>did this:

Curious, as the TI installer places them there (under 

> cp *.ld /opt/msp430-elf-
> cp *.h /opt/msp430-elf-

Makes sense - I'll try that.

> Now that does seem strange, I would have expected that to work, did you make 
> sure you were passing the argument to the linker and not GCC (though that 
> might not make any difference)... how about using the -L switch?
> -L /opt/msp430-elf- -T msp430g2231.ld

Yes, tried that too.

> Benjamin.

Yes, splitting the two worked, (I wonder why they installed into the 
same place?) thank you Ben.

 From David Schultz,

 > I include -Wl,-L$(SUPPORT_FILE_DIRECTORY) in the flags for gcc when
 > linking.

I had tried this, but no joy.

Now I have to find out where the vectors have gone - they are missing 
from the .hex file. Maybe a different name from the old mspgcc?



The Sun is out, the sky is blue, it's time to drive the MR2.

Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
Mspgcc-users mailing list

Reply via email to