If I do an iscsiadm -m iface i get "iscsiadm: no records found!"  do
I have to create the ifaces files manually. I'm having difficult
understanding the ifaces files and how they are used.  I have some
virtual hosts that can attach to storage over eth0 and eht1 as opposed
to an iSCSI hba.  On those systems I dont see any ifaces files.

Can someone explain to me what I need to do in my situation.  iscsiadm
-m iface returns no records found and I'm using a Qlogic HBA qla4xxx.

any assistance would be greatly appreciated.

thanks

Jason


On Aug 15, 7:12 pm, Mike Christie <[EMAIL PROTECTED]> wrote:
> WonderBoy wrote:
> > sorry I didnt see your response, I have not tried specifing the ifaces
>
> No problem. I sent it in the order I read the mails so you would have
> seen the other one first :)
>
> > file.  I'll do that here shortly and see if this works.
>
> Ok, just one update. Below I said it is not possible on RHEL, and it
> turns out it is possible on RHEL5. So if you do
>
> iscsiadm -m iface
>
> you should see some thing about qla4xxx and some mac addresses. You can
> then take the ifacename for the port you want to use and run that command
> iscsiadm -m discovery -t st -p ip -I iface_name_of_qlogic_card
>
> There are some hicups though. We do not yet get any error from qla4xxx
> if something fails. So if the qlogic card has in the firmware defaults
> to use CHAP or digests, but the target does not want to use them you
> will not log into anything and you will not get an error.
>
>
>
> > Thanks Mike
>
> > Jason
>
> > On Aug 15, 2:58 pm, Mike Christie <[EMAIL PROTECTED]> wrote:
> >> WonderBoy wrote:
> >>> I cant use the Sansurfer cli, not because it doesnt work but it stamps
> >>> the volume info "iqn, target ip, etc" on the card.  In my situation
> >>> this data cant be written to the card, and this is why I'm looking
> >>> towards the open-iscsi initiator solution.. data will only be on the
> >>> os.
> >> That is not possible with the driver in RHEL.
>
> >> With the upstream kernel, if you do
>
> >> iscsiadm -m discovery -t st -p ip -I iface_name_of_qlogic_card
>
> >> then it will do sendtargets discovery and log into all the targets and
> >> portals found. It will not store anything on the card firmware.
>
> >> I think the closest you can get with iscli + qla4xxx in RHEL is just
> >> storing the discovery address on the firmware. You do not need to store
> >> the target, ip for every target you want to use. Just the discovrey
> >> address. Maybe that will help.
>
> >>> The software initiator solution is what I really need to work, I have
> >>> Redhat calling be back here shortly and hopefully I'll get more
> >>> information.
> >>> On Aug 15, 2:40 pm, "Don Williams" <[EMAIL PROTECTED]> wrote:
> >>>> If you install the qlogic, iscli utility, you can use that to statically 
> >>>> map
> >>>> the volumes.  You'll need the complete IQN name and the IP address.
> >>>>  Usually, using SANsurfer makes life easier, even if you have to run the 
> >>>> X
> >>>> window to another server.   Are you using RHEL v4.x or v5.x?
> >>>> What iSCSI target are you using?
> >>>>  Don
> >>>> -----Original Message-----
> >>>> From: open-iscsi@googlegroups.com [mailto:[EMAIL PROTECTED] On
> >>>> Behalf Of WonderBoy
> >>>> Sent: Friday, August 15, 2008 4:44 PM
> >>>> To: open-iscsi
> >>>> Subject: Re: Redhat 5 Qlogic HBA discovering new targets
> >>>>   I can boot off of the card fine using the Redhat driver or the
> >>>> Qlogic driver, but I'm not using software initiate for boot.
> >>>>   I'm looking to discover and login to additional storage that I
> >>>> allocate to this server. I need the open-iscsi driver to login through
> >>>> the HBA as well, I cant use front end network interfaces.  I dont care
> >>>> if I use the Redhat driver or the Qlogic driver for open-iscsi, I have
> >>>> tried both and neither work.
> >>>>   I just need the iscsi client to discover my iscsi targets.  Is this
> >>>> even possible at this point with the version of open-iscsi that is
> >>>> available.
> >>>> thanks for the help
> >>>> Jason
> >>>> On Aug 15, 1:11 pm, Konrad Rzeszutek <[EMAIL PROTECTED]> wrote:
> >>>>> On Fri, Aug 15, 2008 at 12:52:10PM -0700, WonderBoy wrote:
> >>>>>>   I'm currently working with Redhat to try and acomplish the following
> >>>>>> and I'm wondering if anyone knows if this can be done or not?
> >>>>>>   Mount iSCSI target through Qlogic iSCSI HBA, not eth0 or eth1, and
> >>>>>> discover and login to storage targets.  In the documentation it says
> >>>>>> you can mount storage through the HBA but I'm not having any success.
> >>>>> I don't think it was ever possible without downloading QLogic drivers.
> >>>>> In fact, I am sure about this b/c that was the only way I could
> >>>>> configure the driver using the SANSurfer and was told that
> >>>>> the future versions of SANSurfer will support the new 'qla4xxx'
> >>>>> driver.
> >>>>>> any suggestions..
> >>>>> Get the QLogic driver.. and e-mail the QLogic developers (you can find
> >>>>> their names in the qla4xxx.c driver) asking for a SANsurfer that works.
> >>>>>>   I currently have a ticket open with Redhat and they are scratching
> >>>>>> their heads.
> >>>>>> thanks
> >>>>>> Jason- Hide quoted text -
> >>>>> - Show quoted text -- Hide quoted text -
> >>>> - Show quoted text -- Hide quoted text -
> >> - Show quoted text -- Hide quoted text -
>
> - Show quoted text -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to