Were you exporting something on ocfs using the iscsi-target?
If you had meant any data transfer between the boxes using
iscsi-target,  there were no data transfers between them.

I tried the suggestion you gave me. It works perfect. Once i stopped
the service, it says connect failed(111) and keeps trying and once the
service is up, the error goes off and it says connection 1 is
operational after 10 attempts.
The same case with the iscsitarget/initiator box reboot as well.

On Thu, May 14, 2009 at 1:14 PM, Mike Christie <micha...@cs.wisc.edu> wrote:
> sundar mahadevan wrote:
>> Hi members,
>> I tried to do the following to find out the error messages:
>> Both systems with iscsitarget/open-iscsi initiator and open-iscsi
>> initiator were up.
>> On the open-iscsi initiator i had opened a terminal with command tail
>> -f /var/log/messages and left it running
>> And then i rebooted the server with iscsitarget/open-iscsi initiator
>> And all i could see were
>> ocfs2_dlm node 0 leaves domain
>> nodes in domain : 1
>> and then it hangs again
>> so i had to manually hard reset the server
>> I tried to boot with runlevel 2 but there were not much of a use
>> because there were no specific error messages to this scenario, i
>> Checked /var/log/messages and /var/log/boot.omsg
>> But i'm still able to ping the open-iscsi initiator system on its
>> hang. But when i try to rsh or ssh to the system, nothing happens.
>> I haven't setup multipath yet.
>> @mike
>> I have setup ocfs2 file system on a partition(on  secondary hard drive
>> on iscsitarget/open-iscsi initiator box) which is being mounted as
>> /u01/orcl on both boxes.
>> So i think i have nbd(not sure if my setup is supposed to be called as nbd).
> nbd is a special network block device driver. Do not worry about it. It
> does not look like you have it.
>> When i tried rciscsitarget stop on  iscsitarget/open-iscsi initiator
>> box, both the  iscsitarget/open-iscsi initiator box and  open-iscsi
>> initiator box hanged. Again a hard reset.
> Were you exporting something on ocfs using the iscsi-target?
> Could you simplify this and take ocfs out for a minute. Just add some
> file or real disk or a virtual disk to the ietd.conf file for the lun.
> For example just stick:
> Lun 0 Type=nullio,Sectors=2097152
> in the ietd.conf which will create a dummy lun.
> Then restart the target and log in from the other box and retry your
> reboot test with that (no ocfcs2 at all).
> Does that hang?
> >

You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at http://groups.google.com/group/open-iscsi

Reply via email to