On Wed, Dec 24, 2014 at 12:48 PM, Adam Brightwell
<adam.brightw...@crunchydatasolutions.com> wrote:
> * BACKUP - allows role to perform backup operations
> * LOGROTATE - allows role to rotate log files
> * MONITOR - allows role to view pg_stat_* details
> * PROCSIGNAL - allows role to signal backend processes

How about just "SIGNAL" instead of "PROCSIGNAL"?

Generally, I think we'll be happier if these capabilities have names
that are actual words - or combinations of words - rather than partial
words, so I'd suggest avoiding things like PROC for PROCESS and AUTH

In this particular case, it seems like the name of the capability is
based off the name of an internal system data structure.  That's the
sort of thing that we do not want to expose to users.  As far as we
can, we should try to describe what the capability allows, not the
details of how that is (currently) implemented.

Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to