On Fri, Oct 14, 2016 at 4:35 AM, Stephen Frost <sfr...@snowman.net> wrote:
> * Peter Eisentraut (peter.eisentr...@2ndquadrant.com) wrote:
> > On 10/12/16 11:22 AM, Tom Lane wrote:
> > > The main problem we're trying to fix here is people thinking that
> > > something with "log" in the name contains discardable data. Just
> > > relocating the directory without renaming it won't improve that.
> > I think it would help if we moved it to something like
> > "internal/pg_xlog" and "internal/pg_clog". Keep the name but move it
> > out of sight.
> I disagree that this will materially help with the issue.
> > We have a tool called pg_xlogdump in the standard installation. initdb
> > has an option --xlogdir, pg_basebackup has --xlog and others. Renaming
> > the xlog directory would make this all a bit confusing, unless we're
> > prepared to rename the programs and options as well.
> pg_xlogdump is not a user-facing tool, frankly, so I don't believe we
> should be terribly concerned about either leaving it named as-is or
> renaming it. I agree that we should consider adding alternative names
> to the options for initdb and pg_basebackup.
Ugh. Changing the names of those options are probably going to break a
*lot* of things, a lot more than changing the names of the directories. Is
it really worth doing that? Especially if we are even more clear that
people should not be touching those directories in the first place.
Those are just the tip of the iceberg. We do use the term xlog in a lot of
places (almost as many as wal, but that's a different problem)