Re: Stephen Frost 2016-10-14 <20161014113523.gz13...@tamriel.snowman.net> > > We have a tool called pg_xlogdump in the standard installation. initdb > > has an option --xlogdir, pg_basebackup has --xlog and others. Renaming > > the xlog directory would make this all a bit confusing, unless we're > > prepared to rename the programs and options as well. > > pg_xlogdump is not a user-facing tool, frankly, so I don't believe we > should be terribly concerned about either leaving it named as-is or > renaming it. I agree that we should consider adding alternative names > to the options for initdb and pg_basebackup.
There's actually another instance of "rename so people shoot their feet less often" here: pg_resetxlog, which is a user-facing tool. Folks on #postgresql have repeatedly been joking that it should rather be named pg_eatmydata, given the number of "howtos" on the web that make use of it. Maybe this is the chance to find a less innocent-sounding name. (Or add a mandatory --rewind-my-data switch.) Christoph -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers