On Wed, Jan 25, 2017 at 2:46 PM, Jim Nasby <jim.na...@bluetreble.com> wrote: > I think the two need to be integrated much better than they are right now. > They should certainly be in the same .so, and as others have mentioned the > docs need to be fixed. For consistency, I think the name should just be > pg_prewarm, as well as the prefix for the GUC.
Yikes. +1, definitely. > It would also be handy of those functions > accepted a different filename. That way you could reset shared_buffers to a > known condition before running a test. That would have some pretty unpleasant security implications unless it is awfully carefully thought out. I doubt this has enough utility to make it worth thinking that hard about. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers