I solved my problem (here).  IBM came out with new drivers and they sovled
the problem.
THanks

-----Original Message-----
From: Simpson, Doug 
Sent: Monday, September 29, 2003 11:38 AM
To: [EMAIL PROTECTED]
Subject: [PHP-DB] odbc


I am trying to connect to an AS/400 from a Linux box running RH9.
I have installed unixODBC and the iSeries drivers.
I can run "cwbping" that tell me that I am connecting to the AS400.
I have made a scipt the following script -
<HTML>
<HEAD><TITLE>ODBC Data Source</TITLE></HEAD>
<BODY>
<?php
//odbc_query.php
        $odbc_dsn = "sysDSN";
        $odbc_userid = "RADCUR";
        $odbc_password = "sacsac";

        $query = "select * from radtcur.nfp";

        if(!($odbc_db = odbc_connect($odbc_dsn, $odbc_userid,
$odbc_password)))
                die("Could not connect to ODBC data source $odbc_dsn");

        if(!($odbc_rs = odbc_exec($odbc_db, $query)))
                die("Error executing query $query");

        odbc_result_all($odbc_rs);

?>
</TABLE>
</BODY>
</HTML>

When I run this script from a web browser I get the following error in my
http error logs

[client 172.16.32.241] PHP Warning:  odbc_exec(): SQL error:
[unixODBC][IBM][iSeries
Access ODBC Driver][DB2 UDB], SQL state S1000 in SQLExecDirect in
/var/www/htdocs/odbcquery.php on line 15

Does anyone know why I am getting this?
Thank you for your time<
Doug

-- 
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

-- 
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to