Wow, thanks. It's trying to read in the entire thing 670kb of PicoLisp.
I'll try other versions of qemu. There are a few between this one and the
others that failed.
Is there a way to change a qemu bios file config? Could I change beg.l to
load it in segments, or would it still require a 670kb read to put it
together again?


On Mon, Jul 20, 2015 at 6:33 PM, Alexander Burger <>

> Hi Rob,
> > I tried several, and when I finally tried version 2.2.90 for windows 64
> > bit, It went past that error and went to a 'READ ERROR 09'
> > Is that a 09h Attempt to DMA over 64kb boundary using the same Wiki
> > reference you supplied in a previous posting?
> Yes, indeed. And interesting: This seems to be the first time that error
> number 09 appears.
> > How can I fix it or keep moving on? Where do I look in the source to
> > troubleshoot this myself? Exciting fun anyhow, so no complaints here!
> The place where this happens is "pilos/x86-64/beg.l", line 26 ff
>    mov $DAP, %si                 # Disk Address Packet
>    mov $0x42, %ah                # Extended Read Sectors
>    int $0x13                     # Drive interrupt
>    jc readError
> This is the standard BIOS call to read a given number of sectors from a
> drive.
> This above error is correct, in that indeed more than 64 KiB are being
> read from the drive (the size of PilOS is 670 KiB currently).
> So the BIOS which is emulated in your version of Qemu somehow cannot
> handle it. Unfortunately, I don't know of any other way, except from
> writing your own "BIOS".
> ♪♫ Alex
> --

Reply via email to