On Fri, Oct 08, 2010 at 05:10:01PM +0200, IOhannes m zmölnig wrote:
On 10/08/2010 04:30 PM, Reinhard Tartler wrote:


or just add the patch to debian/patches and apply at build-time...


is it allowed to fix license issues in the upstream code by applying debian/patches?

If old upstream code is still not DFSG-free (i.e. deemed unsuitable for Debian to redistribute even in source form), and upstream solved the issue by replacing it with other code which is differently licensed, then a Debian patch is not enough: We need to replace the upstream tarball with one containing only DFSG-free code.

If, on the other hand, the exact same old code has been relicensed upstream, then we need not even a patch: It is enough to clarify in debian/copyright the upstream statement on the relicensing.


Regards,

 - Jonas

--
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to