Ken Snyder wrote:

> The function seems more useful if it returns the id.  I'd vote for the 
> name Element#getId(). 

Not getId() since that implies that the id already exists and this is simply
retrieving it. createId() would be more indicative of what it does.

But since all this does it create a unique identifier in the context of the
current page, why limit it to just being a part of elements? I've used unique id
generation stuff before that had nothing to do with an element's actual id.

Here's some other possible names:

String.createId()
String.uniqueId()
$id()
$uid()

-- 
Michael Peters
Developer
Plus Three, LP


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to