[ http://issues.apache.org/jira/browse/MODPYTHON-127?page=all ]
Work on MODPYTHON-127 started by Graham Dumpleton.
> Use namespace for mod_python PythonOption settings.
> Key: MODPYTHON-127
> URL: http://issues.apache.org/jira/browse/MODPYTHON-127
> Project: mod_python
> Issue Type: Improvement
> Components: core
> Affects Versions: 3.3
> Reporter: Graham Dumpleton
> Assigned To: Graham Dumpleton
> Fix For: 3.3
> In the interests of avoiding name clashes, I want to push that where
> mod_python uses its own PythonOption settings, that they use a namespace. For
> PythonOption mod_python.session_cookie_name ...
> PythonOption mod_python.ApplicationPath ...
> PythonOption mod_python.session_dbm ...
> PythonOption mod_python.session_fast_cleanup ...
> etc ....
> If appropriate for mod_python, multiple levels of naming should be used. For
> example, "session_fast_cleanup" is actually related to FileSession, so
> perhaps it should be:
> PythonOption mod_python.Session.cookie_name ...
> PythonOption mod_python.Session.application_path ...
> PythonOption mod_python.DbmSession.database ...
> PythonOption mod_python.FileSession.fast_cleanup ...
> Thus, class name is interjected as second level in name. Also would like to
> see final attribute name settle on lower case with underscore between
> distinct words.
> We can support old names in mod_python for the time being but should
> deprecate them.
> Any third party package developers should be strongly encouraged to also put
> any of their own PythonOption settings names in their own unique namespace.
> Mailing list thread where this was first proposed, and in case there were
> followups of interest, was:
This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see: http://www.atlassian.com/software/jira