Hi Angelos,
thanx a lot for the hint. It works!

This is now indeed the third variation of a working setup in a row.
We already had to enable three repositories, then two, and now it's only one. Unfortunately the instructions on the download page never manage to reflect those changes.


Cheers
Bernd


Am 17.07.2016, 21:36 Uhr, schrieb Angelos Tzotsos <gcpp.kal...@gmail.com>:

Hi Bernd,

This will get you to a working setup:
1. Please remove all previous installed versions with apt-get purge qgis
2. Enable only UbuntuGIS-Unstable and remove all other ppa's
3. apt-get install qgis.

This will get you QGIS 2.14.3. I have several reports that this works fine.

Best,
Angelos

On 07/17/2016 09:47 PM, Bernd Vogelgesang wrote:
Hi all,

now I enabled http://qgis.org/ubuntugis-ltr and I face the same problems as below, but only for 2.14 version now. Is there any way to install a recent QGIS with my beloved ubuntugis features from the repositories, or is this just a local problem?

I need to get this up and running as I would like to do some work ...

Cheers
Bernd

Am 16.07.2016, 15:11 Uhr, schrieb Bernd Vogelgesang <bernd.vogelges...@gmx.de>:

Hi Jürgen,
thanks for the reply.

Ok, as I understood your words, I disabled ubuntugis and enabled instead:

deb http://qgis.org/ubuntugis-nightly-release trusty main
deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty
main

But still, QGIS will not install:

bernd@bernd-TERRA-PC ~ $ sudo apt-get install qgis
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
    qgis : Depends: libgdal.so.1-1.11.2
Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
           Depends: libqgis-analysis2.16.0 but it is not going to be
installed
Depends: libqgis-app2.16.0 but it is not going to be installed Depends: libqgis-core2.16.0 but it is not going to be installed Depends: libqgis-gui2.16.0 but it is not going to be installed Depends: libqgis-networkanalysis2.16.0 but it is not going to be
installed
           Depends: python-qgis (=
1:2.16.0+git20160712+1b016e4+20trusty-ubuntugis) but it is not going to be
installed
           Depends: qgis-providers (=
1:2.16.0+git20160712+1b016e4+20trusty-ubuntugis) but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.

Actually, I do not intend to have something "unstable" or exotic, but simply just the same
flavour as when I use the OSGEO4W-installer on Windows.

Even after years, I can't figure out from the help pages what all the stuff means and how things have to be handled in case something doesn't work (which happens actually at each change of version, but the way to resolve this seems to be different every time).

Thankful for any hint
Bernd

Am 15.07.2016, 21:28 Uhr, schrieb Jürgen E. Fischer <j...@norbit.de>:

Hi Bernd,

On Fri, 15. Jul 2016 at 18:36:06 +0200, Bernd Vogelgesang wrote:
Will the rebuilding be triggered automatically, or do I have to
"trigger" someone to have a look at it ?

No, the dependencies are not actively tracked and therefore no automatic
rebuilds are triggered.

But the nightlies are rebuilt with current dependencies whenever a commit (backport) has happened in the meantime. So you can resort to those for
"unstable" distributions (ie. distributions that have changed between
releases).

The next regular rebuild is on 29.7. for the 2.14.1 and 2.16.1 point releases.


Jürgen









--
Bernd Vogelgesang
Siedlerstraße 2
91083 Baiersdorf/Igelsdorf
Tel: 09133-825374
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to