Henri - sorry for the late reply back.

If you look under /etc/apt/sources.list.d - do you have a QGIS.list file? Or something under /etc/apt/sources.list with a repository listing for QGIS?


Yes - it is possible because I am sitting here running QGIS on Ubuntu 16.04.

Randy


On 09/19/2016 02:36 PM, Henri LABORDE wrote:

Yes, seriously,  is there a way???

which QGis version ?

and how to proceed?

That sems impossible, because a lot of mysterious messages like these ones:

cheers

Henri (desperate Linux user)

==================================================================

Paramétrage de qgis-providers (2.14.1+dfsg-3~xenial0) ...
/usr/lib/qgis/crssync: error while loading shared libraries: *libgif.so.4*: cannot open shared object file: No such file or directory
dpkg: erreur de traitement du paquet qgis-providers (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 127
Paramétrage de libjs-leaflet (0.7.3~dfsg-1) ...
Paramétrage de qgis-common (2.14.1+dfsg-3~xenial0) ...
dpkg: des problèmes de dépendances empêchent la configuration de qgis :
 qgis dépend de qgis-providers (= 2.14.1+dfsg-3~xenial0) ; cependant :
 Le paquet qgis-providers n'est pas encore configuré.

dpkg: erreur de traitement du paquet qgis (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de qgis-plugin-globe-common (2.14.1+dfsg-3~xenial0) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent. dpkg: des problèmes de dépendances empêchent la configuration de qgis-plugin-globe :
 qgis-plugin-globe dépend de qgis (= 2.14.1+dfsg-3~xenial0) ; cependant :
 Le paquet qgis n'est pas encore configuré.

dpkg: erreur de traitement du paquet qgis-plugin-globe (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent. Paramétrage de qgis-plugin-grass-common (2.14.1+dfsg-3~xenial0) ... dpkg: des problèmes de dépendances empêchent la configuration de qgis-provider-grass : qgis-provider-grass dépend de qgis (= 2.14.1+dfsg-3~xenial0) ; cependant :
 Le paquet qgis n'est pas encore configuré.

dpkg: erreur de traitement du paquet qgis-provider-grass (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
dpkg: des problèmes de dépendances empêchent la configuration de qgis-plugin-grass :
 qgis-plugin-grass dépend de qgis (= 2.14.1+dfsg-3~xenial0) ; cependant :
 Le paquet qgis n'est pas encore configuré.
qgis-plugin-grass dépend de qgis-provider-grass (= 2.14.1+dfsg-3~xenial0) ; cependant :
 Le paquet qgis-provider-grass n'est pas encore configuré.

dpkg: erreur de traitement du paquet qgis-plugin-grass (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu3) ...
Des erreurs ont été rencontrées pendant l'exécution :
 qgis-providers
 qgis
 qgis-plugin-globe
 qgis-provider-grass
 qgis-plugin-grass
E: Sub-process /usr/bin/dpkg returned an error code (1)

======================================================================

very very bad trip since I've made the upgrade from 14.04 LTS to 16.04 LTS

La curiosité est un vilain défaut...curiosity is a bad thing...

    > Message du 14/09/16 06:24
    > De : "Blumentrath, Stefan" <stefan.blumentr...@nina.no>
    > A : "Randal Hale" <rjh...@northrivergeographic.com>,
    "qgis-user@lists.osgeo.org" <qgis-user@lists.osgeo.org>
    > Copie à :
    > Objet : Re: [Qgis-user] Ubuntu updating instructions
    >
    >

    And if I may add:

    Even if the users are aware of the fact that ubuntugis-unstable
    contains the current releases, it can be hard to impossible to
    convince a GIS-ignorant system administrator that it is OK to
    install “unstable” packages.

    But this issue is not a QGIS issue I guess...

    *From:*Qgis-user [mailto:qgis-user-boun...@lists.osgeo.org] *On
    Behalf Of *Randal Hale
    > *Sent:* 13. september 2016 16:45
    > *To:* qgis-user@lists.osgeo.org
    > *Subject:* Re: [Qgis-user] Ubuntu updating instructions

    >

    On 09/13/2016 10:23 AM, Jürgen E. Fischer wrote:

        Hi Randal,

        On Tue, 13. Sep 2016 at 00:21:21 -0400, Randal Hale wrote:

            It's a little bit confusing. There are like three repositories:

            stable, unstable, and testing. Testing you don't want (unless you

            want to test packages). Typically stable is a bit older. Unstable is

            current. Which doesn't really make sense - but that's the way it is.

        Not like it matters much in this case.

        We have packages in qgis.org/debian/ against the plain versions of the

        distributions (debian and **ubuntu**) and in qgis/ubuntugis/ packages 
against

        newer dependencies from - and only from - ubuntugis-unstable.

        Looks like it's hard for people to accept that there are also ubuntu 
packages

        in a directory called debian and that probably makes them jump on the 
other

        because it has ubuntu in it's name.

    I was thinking about it last night (and I was up way to late) and
    it is a bit confusing for the casual user. They've installed
    Ubuntu (or mint/debian/xubuntu/etc) and they may not understand
    ubuntu is based off debian. So like you said - they see debian but
    want to use Ubuntu. They go to UbuntuGIS and they see the
    repositories for UbuntuGIS and the choice is unstable (and no one
    likes unstable software) and stable (which doesn't contain the
    newest software). So you end up going "Use Unstable because it's
    stable and current".
    >
    >

            Under my /etc/apt/sources.list.d directory I made a qgis.list file

            and put the following in there:

            debhttp://qgis.org/debian  xenial main

            debhttp://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu  
xenial main

        Why?  That are the packages not based on ubuntugis with the 
dependencies from

        ubuntugis.

    Do I have this wrong? I thought I had the repositories for the
    install correct based off the directions on qgis.org. Which I
    could completely have it wrong. With the above repos I'm getting
    QGIS 2.16.x and GDAL 2.1.x.
    >
    >

        Jürgen


        >
        >
        >

        _______________________________________________

        Qgis-user mailing list

        Qgis-user@lists.osgeo.org <mailto:Qgis-user@lists.osgeo.org>

        List info:http://lists.osgeo.org/mailman/listinfo/qgis-user

        Unsubscribe:http://lists.osgeo.org/mailman/listinfo/qgis-user


    >
    >

--
    -----------------

    Randal Hale

    North River Geographic Systems, Inc

    http://www.northrivergeographic.com

    423.653.3611rjh...@northrivergeographic.com
    <mailto:rjh...@northrivergeographic.com>

    twitter:rjhale




    _______________________________________________
    Qgis-user mailing list
    Qgis-user@lists.osgeo.org
    List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
    Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user


--
------------------------------------------------
Randal Hale
North River Geographic Systems, Inc
http://www.northrivergeographic.com
423.653.3611 rjh...@northrivergeographic.com
twitter:rjhale     http://about.me/rjhale
http://www.northrivergeographic.com/introduction-to-quantum-gis
https://www.facebook.com/NRGSInc

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to