On Saturday, November 11, 2017 at 12:54:49 PM UTC, Yuraeitha wrote:
> On Saturday, November 11, 2017 at 12:23:28 PM UTC, JPL wrote:
> > For some reason the debian template didn't install when I installed Qubes, 
> > even though I selected it. No matter I thought, I'll do it manually.
> > 
> > However following the instructions here: 
> > 
> > https://www.qubes-os.org/doc/templates/debian/
> > 
> > namely: 
> > 
> > [user@dom0 ~]$ sudo qubes-dom0-update qubes-template-debian-8
> > 
> > I get "Nothing to do. Complete"
> > 
> > qvm-ls reveals that debian-8 is absent.
> > 
> > Is this instruction out of date or do I need to enable something first? Any 
> > tips appreciated.
> 
> The template re-install is currently broken, and requires fixing in a future 
> patch. I've had/seen mixed results with the plain template install too 
> (rather than re-install), so I suspect it's at least partly broken too? 
> Either way it's not you, this is something that likely needs patch fixing. 
> Possibly you can re-install Qubes and hope debian installs (sometimes work?, 
> see below), or you could try move debian from one of your 3.2. backup 
> archives, and then update it in Qubes 4 (hope for the best that the 3.2. 
> template Qubes tools won't get in the way). 
> 
> Also, in my own experience, I've installed Qubes 4 RC-2 on now 4-5 different 
> hardware machines, including various different CPU architecturs, from the 
> Intel i5 line, Intel M line, and Ryzen 3 1200. I've experienced different 
> results. 
> 
> For example, I never got debian working on my Intel i5 or Intel M 
> architectures, but for what seems like a paradoxial twist of fate, my Ryzen 
> architecture installs all templates perfectly fine, including debian-8. 
> Everything just work here. 
> 
> But on my Intel i5 or M processers, all which support minimum Qubes 4 specs 
> btw, and HVM works just fine, however debian-8 just doesn't work. 
> 
> I've had mixed results with Whonix-ws and Whonix-gw on the Intel 
> architectures too, however fedora worked mostly on all systems.
> 
> Frankly I do not know if its caused by different CPU archtectures, however, 
> from what I anecdotally experienced, it seems like what made the difference. 
> 
> Also if you encounter python errors during the very last stage of Qubes 4 
> install, immediately reinstall, no second thoughts. Apparently this happens 
> for no easy to observe reason too, but I'm able to make the last stage Qubes 
> configuration work properly by re-installing a few times, try different 
> settings, mess and push the system a little around, trial and error. 
> Eventually I got a clean install, with no last stage python errors. I do not 
> know exactly what made it work, or what caused it, except trial and error, 
> and trying different install settings, seemed to work.
> 
> Also seen install and system stability outcomes between legacy BIOS and UEFI, 
> however I did not test it extensively, nor can I confirm if it truly is so. 
> It's just something I took slight notice of, and in my case, legacy BIOS 
> seemed to fix my Ryzen system, which now runs Qubes templates flawlessly, 
> except for the missing CPU features in this kernel, but at least it works.
> 
> Hopefully you can use any of this, but as said, nothing conclusive. But 
> merely some experience and observation from many Qubes 4 RC-2 installs, on 
> various different hardware systems.

Thanks for the detailed reply. I have an i7 machine, installing to a USB stick. 
Strangely, last time I tried (this is my second installation on the same USB 
having borked the first) debian-8 *did* install so it's obviously a very quirky 
bug. Whonix installed OK although it seems very slow (everything, not just Tor 
browser). I don't see this issue reported on Github. Is it worth reporting or 
are Axon, Marek et al aware?  

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/872ab2ea-1d27-450a-90ac-239ed538b78c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to