On Wed, Sep 23, 2009 at 12:43 PM, John W. Long <m...@johnwlong.com> wrote: > On Sep 23, 2009, at 11:33 AM, Jim Gay wrote: >> >> I don't like the if/unless_blank tags when we could do this with >> if_content. >> >> . . . >> >> What would everyone think about adding this, but altering the default >> behavior so that if a page part is blank, it is considered not there. >> So <r:if_content part="my_part" allow_blank="false"> would be your use >> case to override and <r:if_content part="my_part"> would be the >> default where allow_blank is assumed to be true. > > The original intent behind if_content was the semantic "does this part > exist?"
That may be the case, but the name of the tag has caused confusion in my experience. My typical users (myself included) consider content to be text. > It's not meant to be something that checks for whitespace. if_blank > seems much more intention revealing (with that goal in mind). I'm not sure > that I see the need for both a new attribute on the if_content tag and a new > if_blank tag, so I favor just the if_blank tag. I don't see the need for both. I'm arguing that the default behavior for if_content be more reflective of it's name (checking for content), but allow that behavior to be changed to fall in line with it's historical behavior (checking for a page part). Adding an attribute adds some complexity, but adding a new tag certainly adds more. And my expectation would be that the use of the attribute would be rare. When I look at the names of them, my intuition would tell me that: if_content == unless_blank unless_content == if_blank But that's not at all how they would behave according to this discussion. _______________________________________________ Radiant mailing list Post: Radiant@radiantcms.org Search: http://radiantcms.org/mailing-list/search/ Site: http://lists.radiantcms.org/mailman/listinfo/radiant