On Tue, Sep 22, 2009 at 11:21 PM, Nate <pixeln...@gmail.com> wrote:
> Jim Gay wrote:
>>
>> I think this is a good idea. Possibly painful, but ultimately good.
>>
>> I'd like to broaden the discussion a bit and also suggest a change to
>> if_content so that it checks if content is not blank in a part, and
>> if_part which would check if the part exists. I think those names
>> would be more consistent with their features, much like the if_url and
>> if_path would be.
>>
>>
>
> I agree with this, as long as if_part could also check if it is blank or
> not.
>
>

Hmm. If it's going to go that way, I retract the suggestion. Why not
just add an attribute to if_content which checks the presence of text
then. <if_content part="my_part" blank="false|true">
And then inheritance would get tricky.

+1 for if_url and if_path changes

-- 
Jim Gay
http://www.saturnflyer.com
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to