Hmm... Ok, I think you may have it. I copied the jprofiler tree instead of installing it. I bet it adds itself to my LD_LIBRARY_PATH.

I tried removing the debug options already with no luck.

In any case, I'll try looking for a .so file tomorrow and if that doesn't fix it, I'll try the verbose option.


Knut Forkalsrud wrote:
Andrew Fritz wrote:
Regardless, I still get a "Could not find agent library on the library path or in the local directory: jprofilerti".

The profiler likely comes with a binary, a file whose name end in .so, at least for Linux.  For jprofilerti the file name would be I think.  Make sure that file is available to the dynamic loader by for example setting the environment variable LD_LIBRARY_PATH (Linux) or DYLD_LIBRARY_PATH (Mac if I remember correctly) or just copy it to ${resin.home}/libexec/ if you have such a directory.


PS: I still think removing -Xdebug is worth an attempt.  I had very similar symptoms and that change did the trick.

_______________________________________________ resin-interest mailing list

resin-interest mailing list

Reply via email to