>Has anyone else seen anything like this or know what might be causing

I can't help you but to add weight to this, I have a similar and frequent 
problem in 3.1.5 GPL which is an issue each time I restart the container.

I have a servlet mapped to the "root" of the Web server - i.e. it is 
supposed to execute just like a welcome page for:


I can't use the servlet-mapping of "/" since that's defined in Java EE as 
the "default servlet" and will execute for *every* request to an otherwise 
unmatched URL, which isn't what I want. I just want the servlet to handle 
requests for the root.

The "obvious" thing in Resin is to add a <servlet-mapping> with a 
url-regexp attribute:

<servlet-mapping url-regexp="^/?$" servlet-name="MyServlet" />

This worked for a while, until a restart. It then gave a 404 even after 
several reloads, restarts and a full stop and start. So I changed it to 
url-regexp="^/index.html$" which again worked, until another restart (weeks 
later) - I also couldn't then revert back to "^/?$" as the pattern as that 
still gave 404. Finally I'm left using "^/index.jsp$" as my pattern since 
that is what's working since the last restart. So definitely something 
weird going on with those index page mappings.

I am using Resin with mod_caucho for an Apache 2 front end. I imagine 
mod_caucho might be causing the issues with patterns still giving 404s even 
after a complete restart of Resin? I guess also mod_caucho may be the main 
culprit in all this, though that's a (far from educated) guess.


resin-interest mailing list

Reply via email to