Well that was easy :) Thanks for the quick help. Switching it to a fully qualified domain name and using /etc/hosts to catch it made everything work like a charm after the re-install.
So it sounds like the error message I thought might be coming from the Server actually was and I wasn't even stressing over the right field. doh Thanks again -wes On Jan 22, 12:52 am, Christian Hammond <[email protected]> wrote: > Django's URLField requires a fully-qualified domain (like foo.com), so if > you're using something likehttp://reviews/, it'll complain. I want to > change this at some point, since internal domains should be fine. Are you > using such a domain in that field? > > I imagine the media field is actually fine, and once you enter a URL that > the URLField is happy with, it should fix the double "/" in the media path. > > Christian > > -- > Christian Hammond - [email protected] > VMware, Inc. > > On Wed, Jan 21, 2009 at 9:45 PM, Wes Winham <[email protected]> wrote: > > > I'm not sure, but I might be having the same site media problem. I'm > > familiar with django, but not the way djiblets does the database > > settings stuff. > > > Basically, the MEDIA_URL isn't being set at all. I've tried setting it > > through the admin interface, but what I'd think would be the correct > > value of "/media/" (no quotes) throws up an "Enter a valid URL." error > > when I try and save it. All of the media is attempting to be pulled > > from urls likehttp://media/djblets/js/jquery-1.2.6.min.jsor > >http://media/rb/css/admin.css > > > I tried setting a MEDIA_URL in my settings_local, but it looks like > > it's over-ridden in settings.py anyway (and possible through whatever > > the djiblets stuff does that I don't fully understand). The more > > confusing part is that I can't get any value to stick in the media url > > field with the description- > > > > Media URL: > > > > The URL to the media files. Leave blank to use the default media path on > > this server. > > > I've tried: /, /media/,http://test.reviews/media/, /media and leaving > > it blank and I always get the "Enter a valid URL" message (which is > > placed above the Server field in reality, so maybe I'm just > > misunderstanding, but I can't get any valid values for that either). > > > Also, the default value for Media URL when I load > >http://test.reviews/admin/settings/general/is "//media/' despite the > > fact that I can't even resubmit the form to keep it as //media/ > > > I'm using the easy_install with 1.0alpha2.dev_20090121 > > > And yes, my media works fine if I just access it via something like > >http://test.reviews/media/djiblets > > > Any suggestions? > > > thanks > > -wes > > > On Jan 20, 5:05 am, "roshan pius" <[email protected]> wrote: > > > The Permissions have been set: > > > > drwxrwxrwx 3 www-data www-data 4096 Jan 19 20:05 . > > > drwxrwxrwx 5 www-data www-data 4096 Jan 19 20:05 .. > > > lrwxrwxrwx 1 www-data www-data 99 Jan 19 20:05 errordocs -> > > > /usr/local/lib/python2.6/site-packages/ReviewBoard-1.0alpha1-py2.6.egg/reviewboard/htdocs/errordocs > > > drwxrwxrwx 3 www-data www-data 4096 Jan 19 20:05media > > > > On Tue, Jan 20, 2009 at 3:24 PM, Christian Hammond <[email protected]> > > wrote: > > > > Okay, so you're getting a "Forbidden" error with this directory, but > > the > > > > HTML file for that is missing so it's sending a 404 instead. > > > > > What you're seeing is a config error on your server where Apache's user > > is > > > > unable to access yourmediadirectory. The user just doesn't have the > > > > permissions required. > > > > > Check to make sure your site's htdocs/mediadirectory (and everything > > else > > > > in htdocs/) has permissions set so that the Apache user can access it. > > > > > Christian > > > > > -- > > > > Christian Hammond - [email protected] > > > > VMware, Inc. > > > > > On Tue, Jan 20, 2009 at 1:46 AM, roshan pius < > > [email protected]> > > > > wrote: > > > > >> I added the line to vhosts.conf file > > > > >> "Options FollowSymLinks" > > > > >> When i tried accessing thehttp://135.254.219.50/media/-I got this > > > >> error on the browser > > > > >> Page not found (404) > > > >> Request Method: GET > > > >> Request URL: http://135.254.219.50/error/HTTP_FORBIDDEN.html.var > > > > >> Regards, > > > >> Roshan Pius > > > > >> On Tue, Jan 20, 2009 at 3:06 PM, Christian Hammond < > > [email protected]> > > > >> wrote: > > > >> > That file seems to have some issues. Perhaps the browser tried to > > > >> > normalize > > > >> > the file paths, but they end up looking like: > > > > >> > <SCRIPT type="text/javascript" src="./Dashboard Review Board > > > >> > administration_files/jquery-1.2.6.min.js"></SCRIPT> > > > > >> > There's also a bunch of custom HTML in there, and existing HTML > > that's > > > >> > modified. Definitely looks like the browser is doing it. > > > > >> > Can you look at the source for that file in your browser, find any > > > >> > <link> or > > > >> > <script> line, and paste it? > > > > >> > Also, what happens if you go tohttp://yoursite/media/?Do you get a > > > >> > 404, > > > >> > or a directory with "admin" and "rb" and "djblets" ? > > > > >> > Another thing that could potentially cause this is Apache being > > > >> > configured > > > >> > to block symlinks by default. Try to edit your Apache config and, in > > the > > > >> > <Location "/media"> section, add: > > > > >> > Options FollowSymLinks > > > > >> > This may fix it. > > > > >> > Christian > > > > >> > -- > > > >> > Christian Hammond - [email protected] > > > >> > VMware, Inc. > > > > >> > On Tue, Jan 20, 2009 at 1:17 AM, roshan pius > > > >> > <[email protected]> > > > >> > wrote: > > > > >> >> Hi , > > > > >> >> The post-review worked once i removed the old cookies file. > > > > >> >> <<< > > > >> >> > You may want to also try going tohttp://yoursite/admin/, logging > > in, > > > >> >> > clicking on "Settings", and then checking what the "MediaURL" is > > set > > > >> >> > to. It > > > >> >> > should be "/media/". If not, you can set this and then click > > "Save." > > > >> >> > It > > > >> >> > should all work even if the page styles aren't there. > > > > >> >> I already tried this and no luck. MymediaURL is already "/media/". > > > > >> >> I've attached the admin html page. i accessed using the url : > > > >> >>http://xxx.xxx.xxx.xxx/admin > > > > >> >> Thanks, > > > >> >> Roshan Pius > > > > >> >> On Tue, Jan 20, 2009 at 2:26 PM, Christian Hammond > > > >> >> <[email protected]> > > > >> >> wrote: > > > >> >> > Can you run post-review with -d and attach the debug log? > > > > >> >> > Is it just asking for a password over and over? If so, try > > deleting > > > >> >> > ~/.post-review-cookies.txt. > > > > >> >> > I'm imagining the problem is the site root ormediaroot. Can you > > > >> >> > attach > > > >> >> > the > > > >> >> > HTML file of any page on your install? It'll help me determine if > > > >> >> > this > > > >> >> > is > > > >> >> > the cause. If so, we can fix this pretty easily. > > > > >> >> > You may want to also try going tohttp://yoursite/admin/, logging > > in, > > > >> >> > clicking on "Settings", and then checking what the "MediaURL" is > > set > > > >> >> > to. It > > > >> >> > should be "/media/". If not, you can set this and then click > > "Save." > > > >> >> > It > > > >> >> > should all work even if the page styles aren't there. > > > > >> >> > Christian > > > > >> >> > -- > > > >> >> > Christian Hammond - [email protected] > > > >> >> > VMware, Inc. > > > > >> >> > On Tue, Jan 20, 2009 at 12:51 AM, roshan pius > > > >> >> > <[email protected]> > > > >> >> > wrote: > > > > >> >> >> Hi , > > > > >> >> >> I've run into major issues with post-review as well now. it is > > not > > > >> >> >> able to post the reviews as well. > > > >> >> >> It keeps retrying and retrying but fails. > > > > >> >> >> Thanks, > > > >> >> >> Roshan Pius > > > > >> >> >> On Tue, Jan 20, 2009 at 12:27 PM, roshan pius > > > >> >> >> <[email protected]> wrote: > > > >> >> >> > <VirtualHost *:80> > > > >> >> >> > ServerName xxx.xxx.com > > > >> >> >> > DocumentRoot /srv/www/htdocs/review-board-evros/htdocs > > > > >> >> >> > # Error handlers > > > >> >> >> > ErrorDocument 500 /errordocs/500.html > > > > >> >> >> > # Serve django pages > > > >> >> >> > <Location "/"> > > > >> >> >> > PythonPath > > > >> >> >> > "['/srv/www/htdocs/review-board-evros/conf'] + sys.path" > > > >> >> >> > SetEnv DJANGO_SETTINGS_MODULE > > reviewboard.settings > > > >> >> >> > SetHandler mod_python > > > >> >> >> > PythonHandler django.core.handlers.modpython > > > >> >> >> > PythonAutoReload Off > > > >> >> >> > PythonDebug Off > > > >> >> >> > # Used to run multiple mod_python sites in the > > same > > > >> >> >> > apache > > > >> >> >> > PythonInterpreter > > reviewboard_review-board-evros > > > >> >> >> > </Location> > > > > >> >> >> > # Serve staticmediawithout running it through > > mod_python > > > >> >> >> > # (overrides the above) > > > >> >> >> > <Location "/media"> > > > >> >> >> > SetHandler None > > > >> >> >> > </Location> > > > >> >> >> > <Location "/errordocs"> > > > >> >> >> > SetHandler None > > > >> >> >> > </Location> > > > > >> >> >> > # Alias staticmediarequests to filesystem > > > >> >> >> > Alias /media > > > >> >> >> > /srv/www/htdocs/review-board-evros/htdocs/media > > > >> >> >> > Alias /errordocs > > > >> >> >> > /srv/www/htdocs/review-board-evros/htdocs/errordocs > > > >> >> >> > </VirtualHost> > > > > >> >> >> > On Tue, Jan 20, 2009 at 12:20 PM, Christian Hammond > > > >> >> >> > <[email protected]> wrote: > > > > >> >> >> >> Hmm. If sounds like the site install went fine. Can you > > e-mail me > > > >> >> >> >> the > > > >> >> >> >> resulting Apache config and the HTML from any page on the > > site > > > >> >> >> >> (something generic like the login page would do). > > > > >> >> >> >> It's probably either the site root setting, or Apache is > > looking > > > >> >> >> >> in > > > >> >> >> >> the wrong place formediafiles. > > > > >> >> >> >> Christian > > > > >> >> >> >> On 1/19/09, roshan pius <[email protected]> wrote: > > ... > > read more » --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "reviewboard" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/reviewboard?hl=en -~----------~----~----~----~------~----~------~--~---
