I had a feeling Windows wasn't the target platform. I don't have much
choice since my evaluation has to be done on my workstation so I ended
up having to install a lot of things I wouldn't normally put on XP
machine. If we end up using Review Board, it'll go on our Linux
servers, which already has a lot of this stuff installed. I gotta say
though, an msi definitely would have been handy since it was a
nightmare figuring what versions of what I needed. I'm not really a
server guy so some of these things aren't intuitive for me.

I thought Patch might be a problem. When I first used post-review, it
complained that it didn't have the GNU diff. I had Patch installed and
it went into a directory called gnuwin32 so I figured that was it. I
doubled-checked the Path variable to make sure that directory was in
there but post-review still complained. Finally, I downloaded this GNU
diff, which wanted to go into that same gnuwin32 directory. I moved
Patch into its own directory and then installed the GNU diff. I also
updated the Path to include both directories. Post-review stopped
complaining but now the diff is generating that stacktrace.

OK, while writing this, I decided to try restarting the web server
since it wouldn't know about the changes to the Path. After the
restart, Review Board is indeed now complaining that Patch isn't
installed but I am 100% sure that it is installed and the correct path
is in the Path. And by 100% sure, I mean I copy & pasted the directory
location into the Path so there's no chance of a typo. The only
difference is that it's now in a directory called 'Patch' instead of
one called 'gnuwin32', which is where the GNU diff is now installed.
Both directories are in the Path, though. What am I missing?

On Jan 6, 2:47 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Hi Andrew,
> Looks like you're most likely missing patch.exe on the server, or it's
> not in the path. The installation guide for Windows should point to a
> suitable version.
> I'm sorry you had so many problems. Installation on Windows is not at
> all smooth. A large part of this is just that Review Board, and most
> of its dependencies, were really designed to be run on a Linux or
> other Posix platform.
> We've tried to get Review Board itself into shape and smooth out the
> docs to provide an easier install experience, but it definitely
> depends on how the system is configured and how the admin wants it
> configured. You'll see threads on here sometimes with various install
> problems on Windows, sometimes as a result of having Cygwin installed,
> or having some C-compiled Python module being built against MSVC vs.
> Mingw32... Lots of issues like that that are beyond our control, but
> impact us nonetheless.
> There was a project the past few months to create a Windows installer,
> which I'm planning to put into the 1.6 release. Doesn't help you now,
> certainly, but we are trying to get to a point where it's not so much
> a pain.
> What I generally recommend to people is that they try to get an
> install going on Linux. You will be astounded by how much easier it is
> to get going, particularly on a modern Fedora or Ubuntu. If you're
> largely a Windows shop, you could consider using a VM (VMware Server
> 2.0 is free and works fine for that).
> Christian
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
> On Thu, Jan 6, 2011 at 12:34 PM, Andrew Leppke <alep...@hotmail.com> wrote:
> > I'm trying to determine if Review Board is right for our company and
> > so far, I've had nothing but problems. I ran into numerous
> > installation problems because I couldn't figure out which versions of
> > what I needed to use. But I solved all that. At least, I think I've
> > solved all that since the server is up and running.
> > My latest problem occurred when I attempted to create my first review.
> > I used post-review to create and upload a diff. Everything looked like
> > it had worked from the command line as I got the following output:
> > C:\workspaces\test\src\test>post-review -o
> > ==> Review Board Login Required
> > Enter username and password for Review Board athttp://localhost/reviews/
> > Username: leppke
> > Password:
> > Review request #2 posted.
> >http://localhost/reviews/r/2
> > As expected, it opened a browser to the review and sure enough, it was
> > there. I click on the View Diff tab and am treated to this wonderful
> > stacktrace:
> > [Error 2] The system cannot find the file specified
> > Traceback (most recent call last):
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\views.py", line 153, in view_diff
> >    interdiffset, highlighting, True)
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 1063, in get_diff_files
> >    large_data=True)
> >  File "c:\python25\lib\site-packages\Djblets-0.6.6-py2.5.egg\djblets
> > \util\misc.py", line 166, in cache_memoize
> >    data = lookup_callable()
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 1062, in <lambda>
> >    enable_syntax_highlighting)),
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 549, in get_chunks
> >    new = get_patched_file(old, filediff)
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 374, in get_patched_file
> >    return patch(filediff.diff, buffer, filediff.dest_file)
> >  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 222, in patch
> >    stderr=subprocess.STDOUT)
> >  File "C:\Python25\lib\subprocess.py", line 594, in __init__
> >    errread, errwrite)
> >  File "C:\Python25\lib\subprocess.py", line 822, in _execute_child
> >    startupinfo)
> > WindowsError: [Error 2] The system cannot find the file specified
> > From what I can tell, it threw a FileNotFound exception when trying to
> > create the diff but it doesn't say which file it was trying to find.
> > Anyone have any suggestions?
> > --
> > Want to help the Review Board project? Donate today 
> > athttp://www.reviewboard.org/donate/
> > Happy user? Let us know athttp://www.reviewboard.org/users/
> > -~----------~----~----~----~------~----~------~--~---
> > To unsubscribe from this group, send email to 
> > reviewboard+unsubscr...@googlegroups.com
> > For more options, visit this group 
> > athttp://groups.google.com/group/reviewboard?hl=en

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to