I'm trying to determine if Review Board is right for our company and
so far, I've had nothing but problems. I ran into numerous
installation problems because I couldn't figure out which versions of
what I needed to use. But I solved all that. At least, I think I've
solved all that since the server is up and running.

My latest problem occurred when I attempted to create my first review.
I used post-review to create and upload a diff. Everything looked like
it had worked from the command line as I got the following output:

C:\workspaces\test\src\test>post-review -o
==> Review Board Login Required
Enter username and password for Review Board at http://localhost/reviews/
Username: leppke
Password:
Review request #2 posted.

http://localhost/reviews/r/2

As expected, it opened a browser to the review and sure enough, it was
there. I click on the View Diff tab and am treated to this wonderful
stacktrace:

[Error 2] The system cannot find the file specified

Traceback (most recent call last):
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\views.py", line 153, in view_diff
    interdiffset, highlighting, True)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\diffutils.py", line 1063, in get_diff_files
    large_data=True)
  File "c:\python25\lib\site-packages\Djblets-0.6.6-py2.5.egg\djblets
\util\misc.py", line 166, in cache_memoize
    data = lookup_callable()
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\diffutils.py", line 1062, in <lambda>
    enable_syntax_highlighting)),
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\diffutils.py", line 549, in get_chunks
    new = get_patched_file(old, filediff)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\diffutils.py", line 374, in get_patched_file
    return patch(filediff.diff, buffer, filediff.dest_file)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\diffutils.py", line 222, in patch
    stderr=subprocess.STDOUT)
  File "C:\Python25\lib\subprocess.py", line 594, in __init__
    errread, errwrite)
  File "C:\Python25\lib\subprocess.py", line 822, in _execute_child
    startupinfo)
WindowsError: [Error 2] The system cannot find the file specified


>From what I can tell, it threw a FileNotFound exception when trying to
create the diff but it doesn't say which file it was trying to find.
Anyone have any suggestions?

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to