Forgot to mention, I repaired the DB on command line like :

$ myisamchk -r diffviewer_diffsethistory
- recovering (with sort) MyISAM-table 'diffviewer_diffsethistory'
Data records: 514068
- Fixing index 1
Data records: 514067

On Friday, November 8, 2013 11:45:59 PM UTC-8, humble wrote:
> OK, I got the final piece of puzzle resolved. Put my solutions here for 
> next poor guy in the future. Note, what worked for me doesn't necessary 
> mean it will work for you. Take snapshot of your DB before doing it!!
> Go back to my last error in last reply. It was complaining one DB was 
> crashed, and in fact when I click on "view diff" on the RB UI, I see a 
> stacktrace like:
> .....
> DatabaseError at /r/513130/diff/ 
> (1054, "Unknown column 'diffviewer_diffsethistory.last_diff_updated' in 
> 'field list'")
> ....
> so I decided to add that column myself according to the output from 
> --hint. I then ran django's syncdb command (yes, not via RB's 
> wrapper). 
> $ sudo syncdb
> Creating tables ...
> There are unapplied evolutions for auth.
> The following content types are stale and need to be deleted:
>     auth | message
> Any objects related to these content types by a foreign key will also
> be deleted. Are you sure you want to delete these content types?
> If you're unsure, answer 'no'.
>     Type 'yes' to continue, or 'no' to cancel: yes
> There are unapplied evolutions for accounts.
> There are unapplied evolutions for diffviewer.
> There are unapplied evolutions for reviews.
> Project signature has changed - an evolution is required
> Installing custom SQL ...
> Installing indexes ...
> Installed 0 object(s) from 0 fixture(s)
> Finally, I ran again. It worked.

Get the Review Board Power Pack at
Sign up for Review Board hosting at RBCommons:
Happy user? Let us know at
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to