the "Abort: repository .. is not local" message is one you get when trying 
to run local-only commands
on remote repositories, such as 'hg cat' or 'hg log'. Looking why I'm 
getting similar failures as Jimmy
describes in his first email here, this is what hg.py is doing - calling 
'hg cat' on a remote repo.
Here's the relevant debug log (adding the command debug to hg.py) 
[ReviewBoard 1.7.22]:

2014-03-06 13:14:17,557 - DEBUG -  - ['hg', '--noninteractive', 
'--repository', u'ssh://USER@HOST/PATH_redacted', '--cwd', 
u'ssh://USER@HOST/PATH_redacted', 'showconfig', 'ui.ssh']
2014-03-06 13:14:17,606 - DEBUG -  - Using rbssh for mercurial:
2014-03-06 13:14:17,606 - DEBUG -  - ['hg', '--noninteractive', 
'--repository', u'ssh://USER@HOST/PATH_redacted', '--cwd', 
u'ssh://USER@HOST/PATH_redacted', '--config', 'ui.ssh=rbssh', 'cat', 
'--rev', 'REV_redacted', 'FILE_PATH_redacted']



On Tuesday, 11 June 2013 16:08:57 UTC+2, jimmy jiang wrote:
> Hi, Christian,
> For the above error of ""Abort: repository 'ssh://
> hg@' is not local"", i did below change for 
> this issue:
> in ./reviewboard/scmtool/hg.py, calss HgClient, __init__(self, repoPath, 
> local_site),
> change self.repo = hg.repository (hg_ui, path+repoPath)
> to => self.repo = hg.peer (hg_ui, {}, path=repoPath)
> After this, i got the same error point ('sshpeer' object has no attribute 
> 'changectx'.) as before, it means the same error happen after i upgraded 
> mercurial from v2.2.2 to v2.6.1.
> Thanks for your support.
> BR
> Jimmy
> 2013/5/31 jimmy jiang <jimmy....@gmail.com <javascript:>>
>> Hi. Christian,
>> I updated the mercurial to latest v2.6.1. but new error happened,
>> It is "Abort: repository 'ssh://hg@' is not 
>> local" , which is the earlier to the original error.
>> The reviewboard.log attached, please help to check, thanks.
>> BR
>> Jimmy.

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to