Hi, Christian,

For the above error of ""Abort: repository 'ssh://
hg@' is not local"", i did below change for this
in ./reviewboard/scmtool/hg.py, calss HgClient, __init__(self, repoPath,
change self.repo = hg.repository (hg_ui, path+repoPath)
to => self.repo = hg.peer (hg_ui, {}, path=repoPath)

After this, i got the same error point ('sshpeer' object has no attribute '
changectx'.) as before, it means the same error happen after i upgraded
mercurial from v2.2.2 to v2.6.1.

Thanks for your support.


2013/5/31 jimmy jiang <jimmy.a.ji...@gmail.com>

> Hi. Christian,
> I updated the mercurial to latest v2.6.1. but new error happened,
> It is "Abort: repository 'ssh://hg@' is not
> local" , which is the earlier to the original error.
> The reviewboard.log attached, please help to check, thanks.
> BR
> Jimmy.

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to