Steve,

It's pretty hard for us to do support for post-review, since it's
completely obsolete (and 0.5.2 is pretty old). That said, can you give us
the output of running post-review with --debug in a case where this problem
is showing up?

BTW, why are you planning to upgrade to 0.6.3 instead of 0.7.3?

-David

On Mon, Jun 8, 2015 at 9:36 AM Steve <seide.al...@gmail.com> wrote:

> I forgot to mention that I restarted memcached on the servers too, but the
> problem persists.
>
> --steve
>
>
> On Monday, June 8, 2015 at 9:28:21 AM UTC-7, Steve wrote:
>>
>> We changed our DNS entry for our perforce server over the weekend which
>> required me to change our port settings in ReviewBoard.  I edited the repo
>> setting in the RB admin console and changed the name an path like this:
>>
>> # Old
>> Name: oldname:1666
>> Path:   oldname:1666
>>
>> # New
>> Name: perforce:1666
>> Path:   perforce:1666
>>
>> The string 'perforce:1666'  is what is returned by 'p4 info' as the
>> 'Server address'.  This works fine in the sense that all the old reviews
>> show the new perforce port string and the diffs are being properly
>> displayed.  The problem occurs when we try to update a review that was
>> created prior to the DNS change using post-review.  Instead of updating the
>> old review, it creates a new one.  I've told my users they can get around
>> this for the old reviews by adding the -r option to specify the review
>> board id, but I'd like to understand what I may have done wrong.
>>
>> We are currently using RBTools 0.5.2 and post-review, but we're planning
>> to upgrade soon to 0.6.3 and rbt.  Our RB version is 1.7.28.  I'll try to
>> test with the new RBTools, but I have a limited amount of old reviews that
>> I can play with.
>>
>>
>> Thanks
>>
>> --Steve
>>
>>  --
> Supercharge your Review Board with Power Pack:
> https://www.reviewboard.org/powerpack/
> Want us to host Review Board for you? Check out RBCommons:
> https://rbcommons.com/
> Happy user? Let us know! https://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to