[edk2] [PATCH 2/2] ShellPkg/mkdir: support creating nested directories

2017-08-15 Thread Ruiyu Ni
From: Huajing Li Contributed-under: TianoCore Contribution Agreement 1.0 Signed-off-by: Huajing Li Reviewed-by: Ruiyu Ni --- .../Library/UefiShellLevel2CommandsLib/MkDir.c | 54 ++ 1 file changed, 46

[edk2] [PATCH 1/2] Shell/mkdir: Modify the help content to align to spec.

2017-08-15 Thread Ruiyu Ni
From: Huajing Li Contributed-under: TianoCore Contribution Agreement 1.0 Signed-off-by: Huajing Li Reviewed-by: Ruiyu Ni --- .../UefiShellLevel2CommandsLib.uni| 15 ++- 1 file changed, 6

[edk2] [PATCH 0/2] ShellPkg/mkdir Support creating nested directories

2017-08-15 Thread Ruiyu Ni
Huajing Li (2): Shell/mkdir: Modify the help content to align to spec. ShellPkg/mkdir: support creating nested directories .../Library/UefiShellLevel2CommandsLib/MkDir.c | 54 ++ .../UefiShellLevel2CommandsLib.uni | 15 +++--- 2 files changed, 52

[edk2] [Patch v4] UefiCpuPkg RegisterCpuFeaturesLib: Fix buffer pointer error usage.

2017-08-15 Thread Eric Dong
Current code allocate buffer for the pointer which later get value from PCD database. but current code error use "=" for this case. Use AllocateCopyPool instead to fix it. V2 enhanced to directly use AllocateCopyPool to get the PCD value. V3 enhanced to avoid using local temp variable. V4

[edk2] [PATCH v2 2/3] MdeModulePkg/DisplayEngine: Add implementation of HiiPopup protocol

2017-08-15 Thread Dandan Bi
V2: Addstring "ERROR", "WARNING", "INFO" at the top of the message box to implement the different appearances for different styles of Popup. Add the implementation of HiiPopup protocol in DisplayEngineDxe, since DisplayEngineDxe is responsible for drawing tasks. Cc: Eric Dong

[edk2] [PATCH v2 0/3] Add HII Popup Protocol

2017-08-15 Thread Dandan Bi
Patch 1: Add the definition of HII Popup Protocol. Patch 2: Add the implementation of HII Popup Protocol. Patch 3: Add one sample use case of HII Popup Protocol. V2: Updates in pacth 2: Addstring "ERROR", "WARNING", "INFO" at the top of the message box to implement the different appearances for

[edk2] [PATCH v2 1/3] MdePkg/HiiPopup: Add HII Popup Protocol definitions

2017-08-15 Thread Dandan Bi
Add definitions for HII Popup Protocol according to UEFI2.7. Cc: Eric Dong Cc: Liming Gao Contributed-under: TianoCore Contribution Agreement 1.0 Signed-off-by: Dandan Bi --- MdePkg/Include/Protocol/HiiPopup.h | 81

[edk2] [PATCH v2 3/3] MdeModulePkg/DriverSample: Add sample case for popup protocol

2017-08-15 Thread Dandan Bi
V2: Update the date info in the Copyright. Add one sample case about how to use HiiPopup protocol to draw message box. Cc: Eric Dong Cc: Liming Gao Contributed-under: TianoCore Contribution Agreement 1.0 Signed-off-by: Dandan Bi

Re: [edk2] [Patch] UefiCpuPkg RegisterCpuFeaturesLib: Fix buffer pointer error usage.

2017-08-15 Thread Kinney, Michael D
Hi Eric, I think we should keep the Getxxx() functions to make the code easier to read and we have matched Get/Set functions to access these PCDs. Mike > -Original Message- > From: Dong, Eric > Sent: Tuesday, August 15, 2017 6:04 PM > To: edk2-devel@lists.01.org > Cc: Ni, Ruiyu

Re: [edk2] [PATCH] MdeModulePkg SerialDxe: Process timeout consistently in SerialRead

2017-08-15 Thread Zeng, Star
*Control = 0; if (!SerialPortPoll ()) { *Control = EFI_SERIAL_INPUT_BUFFER_EMPTY; } return RETURN_SUCCESS; As example, the code above (in OvmfPkg\Library\XenConsoleSerialPortLib\XenConsoleSerialPortLib.c) can be simply used in SerialPortGetControl(). Thanks, Star -Original

Re: [edk2] [PATCH] MdeModulePkg SerialDxe: Process timeout consistently in SerialRead

2017-08-15 Thread Laszlo Ersek
On 08/16/17 01:59, Kinney, Michael D wrote: > Laszlo, > > gBS->Stall() layers on top of the Metronome Architectural Protocol. > > armvirtqemu.dsc: EmbeddedPkg/MetronomeDxe/MetronomeDxe.inf > > And this implementation layers on top of a TimerLib > > armvirtqemu.dsc:

[edk2] [Patch][edk2-platforms/devel-MinnowBoard3-UDK2017] Add Source Level Debug

2017-08-15 Thread zwei4
Contributed-under: TianoCore Contribution Agreement 1.1 Signed-off-by: zwei4 --- Platform/BroxtonPlatformPkg/BuildBios.sh | 1 - .../FspmWrapperPeim/FspmWrapperPeim.inf| 3 --- .../PlatformDsc/Components.IA32.dsc| 2 ++

Re: [edk2] [PATCH V2] edk2: Fix typo in Contributions.txt

2017-08-15 Thread Kinney, Michael D
Reviewed-by: Michael D Kinney > -Original Message- > From: Zeng, Star > Sent: Tuesday, August 15, 2017 6:17 PM > To: edk2-devel@lists.01.org > Cc: Zeng, Star ; Kinney, Michael D > > Subject: [PATCH V2] edk2:

[edk2] [PATCH V2] edk2: Fix typo in Contributions.txt

2017-08-15 Thread Star Zeng
V2: Use "license" instead of "BSD License" V1: Use "FreeBSD" instead of "BSD" Cc: Michael D Kinney Contributed-under: TianoCore Contribution Agreement 1.1 Signed-off-by: Star Zeng --- Contributions.txt | 2 +- 1 file changed, 1 insertion(+), 1

[edk2] [Patch] UefiCpuPkg RegisterCpuFeaturesLib: Fix buffer pointer error usage.

2017-08-15 Thread Eric Dong
Current code allocate buffer for the pointer which later get value from PCD database. but current code error use "=" for this case. Use AllocateCopyPool instead to fix it. V2 enhanced to directly use AllocateCopyPool to get the PCD value. V3 enhanced to avoid using local temp variable. Cc: Ruiyu

Re: [edk2] [PATCH] edk2: Fix typo in Contributions.txt

2017-08-15 Thread Kinney, Michael D
Star, Do not change to the source code paragraph. Only change the documentation one and use "license" not "License". Mike > -Original Message- > From: Zeng, Star > Sent: Tuesday, August 15, 2017 5:39 PM > To: Kinney, Michael D ; edk2- > de...@lists.01.org >

Re: [edk2] [PATCH v2 05/23] OvmfPkg/Virtio: fix comment style

2017-08-15 Thread Laszlo Ersek
On 08/14/17 13:36, Brijesh Singh wrote: > Cc: Ard Biesheuvel > Cc: Jordan Justen > Cc: Tom Lendacky > Cc: Laszlo Ersek > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by:

Re: [edk2] [PATCH] edk2: Fix typo in Contributions.txt

2017-08-15 Thread Zeng, Star
Mike, Follow your recommendation. "A copy of the BSD License is available at" also need to be "A copy of the license is available at", right? 145215034bc3765a4cc69a9b7494e956e6e0136c Contributions.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Contributions.txt

Re: [edk2] [PATCH v2 04/23] OvmfPkg/VirtioMmioDeviceLib: add missing IN and OUT decoration

2017-08-15 Thread Laszlo Ersek
On 08/14/17 13:36, Brijesh Singh wrote: > Cc: Ard Biesheuvel > Cc: Jordan Justen > Cc: Tom Lendacky > Cc: Laszlo Ersek > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by:

Re: [edk2] [PATCH v2 03/23] OvmfPkg/VirtioPciDeviceDxe: add missing IN and OUT decoration

2017-08-15 Thread Laszlo Ersek
On 08/14/17 13:36, Brijesh Singh wrote: > Cc: Ard Biesheuvel > Cc: Jordan Justen > Cc: Tom Lendacky > Cc: Laszlo Ersek > Contributed-under: TianoCore Contribution Agreement 1.1 > Signed-off-by:

Re: [edk2] [PATCH] MdeModulePkg SerialDxe: Process timeout consistently in SerialRead

2017-08-15 Thread Kinney, Michael D
Laszlo, gBS->Stall() layers on top of the Metronome Architectural Protocol. armvirtqemu.dsc: EmbeddedPkg/MetronomeDxe/MetronomeDxe.inf And this implementation layers on top of a TimerLib armvirtqemu.dsc: TimerLib|ArmPkg/Library/ArmArchTimerLib/ArmArchTimerLib.inf There are a couple PCDs

Re: [edk2] [PATCH] edk2: Fix typo in Contributions.txt

2017-08-15 Thread Kinney, Michael D
Star, I recommend changing the sentence to: "A copy of the license is available at" Mike > -Original Message- > From: Zeng, Star > Sent: Monday, August 14, 2017 6:54 AM > To: edk2-devel@lists.01.org > Cc: Zeng, Star ; Kinney, Michael D >

Re: [edk2] [PATCH] MdeModulePkg SerialDxe: Process timeout consistently in SerialRead

2017-08-15 Thread Laszlo Ersek
Hi Star, On 08/04/17 10:29, Star Zeng wrote: > https://lists.01.org/pipermail/edk2-devel/2017-July/012385.html > reported the timeout processing in SerialRead is not consistent. > > Since SerialPortPoll only checks the status of serial port and > returns immediately, and SerialPortRead does not

Re: [edk2] [PATCH v2 1/1] OvmfPkg/build.sh: select the GCC49 toolchain settings for gcc-7.*

2017-08-15 Thread Jordan Justen
Reviewed-by: Jordan Justen On 2017-08-15 10:09:14, Laszlo Ersek wrote: > When UefiCpuPkg/MpInitLib is built for X64 with gcc-7, using the DEBUG > build target and the GCC5 toolchain settings, a C-language assignment is > miscompiled such that the initial AP startup

Re: [edk2] [PATCH v1 00/14] OvmfPkg/Virtio: Add APIs to map system physical to device address

2017-08-15 Thread Laszlo Ersek
On 08/15/17 22:44, Brijesh Singh wrote: > > > On 08/15/2017 03:39 PM, Laszlo Ersek wrote: >> On 08/15/17 22:26, Brijesh Singh wrote: >>> >>> >>> On 08/15/2017 02:48 PM, Laszlo Ersek wrote: On 08/15/17 21:32, Brijesh Singh wrote: > Hi Laszlo, > > On 08/15/2017 05:42 AM, Laszlo

[edk2] [edk2-staging/edk2-test Patch V3] Test*Pkg: Replace POSTBUILD batch files with a python script

2017-08-15 Thread Michael D Kinney
Update the POSTBUILD step to use a python script to create and/or update the installer for the test framework and test cases. This expands the OS compatibility to include Windows, Linux, and Mac OS X. The python script TestFrameworkPkg/GenFramework.py is used by the TestFrameworkPkg to generate

Re: [edk2] [PATCH v1 00/14] OvmfPkg/Virtio: Add APIs to map system physical to device address

2017-08-15 Thread Brijesh Singh
On 08/15/2017 03:39 PM, Laszlo Ersek wrote: On 08/15/17 22:26, Brijesh Singh wrote: On 08/15/2017 02:48 PM, Laszlo Ersek wrote: On 08/15/17 21:32, Brijesh Singh wrote: Hi Laszlo, On 08/15/2017 05:42 AM, Laszlo Ersek wrote: [snip] I have been following the steps from

Re: [edk2] [PATCH v1 00/14] OvmfPkg/Virtio: Add APIs to map system physical to device address

2017-08-15 Thread Laszlo Ersek
On 08/15/17 22:26, Brijesh Singh wrote: > > > On 08/15/2017 02:48 PM, Laszlo Ersek wrote: >> On 08/15/17 21:32, Brijesh Singh wrote: >>> Hi Laszlo, >>> >>> On 08/15/2017 05:42 AM, Laszlo Ersek wrote: >>> [snip] >>> > > I have been following the steps from >

Re: [edk2] [PATCH v1 00/14] OvmfPkg/Virtio: Add APIs to map system physical to device address

2017-08-15 Thread Brijesh Singh
On 08/15/2017 02:48 PM, Laszlo Ersek wrote: On 08/15/17 21:32, Brijesh Singh wrote: Hi Laszlo, On 08/15/2017 05:42 AM, Laszlo Ersek wrote: [snip] I have been following the steps from https://wiki.linaro.org/LEG/UEFIforQEMU qemu-system-aarch64 \ -m 1024 \ -cpu cortex-a57 \ -M

[edk2] [PATCH v2 1/1] OvmfPkg/build.sh: select the GCC49 toolchain settings for gcc-7.*

2017-08-15 Thread Laszlo Ersek
When UefiCpuPkg/MpInitLib is built for X64 with gcc-7, using the DEBUG build target and the GCC5 toolchain settings, a C-language assignment is miscompiled such that the initial AP startup hangs in CpuMpPei (X64) or CpuDxe (Ia32X64). See for a

Re: [edk2] [edk2-CCodingStandardsSpecification PATCH 0/2] improvements related to line wrapping

2017-08-15 Thread Laszlo Ersek
On 08/15/17 17:17, Kinney, Michael D wrote: > Laszlo, > > If you only change a couple of words in a sentence, it will > show the differences at the work level instead of the line > level. This crossed my mind, but when I compared the two views, I saw the word-level highlighting (on top of the

Re: [edk2] [Patch v2] UefiCpuPkg RegisterCpuFeaturesLib: Fix buffer pointer error usage.

2017-08-15 Thread Kinney, Michael D
Eric, You can eliminate the BitMaskSize local if you use the following: SupportBitMask = AllocateCopyPool ( PcdGetSize (PcdCpuFeaturesSupport), (UINT8 *) PcdGetPtr (PcdCpuFeaturesSupport) ); Mike > -Original Message- >

Re: [edk2] [edk2-CCodingStandardsSpecification PATCH 0/2] improvements related to line wrapping

2017-08-15 Thread Kinney, Michael D
Laszlo, If you only change a couple of words in a sentence, it will show the differences at the work level instead of the line level. If you add/remove entire paragraphs, then you will not see any differences. I am just in the habit of always adding ?w=1 to provide the best possible review

Re: [edk2] [edk2-CCodingStandardsSpecification PATCH 2/2] Source Files / Spacing / Multi-line func. calls: allow condensed arguments

2017-08-15 Thread Laszlo Ersek
On 08/12/17 12:13, Leif Lindholm wrote: > On Fri, Aug 11, 2017 at 01:45:12PM -0700, Jordan Justen wrote: >>> +Use this line breaking style especially if it saves a format string or >>> complex >>> +argument from being split, or when commenting on individual arguments. >>> + >>> +# 5.2.2.4.2

Re: [edk2] [PATCH v1 00/14] OvmfPkg/Virtio: Add APIs to map system physical to device address

2017-08-15 Thread Laszlo Ersek
On 08/12/17 00:22, Brijesh Singh wrote: > > > On 08/09/2017 12:56 PM, Laszlo Ersek wrote: > >>> >>> Sure, I will make the necessary changes in VirtioMmioDeviceLib and try >>> do the build test but I don't have aarch64 platform to verify at the >>> runtime. >> >> Actually, dependent on your

Re: [edk2] [Patch] Nt32/PlatformBootManagerLib: Enable STD_ERROR on all consoles

2017-08-15 Thread Wang, Sunny (HPS SW)
Reviewed and tested it. Looks good to me. Thanks for addressing my offline comment, Michael. :) Reviewed-by: Sunny Wang Regards, Sunny Wang -Original Message- From: edk2-devel [mailto:edk2-devel-boun...@lists.01.org] On Behalf Of Michael D Kinney Sent: Tuesday,

[edk2] [Patch v2] UefiCpuPkg RegisterCpuFeaturesLib: Fix buffer pointer error usage.

2017-08-15 Thread Eric Dong
Current code allocate buffer for the pointer which later get value from PCD database. but current code error use "=" for this case. Use AllocateCopyPool instead to fix it. V2 enhanced to directly use AllocateCopyPool to get the PCD value. Cc: Ruiyu Ni Cc: Shao Ming