[gwt-contrib] Re: Comment on DomEventsAndMemoryLeaks in google-web-toolkit

2010-03-19 Thread codesite-noreply
Comment by GlacieredPyro: Thanks for the response, I see now that only by running IE in no addon mode will stop the memory from growing, in fact it doesnt get near 30MB. Not that my normal IE installation has anything but the default addons but they seem to make the most trivial application

[gwt-contrib] Re: Tweaks to eclipse instructions (issue242801)

2010-03-19 Thread jlabanca
LGTM http://gwt-code-reviews.appspot.com/242801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the words REMOVE ME as the subject.

Re: [gwt-contrib] Re: RR : Soft permutations (issue160801)

2010-03-19 Thread Lex Spoon
On Thu, Mar 18, 2010 at 7:38 PM, John Tamplin j...@google.com wrote: On Thu, Mar 18, 2010 at 7:25 PM, sp...@google.com wrote: The main issue is that I don't believe that sharded builds will take full advantage of the collapsing. We need for Precompile to emit the number of *collapsed*

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Miguel Méndez
I'm not advocating that you save up for one large patch at the end. You should have the code reviewed in increments as you are planning on doing. All I'm suggesting is that the code not land in trunk/user/... until is ready. A real branch or bikeshed would be a better place. On Thu, Mar 18,

[gwt-contrib] Re: While paving the way to ValueStore, I've greatly simplified (issue243801)

2010-03-19 Thread amitmanjhi
EntityKey.java seems to be missing from the patch On 2010/03/19 07:52:39, Ray Ryan wrote: http://gwt-code-reviews.appspot.com/243801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Rodrigo Chandia
Yes. I like your idea. I'll move the development to bikeshed so nobody thinks this is ready for general consumption. Once the classes are in a good enough state we will migrate (move) things into GWT proper. Afterwards, integration of these classes into GWT (aka using them for interesting things)

[gwt-contrib] Re: Multiple inheritance in Widget hierarchy

2010-03-19 Thread jd
Thanks for all the responses guys. So far it hasn't been so difficult to change the hierarchy of the elements I need. I was mainly just curious as to why such a setup existed - quite an ingenious solution to your problem! Ajax crawling looks very cool indeed but I suspect my site will have too

[gwt-contrib] [google-web-toolkit] r7748 committed - Checkpoint tree/list stuff:...

2010-03-19 Thread codesite-noreply
Revision: 7748 Author: r...@google.com Date: Fri Mar 19 07:22:04 2010 Log: Checkpoint tree/list stuff: No more DataSource interface Added maxSize/increment to SimpleCellList constructor (not fully functional) Fix tree node size 0 bug

[gwt-contrib] DockLayoutPanel addLayoutCompleteHandler

2010-03-19 Thread jd
Hi, I use DockLayoutPanel with Google maps and there is a known issue where any component inside a DockLayoutPanel that depends on the size of its container must be initialized like this: root.animate(0, new AnimationCallback() { public void onLayout(Layer layer, double progress) { }

[gwt-contrib] ClientBundle produce memory leaks in IE6

2010-03-19 Thread AdrienA
Hello, I find out a problem with the using of ClientBundle wich produce memory leaks in IE6. To proove that, I have realised a very simple application (you can find the source code at this address :

[gwt-contrib] Re: While paving the way to ValueStore, I've greatly simplified (issue243801)

2010-03-19 Thread rjrjr
http://gwt-code-reviews.appspot.com/243801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the words REMOVE ME as the subject.

[gwt-contrib] Re: While paving the way to ValueStore, I've greatly simplified (issue243801)

2010-03-19 Thread rjrjr
From desk review w/Amit. Will do this and some other cleanup and then submit: Revert Places.java Maybe todo valuestore in EmployeeListRequest as not-used-yet Try to back out ValueStore changes since they do nothing yet http://gwt-code-reviews.appspot.com/243801/diff/6001/7001 File

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Ray Ryan
Great. When you move them to trunk/bikeshed, please *don't* put them under the com.google.gwt.bikeshed package. We've concluded that was a mistake and will be rejiggering it slightly. Your stuff should stay in its real packages. On Fri, Mar 19, 2010 at 9:57 AM, Rodrigo Chandia

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Rodrigo Chandia
You just told me right in time (talking to myself: how was incantation to revert the last git commit?) Just to make sure. The classes should go into: bikeshed/src/com/google/gwt/collections/client/ bikeshed/test/com/google/gwt/collections/client/ Or would it be better to do a new project under

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Ray Ryan
I think bikeshed/{src,test}/com/google/gwt/collections/client/ is just right. Be warned, btw, that we have no ant test target in the build.xml there yet. Patches welcome ;-) On Fri, Mar 19, 2010 at 12:15 PM, Rodrigo Chandia rchan...@google.comwrote: You just told me right in time (talking to

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Rodrigo Chandia
Sure! 2010/3/19 Ray Ryan rj...@google.com I think bikeshed/{src,test}/com/google/gwt/collections/client/ is just right. Be warned, btw, that we have no ant test target in the build.xml there yet. Patches welcome ;-) On Fri, Mar 19, 2010 at 12:15 PM, Rodrigo Chandia

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Bruce Johnson
re: package...consider skipping the client convention because it's meant to be used on the server too. that new form of target-less naming is part of the design experiment I hope this work can include. On Friday, March 19, 2010, Rodrigo Chandia rchan...@google.com wrote: Sure! 2010/3/19 Ray

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread John Tamplin
On Fri, Mar 19, 2010 at 4:05 PM, Bruce Johnson br...@google.com wrote: re: package...consider skipping the client convention because it's meant to be used on the server too. that new form of target-less naming is part of the design experiment I hope this work can include. The convention in

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Rodrigo Chandia
I guess we could use a supersource trick to swap in the JS-optimized ones 2010/3/19 John Tamplin j...@google.com On Fri, Mar 19, 2010 at 4:05 PM, Bruce Johnson br...@google.com wrote: re: package...consider skipping the client convention because it's meant to be used on the server too. that

[gwt-contrib] Re: While paving the way to ValueStore, I've greatly simplified (issue243801)

2010-03-19 Thread rjrjr
Revert Places.java * Done Maybe todo valuestore in EmployeeListRequest as not-used-yet * Done Backed out ValueStore changes Rietveld is lying about a few things, e.g.: the Filter and Visitor classes are no longer deleted. Committing.

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread John Tamplin
On Fri, Mar 19, 2010 at 4:21 PM, Rodrigo Chandia rchan...@google.comwrote: I guess we could use a supersource trick to swap in the JS-optimized ones Correct, see RegExp for an example of how this is done. -- John A. Tamplin Software Engineer (GWT), Google --

[gwt-contrib] Add 'view data' to cell, column, and updater classes. (issue248801)

2010-03-19 Thread rice
Reviewers: jgw, Description: Add 'view data' to cell, column, and updater classes. Make the Validation example work with view data. Please review this at http://gwt-code-reviews.appspot.com/248801/show Affected files: M bikeshed/src/com/google/gwt/bikeshed/cells/client/ButtonCell.java M

Re: [gwt-contrib] ClientBundle produce memory leaks in IE6

2010-03-19 Thread Joel Webber
I am able to reproduce this leak as well, and can confirm that it only happens on IE6 (not 7+). If I use a standard image url rather than a ClientBundle, the leak goes away. Interestingly, though, it doesn't appear to be a standard circular-ref leak, because Microsoft's own leak detector doesn't

[gwt-contrib] Checkstyle fixes (issue249801)

2010-03-19 Thread rice
Reviewers: Ray Ryan, Description: Checkstyle fixes Please review this at http://gwt-code-reviews.appspot.com/249801/show Affected files: M bikeshed/src/com/google/gwt/sample/expenses/client/EmployeeList.java M bikeshed/src/com/google/gwt/sample/expenses/client/EntityListView.java M

[gwt-contrib] Re: Support runAsync with the cross-site linker. (issue213801)

2010-03-19 Thread cromwellian
Lex, Mostly LGTM except for what looks to me like a missing fall through case in HandleCrossIslandReferences. I'm still somewhat iffy on the stringify-and-eval stuff because I suspect some bloat, but maybe we can bench alternatives later. http://gwt-code-reviews.appspot.com/213801/diff/1/7

[gwt-contrib] Re: Checkstyle fixes (issue249801)

2010-03-19 Thread rjrjr
I just changed a bunch of these, and deleted some, Can you refresh before I review? http://gwt-code-reviews.appspot.com/249801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to

[gwt-contrib] Re: Support runAsync with the cross-site linker. (issue213801)

2010-03-19 Thread spoon
Thanks, Ray! I'll update the patch on Monday. I share your unease about the code increase due to stringifying. Like you suggest, I was thinking this would be a simple approach to start with that we can optimize over time. Do you have any ideas that would be pretty simple? If not, we might

Re: [gwt-contrib] Re: Fix the bug where you cannot use up arrow to enter the suggestions box (issue239801)

2010-03-19 Thread John LaBanca
I'll review this by Monday. Feel free to send me mean Shakespearean insults over chat if I don't get to it by Monday evening. Thanks, John LaBanca jlaba...@google.com On Thu, Mar 18, 2010 at 3:17 PM, rj...@google.com wrote: Perhaps eclipse deleted them. I forget why they exist exactly,

[gwt-contrib] [google-web-toolkit] r7751 committed - Adds missing dep

2010-03-19 Thread codesite-noreply
Revision: 7751 Author: rj...@google.com Date: Fri Mar 19 10:34:47 2010 Log: Adds missing dep http://code.google.com/p/google-web-toolkit/source/detail?r=7751 Modified: /trunk/bikeshed/src/com/google/gwt/sample/expenses/Expenses.gwt.xml === ---

[gwt-contrib] [google-web-toolkit] r7749 committed - Reduce warnings in Eclipse:...

2010-03-19 Thread codesite-noreply
Revision: 7749 Author: r...@google.com Date: Fri Mar 19 08:12:41 2010 Log: Reduce warnings in Eclipse: o Use ? instead of raw types o Add some @SuppressWarnings annotations o Document or remove unused method parameters Review at http://gwt-code-reviews.appspot.com/219803 Review by:

[gwt-contrib] [google-web-toolkit] r7751 committed - Adds missing dep

2010-03-19 Thread codesite-noreply
Revision: 7751 Author: rj...@google.com Date: Fri Mar 19 10:34:47 2010 Log: Adds missing dep http://code.google.com/p/google-web-toolkit/source/detail?r=7751 Modified: /trunk/bikeshed/src/com/google/gwt/sample/expenses/Expenses.gwt.xml === ---

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread Bruce Johnson
@John: I was thinking about actually not even designating the package as shared -- instead just make it a regular-looking Java package. As an experiment. On Fri, Mar 19, 2010 at 4:23 PM, John Tamplin j...@google.com wrote: On Fri, Mar 19, 2010 at 4:21 PM, Rodrigo Chandia

Re: [gwt-contrib] Array implementation for Lightweight Collections. Pure Java implementation only.

2010-03-19 Thread John Tamplin
On Fri, Mar 19, 2010 at 9:51 PM, Bruce Johnson br...@google.com wrote: @John: I was thinking about actually not even designating the package as shared -- instead just make it a regular-looking Java package. As an experiment. So if you have the module file in the same directory as the

[gwt-contrib] Re: Checkstyle fixes (issue249801)

2010-03-19 Thread rjrjr
LGTM Thanks. http://gwt-code-reviews.appspot.com/249801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the words REMOVE ME as the

[gwt-contrib] LayoutImplIE6 and onResize()

2010-03-19 Thread jd
Hi, I am experiencing a problem using a DockLayoutPanel with IE6 where a child widgets RequiresResize.onResize() is fired before the LayoutImplIE6 has updated the widgets width and height with new values. I have a child widget that needs to know when it is resized so it can resize a nested