Re: RFC 99 (v3) Standardize ALL Perl platforms on UNIX epoch

2000-09-13 Thread Russ Allbery
absolutely maximum speed, particularly if you have good tools to parse it and turn it back into a native format again. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 99 (v3) Standardize ALL Perl platforms on UNIX epoch

2000-09-14 Thread Russ Allbery
with seconds since epoch. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 48 (v4) Replace localtime() and gmtime() with date() and utcdate()

2000-09-26 Thread Russ Allbery
is grossly deficient in this respect, but that's an internals rather than a language issue. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Preprocessing (Was: Re: Recording what we decided *not* to do, and why)

2000-08-05 Thread Russ Allbery
constructs or characters, just identifiers, function calls, and # at the beginning of a line. It still causes a few problems where it recognizes something it shouldn't, but it's trivial to deal with compared to m4. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Sublist auto*

2000-08-05 Thread Russ Allbery
particular topic. Instead, what about a temporary freeze when each list is created? Give it a day or two after it's created before it will accept traffic; have the traffic be held for that long while people subscribe. Would that help this problem? -- Russ Allbery ([EMAIL PROTECTED])

Re: RFC: Rename local() operator

2000-08-05 Thread Russ Allbery
at's being done here is in other languages often called shadowing. What about Cshadow? shadow $/ = "\n"; seems to have the right implications to me. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC: multiline comments

2000-08-05 Thread Russ Allbery
that there's a lot to be said for using /* ... */ for multiline comments, but then I'm a C programmer. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 48 (v1) Replace localtime() and gmtime() with da

2000-08-06 Thread Russ Allbery
nough power for most of what people want to do and if you want to deal with the rest you have to deal with time zone naming. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Things to remove

2000-08-08 Thread Russ Allbery
s" and it chops the head off. Why do you need one-time matching here? /^$/ should work fine. I've very rarely found cases where ?? was useful and // didn't work, and never in regular code. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: AGAINST RFC 48 (v1) Replace localtime() and gmtime() with da

2000-08-08 Thread Russ Allbery
oppose the notion that Perl 6 will magically handle all this. -John -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: AGAINST RFC 48 (v1) Replace localtime() and gmtime() with da

2000-08-10 Thread Russ Allbery
f you call localtime in C, you should get back local time, whatever the local time zone. The whole point is to not try to duplicate that information in Perl core. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: AGAINST RFC 48 (v1) Replace localtime() and gmtime() with da

2000-08-10 Thread Russ Allbery
that it be passed as a string, but writing something like the above would be a *very* common new user mistake. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 48 (v2) Replace localtime() and gmtime() with da

2000-08-11 Thread Russ Allbery
Jarkko Hietaniemi [EMAIL PROTECTED] writes: s/gmt/ut/ IIRC GMT got obsoleted in the 70s by UT (Universal Time). Officially called UTC, so utcdate would be a better name I think. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 48 (v2) Replace localtime() and gmtime() with da

2000-08-11 Thread Russ Allbery
with corrections for UT1). -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 65 (v1) Add change bar functionality to pod

2000-08-14 Thread Russ Allbery
skud [EMAIL PROTECTED] writes: I don't think this is a language issue. However, I don't believe there's a -doc working group yet, either. Is it time for a -doc group to form? [EMAIL PROTECTED] already exists; maybe it should be blessed as a Perl 6 working group as well? -- Russ Allbery

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-15 Thread Russ Allbery
'; @args = split (' ', $args); my $i = 0; %args = map { $_ = ++$i } @args; This is very Perlish to me; the punctuation is part of the variable name and disambiguates nicely. I'd be very upset if this idiom went away. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-15 Thread Russ Allbery
that don't start with @, that's the mistake. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-15 Thread Russ Allbery
ut context makes it quite clear what's going on. This strikes me as the same sort of meaningless style guideline as "all variables must have names that are at least five characters long." -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 99 (v2) Standardize ALL Perl platforms on UNIX epoch

2000-08-15 Thread Russ Allbery
k by xntpd or something, but in practice time on a Unix clock is monotonic. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 84 (v1) Replace = (stringifying comma) with =

2000-08-16 Thread Russ Allbery
may be different (maybe garbage collection happened behind the scenes, the hash was reorganized due to an observation of how you were using it, etc.). -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Russ Allbery
John Porter [EMAIL PROTECTED] writes: Russ Allbery wrote: $args = 'first second third'; @args = split (' ', $args); my $i = 0; %args = map { $_ = ++$i } @args; This is very Perlish to me; the punctuation is part of the variable name and disambiguates nicely. No, it's

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Russ Allbery
and could well have a separate solution. Perhaps @-$$hash{value} as has been proposed before, and Perl 6 can deal with the issue of the @- array in some other way. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-17 Thread Russ Allbery
g the *one* @ in that expression isn't going to make it look any simpler. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 99 (v1) Maintain internal time in Modified Julian (not epoch)

2000-08-14 Thread Russ Allbery
Tim Jenness [EMAIL PROTECTED] writes: On 14 Aug 2000, Russ Allbery wrote: Day resolution is insufficient for most purposes in all the Perl scripts I've worked on. I practically never need sub-second precision; I almost always need precision better than one day. MJD allows fractional days

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Russ Allbery
Glenn Linderman [EMAIL PROTECTED] writes: Russ Allbery wrote: I agree with Tom; I think it's pretty self-evident that they're the same thing. undef means exactly the same thing as null; that's not the problem. The problem is that Perl doesn't implement the tri-state logic semantics

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Russ Allbery
e other hand, are specific to Perl and the default is chosen to be friendly to quick and dirty scripts. Changing those semantics to propagate undef makes perfect sense to me. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Russ Allbery
tion and I thought I was back in grad school. I don't think it's the fault of the writing either; I think that Quantum::Superpositions is trying to do something that's rather too complicated to explain clearly to the average programmer. It's a neat idea, but I don't expect to see it ever widely used.

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Russ Allbery
, at least). Hm, yeah, good point. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-21 Thread Russ Allbery
ls to RFC 263, along the lines of "use tristate", seem to overlook this sort of situation. I'm not overlooking it; I just don't agree with you. There *is* a difference. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-21 Thread Russ Allbery
or not. As a matter of fact, I find them very interesting and fully do expect to use those semantics if they're implemented in Perl, particularly given that I'm likely to be doing a lot more database and SQL coding in the future than I am currently. -- Russ Allbery ([EMAIL PROTECTED]) http

Re: perl6storm #0011: interactive perl mode

2000-09-23 Thread Russ Allbery
ould have been nice. But that's just me. As long as it's possible to get the current "perl" behavior; I actually use that a lot. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-23 Thread Russ Allbery
Glenn Linderman [EMAIL PROTECTED] writes: Russ Allbery wrote: Perhaps I don't use those warnings in the same way that you do. I *very* rarely have undefined value warnings in my programs, and when I do they're usually not actually bugs, just things that require a different way of writing

Re: RFC 283 (v1) Ctr/// in array context should return a histogram

2000-09-26 Thread Russ Allbery
agree with you are saying that only European scripts matter. But please don't escalate the argument as part of being offended. I'll now stop replying to this thread. Sorry for sticking my nose in; it really bugs me when this happens in i18n discussions. -- Russ Allbery ([EMAIL PROTECTED

Re: Perl6Storm: Intent to RFC #0101

2000-09-27 Thread Russ Allbery
ile before realizing they're weird use English things. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Perl6Storm: Intent to RFC #0101

2000-09-27 Thread Russ Allbery
ress the syntactical points of Perl that make it hard to read for someone who doesn't know Perl; it strikes me, and always has struck me, as a bad partial solution to a problem that may not need to be solved and that only makes things more complicated in the long run. -- Russ Allbery ([EMAIL PROTECTE

Re: Expunge use English from Perl? (was Re: Perl6Storm: Intent to RFC #0101)

2000-09-28 Thread Russ Allbery
that need to do UID fiddling need to load. I guess the exception is getpwuid($), which is probably done more than any other operation on UIDs, but maybe just keep that single variable. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: RFC 327 (v2) C\v for Vertical Tab

2000-09-29 Thread Russ Allbery
David Olbersen [EMAIL PROTECTED] writes: From: Russ Allbery [mailto:[EMAIL PROTECTED]] Just out of curiosity, and I'm not objecting to this RFC, has anyone reading this mailing list actually intentionally used a vertical tab for something related to its supposed purpose in the past ten years

Re: RFC 288 (v2) First-Class CGI Support

2000-09-30 Thread Russ Allbery
out of pack and putting it plus those other things into a standard module. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: TIL redux (was Re: What will the Perl6 code name be?)

2000-10-23 Thread Russ Allbery
Python. the TIL speedup over pure interpretation might win that back and more. If that's true, that's a different ballgame of course. If at all possible, Perl 6 should be *faster* than Perl 5. Perl is already too slow IMO. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org

Re: The binding of my (Re: Closures and default lexical-scope

2001-02-17 Thread Russ Allbery
So since when did perl6-language become perl-advocacy? Rephrased: Could people please take the advocacy traffic elsewhere where it isn't noise? Thanks. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: The binding of my (Re: Closures and default lexical-scope

2001-02-18 Thread Russ Allbery
and ended up just being stupid and grating. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Schwartzian Transform

2001-03-26 Thread Russ Allbery
all. sort { $a = $b } contains two functions to extract the keys. Functions don't have to be complicated, you know. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Schwartzian Transform

2001-03-26 Thread Russ Allbery
guaranteeing that Perl 6 would be YAPH-compatible anyway. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Schwartzian Transform

2001-03-26 Thread Russ Allbery
Uri Guttman [EMAIL PROTECTED] writes: "RA" == Russ Allbery [EMAIL PROTECTED] writes: RA Uri Guttman [EMAIL PROTECTED] writes: map { $_-[0] } sort { compare($a-[1], $b-[1]) } map { [$_, f($_)] } data ^^^ ^^^ RA Then you need to

Re: Schwartzian Transform

2001-03-26 Thread Russ Allbery
as much work anyway. Less mental effort is the important part, not how many characters have to be typed. I don't want to be thinking about that extra level of arrays, and until you've written *lots* of ST's, you can't ignore it. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Schwartzian transforms

2001-03-28 Thread Russ Allbery
t sub are called" then life becomes much easier. I am strongly in favor of that approach. I see no reason to allow for weird side effects in Perl 6. (Perl 5 would be a different matter, of course.) Not only is it simpler to deal with, it's simpler to *explain*, and that's important. -- Ru

Re: What can we optimize (was Re: Schwartzian transforms)

2001-03-29 Thread Russ Allbery
in the way of optimizing C. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: What can we optimize (was Re: Schwartzian transforms)

2001-03-29 Thread Russ Allbery
will be fairly rarely used and that most of your gains will come from managing to teach the compiler to figure out that information for itself. This will probably be harder in Perl than in C because C can afford to take more time to do global optimization passes. -- Russ Allbery ([EMAIL PROTECTED

Re: pitching names for the attribute for a function with no memor y or side effects

2001-03-30 Thread Russ Allbery
Dan Sugalski [EMAIL PROTECTED] writes: Doesn't have the right ring to it, unfortunately. It's not really immutable, it just has no side-effects. gcc and the literature both use "pure"; I'd recommend that. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: pitching names for the attribute for a function with no memor y or side effects

2001-03-31 Thread Russ Allbery
nst" (a la C++). I think "pure" was proposed for the somewhat relaxed version of that that allowed memory references but not side effects. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Larry's Apocalypse 1

2001-04-05 Thread Russ Allbery
, so I didn't have much additional response, apart from saying that that was rather more Perl 5 compatibility than I was expecting. Interesting. Oh, and I wholeheartedly approve of the approach to handling objects. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Larry's Apocalypse 1

2001-04-15 Thread Russ Allbery
for running those old scripts. No biggie. There's quite a lot more Perl 5 code out there than there was Perl 4 code. And it's rather annoying to still be maintaining a perl4 installation at this point for the stragglers, although I suppose that can't be helped. -- Russ Allbery ([EMAIL PROTECTED

Re: Strings vs Numbers (Re: Tying Overloading)

2001-04-24 Thread Russ Allbery
syntax of: PATH=/some/long:/bunch/of:/stuff PATH=${PATH}:/more/stuff would really be a shame. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: s/./~/g

2001-04-24 Thread Russ Allbery
-class entities rather than pointers; think about a struct versus a pointer to a struct. - makes you remember that things are pointers. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: s/./~/g

2001-04-24 Thread Russ Allbery
David M Lloyd [EMAIL PROTECTED] writes: On 24 Apr 2001, Russ Allbery wrote: The switch from - to . makes perfect sense from a C perspective if we're turning objects into first-class entities rather than pointers; think about a struct versus a pointer to a struct. - makes you remember

Re: Curious: - vs .

2001-04-25 Thread Russ Allbery
dereferencing), then using . to access object members is entirely compatible with C. I tried to make this point before, but I don't think people understood what I was getting at. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Python...

2001-06-03 Thread Russ Allbery
to make practical ideas already explored in other practical and experimental languages. Perl is far more practical than experimental. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Python...

2001-06-05 Thread Russ Allbery
nearly everything that was proposed back to C, Lisp, or Generic Object-Oriented Language, if not in inspiration than at least in fundamental similarities. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: ~ for concat / negation (Re: The Perl 6 Emulator)

2001-06-21 Thread Russ Allbery
I, actually... it's sort of growing on me. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: ! and !

2001-09-01 Thread Russ Allbery
raptor [EMAIL PROTECTED] writes: I was looking at Interbase SELECT syntax and saw these two handy shortcuts : operator = {= | | | = | = | ! | ! | | !=} ! and ! How is ! different from =? -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: ! and !

2001-09-01 Thread Russ Allbery
Sterin, Ilya [EMAIL PROTECTED] writes: From: Russ Allbery [mailto:[EMAIL PROTECTED]] How is ! different from =? It's just more syntax just like foo != bar is the same as (foo bar || foo bar). It might prove convenient to express the expression. It's the same number of characters. How

Re: ! and !

2001-09-02 Thread Russ Allbery
language I've ever seen uses = and =. I think adding additional comparison operators not found in any other language and identical to (and harder to type than!) existing operators is a really bad idea. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/

Re: Perl 6 Summary for week ending 20020728

2002-08-01 Thread Russ Allbery
of that. -- Russ Allbery ([EMAIL PROTECTED]) http://www.eyrie.org/~eagle/