Re: [SOGo] access multiple users per Thunderbird account with connector

2012-03-12 Thread Christian Mack
Hello Martin Waschbüsch


On 2012-03-11 19:58, Martin Waschbüsch wrote:
 
 Today I found a weird 'problem' concerning SOGo and Thunderbird
 Connector. I am unsure if this is something I should rather ask on
 the Thunderbird list? If so, please let me know. Also, I don't know
 for sure bug #0001029 is about the same thing or related?
 
 Anyway, my setup:
 
 - SOGo 1.3.12c on CentOS 5.8 - Thunderbird 10.0.2 on either Mac or
 Windows - Lightning 1.2.3 - SOGo Connector 10.0
 
 The scenario:
 
 Imagine one of two possible scenarios: The same person / user wants
 to use more than one account on a given SOGo instance. Either because
 
 
 A) the server hosts multiple domains via one FQDN to access SOGo and
 the user in question has accounts for more than one such domain, or 
 B) A server hosts only one domain, but the user needs access to two
 accounts on the same domain.
 
 The problem:
 
 The way the current setup works, it seems impossible to make TB do
 that, because it will 'remember' only one(!) username/password combo
 per host used, effectively blocking access to a second account on the
 same host but with different credentials.
 
 Has anyone found a solution for this problem? Is this a limitation in
 the Connector or in Thunderbird?
 

Yes, this is a known limitation in Connector and in Integrator.
And yes, this is Bug #1029.

And there is no known work around for this.


Kind regards,
Christian Mack

-- 
Christian Mack
Gruppe Informationsdienste
Rechenzentrum Universität Konstanz
-- 
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Christian Mack
Hi Michael Gratton


On 2012-03-12 05:20, Michael Gratton wrote:
 
 No-one has any advice on this?
 
  Message original 
 Sujet: cannot create new contacts or events using web UI
 Date : Thu, 08 Mar 2012 13:53:19 +1100
 De : Michael Gratton mich...@quuxo.com
 Organisation : Quuxo Software
 Pour : users@sogo.nu
 
 
 Hi,
 
 Using sogo-1.3.6-1.el5, I cannot create a new address book contacts or
 calendar events using the web interface.
 
 When hitting save on either the new contact or the new event, the result
 is a generic browser connection error page, since the form is attempting
 to submit to http://127.0.0.1:2/SOGo/[snip] rather than the
 correct address of the calendar server, i.e.
 http://collab.internal.xyz.com/[snip]
 
 Everything else seems to work fine.
 
  ... 
 
 Any suggestions?
 

I hat a similar problem after upgrading.
The solution was to clear the browser cache.

But I don't think this is related to your problem, as you obviously try
to set up a fresh SOGo.


Kind regards,
Christian Mack

-- 
Christian Mack
Gruppe Informationsdienste
Rechenzentrum Universität Konstanz
-- 
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] access multiple users per Thunderbird account with connector

2012-03-12 Thread Georg Bretschneider
Well, with a bug filed I guess we can sooner or later expect a fix.
Good to know that the last scenario isn't working right now and even
better that it doesn't affect me at the moment. But it will.

Am 12.03.2012 11:01, schrieb Christian Mack:
 Hello Martin Waschbüsch
 
 
 On 2012-03-11 19:58, Martin Waschbüsch wrote:

 Today I found a weird 'problem' concerning SOGo and Thunderbird
 Connector. I am unsure if this is something I should rather ask on
 the Thunderbird list? If so, please let me know. Also, I don't know
 for sure bug #0001029 is about the same thing or related?

 Anyway, my setup:

 - SOGo 1.3.12c on CentOS 5.8 - Thunderbird 10.0.2 on either Mac or
 Windows - Lightning 1.2.3 - SOGo Connector 10.0

 The scenario:

 Imagine one of two possible scenarios: The same person / user wants
 to use more than one account on a given SOGo instance. Either because


 A) the server hosts multiple domains via one FQDN to access SOGo and
 the user in question has accounts for more than one such domain, or 
 B) A server hosts only one domain, but the user needs access to two
 accounts on the same domain.

 The problem:

 The way the current setup works, it seems impossible to make TB do
 that, because it will 'remember' only one(!) username/password combo
 per host used, effectively blocking access to a second account on the
 same host but with different credentials.

 Has anyone found a solution for this problem? Is this a limitation in
 the Connector or in Thunderbird?

 
 Yes, this is a known limitation in Connector and in Integrator.
 And yes, this is Bug #1029.
 
 And there is no known work around for this.
 
 
 Kind regards,
 Christian Mack
 
-- 
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] sogo not binding to LDAP

2012-03-12 Thread Georg Bretschneider
Hi Bunjes,

your baseDN in your GNUstepDefaults looks different than from your
ldapsearch string.

GNUstepDefaults: dc=neurologie.uni-tuebingen.de,dc=local
ldapsearch string: ou=HIH,dc=neurologie.uni-tuebingen.de,dc=local

Maybe there lays the problem?

Please run some more manuel ldap searches, using different baseDNs with
the goal to output every (or a group of) authorized sogo users - and
just those.


Bye

Am 07.03.2012 14:55, schrieb Bunjes Friedemann:
 Hi,
 
 sogo seems not to be able to bind to our LDAP server:
 
 .GNUstepDefaults:
 
 keySOGoUserSources/key
 array
 dict
 keyCNFieldName/key
 stringcn/string
 keyIDFieldName/key
 stringuid/string
 keyUIDFieldName/key
 stringuid/string
 keybaseDN/key
 stringdc=neurologie.uni-tuebingen.de,dc=local/string
 keybindDN/key
 
 stringuid=sogo,ou=Users,ou=EDV,ou=HIH,dc=neurologie.uni-tuebingen.de,dc=local/string
 keybindPassword/key
 string***/string
 keycanAuthenticate/key
 stringYES/string
 keydisplayName/key
 stringAddresses/string
 keyhostname/key
 stringlocalhost/string
 keyid/key
 stringpublic/string
 keyisAddressBook/key
 stringYES/string
 keyport/key
 string389/string
 keyscope/key
 stringSUB/string
 
 sogo.log:
 
 Mar 06 09:58:47 sogod [4778]: SOGoRootPage Login for user 'fbunjes' might not 
 have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
 localhost - - [06/Mar/2012:09:58:47 GMT] POST /SOGo/connect HTTP/1.1 403 
 34/42 0.025 - - 2M
 
 Commandline ldapsearch using user sogo is working:
 
 ldapsearch -h localhost -b ou=HIH,dc=neurologie.uni-tuebingen.de,dc=local 
 -D uid=sogo,ou=Users,ou=EDV,ou=HIH,dc=neurologie.uni-tuebingen.de,dc=local 
 -W objectclass=person
 
 How can we further debug this? Any way to make the log more verbose?
 
 Best,
 
 Friedemann
 
-- 
users@sogo.nu
https://inverse.ca/sogo/lists


RE: [SOGo] Probmelm whil installing SOGo2beta5 from sources

2012-03-12 Thread Bartłomiej Kluska
Basically I installed the packages recommended in the manual on the OS version 
(Oneiric) recommended in the manual. Thus I have GNUstep v1.22 and gnustep-make 
v2.6
I tried but I couldn't (maybe that I don't know the right way) downgrade the 
gnustep-make to v2.4.

But I assume that if there was no notice to use older version of gnustep-make 
in the manual, the v2.6 should be also fine..

Regards,
BK


 -Original Message-
 From: Jean-Michel OLTRA [mailto:jm.ol...@cloud-bs.fr]
 Sent: Saturday, March 10, 2012 12:49 PM
 To: users@sogo.nu
 Subject: Re: [SOGo] Probmelm whil installing SOGo2beta5 from sources

 It seems to be worse!
 
 I think that SOGo developpers are quite good developpers, and that they
 did not have commited such code with so much errors.
 
 You and me, we have not the same errors, except the last one: I had an
 error about a String constant, but you had not this one, and you have
 errors about the include path, which I did not have.
 
 I note that you are compiling with gnustep-make 2.6.0. Mine si
 gnustep-make version 2.4.0, on Debian Squeeze.
 
 If I remove the -Werror flag, in the ADDITIONAL_INCLUDE_DIRS parts, the
 compilation ends successfully, but I still have the warning about the
 pointer type at line 1279!
 

-- 
users@sogo.nu
https://inverse.ca/sogo/lists

Re: [SOGo] access multiple users per Thunderbird account with connector

2012-03-12 Thread Peter Schmidt

Hi Martin!

You could do a nicer workaround and create two profiles in thunderbird, 
one for each Sogo user.


I think you can even run them simultaneously but i'm not sure now. This 
seems to me to be a bit cleaner than choosing the sogo account at 
login time.


Depends on your needs... Just a suggestion.

Regards,
Peter


On 2012-03-12 11:11, Georg Bretschneider wrote:

Well, with a bug filed I guess we can sooner or later expect a fix.
Good to know that the last scenario isn't working right now and even
better that it doesn't affect me at the moment. But it will.

Am 12.03.2012 11:01, schrieb Christian Mack:

Hello Martin Waschbüsch


On 2012-03-11 19:58, Martin Waschbüsch wrote:


Today I found a weird 'problem' concerning SOGo and Thunderbird
Connector. I am unsure if this is something I should rather ask on
the Thunderbird list? If so, please let me know. Also, I don't know
for sure bug #0001029 is about the same thing or related?

Anyway, my setup:

- SOGo 1.3.12c on CentOS 5.8 - Thunderbird 10.0.2 on either Mac or
Windows - Lightning 1.2.3 - SOGo Connector 10.0

The scenario:

Imagine one of two possible scenarios: The same person / user wants
to use more than one account on a given SOGo instance. Either because


A) the server hosts multiple domains via one FQDN to access SOGo and
the user in question has accounts for more than one such domain, or
B) A server hosts only one domain, but the user needs access to two
accounts on the same domain.

The problem:

The way the current setup works, it seems impossible to make TB do
that, because it will 'remember' only one(!) username/password combo
per host used, effectively blocking access to a second account on the
same host but with different credentials.

Has anyone found a solution for this problem? Is this a limitation in
the Connector or in Thunderbird?



Yes, this is a known limitation in Connector and in Integrator.
And yes, this is Bug #1029.

And there is no known work around for this.


Kind regards,
Christian Mack


--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] acces to sharing agenda

2012-03-12 Thread Mathilde Rousseau

Hello
I share my agenda with another personne. We are on a test plateform 
running sogo 1.3.12 on debian squeeze. With this personne we test the 
acces rights of class of event. I give him view all on Private events 
but when i try to change it to give him none it doesn't work. I can save 
my choice, but if i disconnect and connect again the changes doesn't 
work he still have view all on my private events.

Thank you for help
Sincerely yours
Mathilde

--
Mathilde Rousseau   tel: 01 69 82 45 84/ 06 10 27 96 32
Responsable du Service Informatique Commun,
ICSN UPR2301, Bâtiment 27
CNRS, 1 Av de la terrasse  mail: mathilde.rouss...@icsn.cnrs-gif.fr
91198 Gif sur Yvette cedex



--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] TB10 all invitations from subscribed calendars

2012-03-12 Thread Ryan Evans

To the devs:

What would be needed to fix this issue with invitations and alarm 
alerts (especially on the IOS platform)?


Cheers,

Ryan


On 3/7/2012 4:38 AM, Adi Kriegisch wrote:

Hi Jonathan!


Where did you actually find the
calendar.registry.HASH.showInvitations user preference?

Sorry, checked about:config (learning to use Thunderbird ;) ) and
found that this preference is false for all of my calendars. I
will add this detail to the mentioned bugs.

Ah... I see: If you want to play around with those settings, choose
preferences -  Advanced and use the config editor. Just be aware of the
fact that you may just blow up Thunderbird with wrong settings... ;-)

-- Adi


--
Ryan Evans
Business Development Account Manager
Gulf Interstate Engineering Company
16010 Barkers Point Lane, Suite 600
Houston, Texas 77079-9000 USA
Office: 713-850-3604
Cell: 281-413-2900




Privileged, Proprietary and/or Confidential Information may be contained in
this electronic message.  If you are not the intended recipient, you should
not copy it, re-transmit it, use it or disclose its contents, but should
kindly return to the sender immediately and delete your copy from your system.
Gulf Interstate Engineering Company does not accept responsibility for
changes made to this electronic message or its attachments. 


--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] Greasemonkey script to remember password

2012-03-12 Thread Christian Reischl

Hi,

is it possible to write/use a Firefox Greasemonkey script to enable 
password saving on the SOGo Web Interface?


Has someone already done that?

The common autocomplete override scripts/bookmarklets aren't working.

I know about the security concerns, but in some cases it would be very 
useful. With Greasemonkey it would be possible without modifying SOGo.


kind regards,
Christian
--
__
Christian Reischl

Fraunhofer Institut für
Verfahrenstechnik und Verpackung
Giggenhauser Str. 35
85354 Freising

Telefon: 08161 491-704
mailto:christian.reis...@ivv.fraunhofer.de
http://www.ivv.fraunhofer.de
--
users@sogo.nu
https://inverse.ca/sogo/lists

Re: [SOGo] Greasemonkey script to remember password

2012-03-12 Thread André Schild

Am 12.03.2012 18:28, schrieb Christian Reischl:

Hi,

is it possible to write/use a Firefox Greasemonkey script to enable 
password saving on the SOGo Web Interface?


Has someone already done that?

The common autocomplete override scripts/bookmarklets aren't working.

I know about the security concerns, but in some cases it would be very 
useful. With Greasemonkey it would be possible without modifying SOGo.

I think it should be a option in sogo install
to allow users to save the password in the normal password save dialogs.

So each sysadmin can decide if they with to allow this or not...

André
--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] default config sogo.conf and .GNUstepDefaults

2012-03-12 Thread Mikel
Hi

Someone is able to connect sogo with ldap throw Apache and could show
the config files?

I'm trying to do it, but on SOGo web for all user that I try to login,
always: user or password incorrect, and in 
sogo.log I can't find the problem.  In SOGo.conf what about:
[env=REMOTE_HOST:%{REMOTE_HOST_ADDR},PT]?
Remote_host is were LDAP is configured?   AuthType XXX?? and
%{REMOTE_USER}e? I'm not sure how to configured it



Thank you very much!!

My config file:

.GNUstepDefaults: I remplaced password_bind for the correct

?xml version=1.0 encoding=UTF-8?
!DOCTYPE plist PUBLIC -//GNUstep//DTD plist 0.9//EN
http://www.gnustep.org/plist-0_9.xml;
plist version=0.9
dict
keyNSGlobalDomain/key
dict
/dict
keysogod/key
dict
keyGCSFolderDebugEnabled/key
stringYES/string
keyGCSFolderStoreDebugEnabled/key
stringYES/string
keyLDAPDebugEnabled/key
stringYES/string
keyMySQL4DebugEnabled/key
stringYES/string
keyNGImap4DisableIMAP4Pooling/key
stringYES/string
keyOCSFolderInfoURL/key

stringmysql://sogo:password@127.0.0.1:3306/sogo/sogo_folder_info/string
keyOCSFolderManagerSQLDebugEnabled/key
stringYES/string
keyOCSSessionsFolderURL/key

stringmysql://sogo:password@127.0.0.1:3306/sogo/sogo_sessions_folder/string
keyPGDebugEnabled/key
stringYES/string
keySOGoACLsSendEMailNotifications/key
stringYES/string
keySOGoAppointmentSendEMailNotifications/key
stringYES/string
keySOGoDebugRequests/key
stringYES/string
keySOGoDraftsFoldersName/key
stringDrafts/string
keySOGoFirstDayOfWeek/key
string1/string
keySOGoFoldersSendEMailNotifications/key
stringYES/string
keySOGoIMAPServer/key
stringlocalhost/string
keySOGoLanguage/key
stringSpanish/string
keySOGoLoginModule/key
stringCalendar/string
keySOGoMailDomain/key
stringgrupodominio.es/string
keySOGoMailKeepDraftsAfterSend/key
stringYES/string
keySOGoMailMessageCheck/key
stringevery_5_minutes/string
keySOGoMailingMechanism/key
stringsmtp/string
keySOGoProfileURL/key

stringmysql://sogo:password@127.0.0.1:3306/sogo/sogo_user_profile/string
keySOGoSMTPServer/key
stringdebianSogo.grupodominio.es/string
keySOGoSentFolderName/key
stringSent/string
keySOGoSieveScriptsEnabled/key
stringYES/string
keySOGoSieveServer/key
stringsieve://localhost:4190/string
keySOGoSuperUsernames/key
array
stringadmin/string
/array
keySOGoTimeZone/key
stringEurope/Madrid/string
keySOGoTrashFolderName/key
stringTrash/string
keySOGoUIxDebugEnabled/key
stringYES/string
keySOGoUserSources/key
array
dict
keyCNFieldName/key
stringcn/string
keyIDFieldName/key
stringuid/string
keyUIDFieldName/key
stringuid/string
keybaseDN/key
stringou=Users,dc=servidor,dc=dominio,dc=com,dc=es/string
keybindDN/key
stringsogopru...@dominio.com.es/string
keybindFields/key
stringuid/string
keybindPassword/key
stringpassword_bind/string
keycanAuthenticate/key
stringYES/string
keydisplayName/key
stringContactos/string
keyhostname/key
stringservidor.dominio.com.es/string
keyid/key
stringpublic/string
keyisAddressBook/key
stringNO/string
keyport/key
string389/string
keytype/key
stringldap/string
/dict
/array
keySOGoVacationEnabled/key
stringYES/string
keySoDebugObjectTraversal/key
stringYES/string
keySoSecurityManagerDebugEnabled/key
stringYES/string
keyWODebugZipResponse/key
stringYES/string
keyWODontZipResponse/key
stringYES/string
/dict
/dict
/plist




SOGo.conf

Alias /SOGo.woa/WebServerResources/ \
  /usr/lib/GNUstep/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
  /usr/lib/GNUstep/SOGo/WebServerResources/
AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) \
   /usr/lib/GNUstep/SOGo/$1.SOGo/Resources/$2

Directory /usr/lib/GNUstep/SOGo/
AllowOverride None
Order deny,allow
Allow from all
/Directory

LocationMatch ^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*\.(jpg|
png|gif|css|js)
  SetHandler default-handler
/LocationMatch

## Uncomment the following to enable proxy-side authentication, you will
then
## need to 

Re: [SOGo] access multiple users per Thunderbird account with connector

2012-03-12 Thread Anselm Martin Hoffmeister

Am 12.03.2012 11:47, schrieb Peter Schmidt:

Hi Martin!

You could do a nicer workaround and create two profiles in 
thunderbird, one for each Sogo user.


I think you can even run them simultaneously but i'm not sure now. 
This seems to me to be a bit cleaner than choosing the sogo account 
at login time.


Depends on your needs... Just a suggestion.


I expect the username/password combo relates to the hostname of the sogo 
server. If you are not in VirtualHost hell (or rather, your sogo server 
is not *g*), you could use another hostname pointing to the same IP 
address, or just the literal IP address...?


I had a Thunderbird setup that way with Lightning for a while, no idea 
about Connector though. Worth a try?


Another way would be to grant the ID A access to ID B's address 
books / calendar and only ever connect as ID A

(That was what I did later).

BR
A.M.H.
--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] access multiple users per Thunderbird account with connector

2012-03-12 Thread Peter Schmidt

On 2012-03-12 19:47, Anselm Martin Hoffmeister wrote:

Am 12.03.2012 11:47, schrieb Peter Schmidt:

Hi Martin!

You could do a nicer workaround and create two profiles in
thunderbird, one for each Sogo user.

I think you can even run them simultaneously but i'm not sure now.
This seems to me to be a bit cleaner than choosing the sogo account
at login time.

Depends on your needs... Just a suggestion.


I expect the username/password combo relates to the hostname of the sogo
server. If you are not in VirtualHost hell (or rather, your sogo server
is not *g*), you could use another hostname pointing to the same IP
address, or just the literal IP address...?

I had a Thunderbird setup that way with Lightning for a while, no idea
about Connector though. Worth a try?

Another way would be to grant the ID A access to ID B's address
books / calendar and only ever connect as ID A
(That was what I did later).

BR
A.M.H.


IIRC the Connector/Integrator plugins connect to the first configured 
mail account of TB. So the hostname alias/IP address won't help you.


Granting ID A all access to ID B's mails/contacts/calendars would be a 
nice solution, but I guess that only works if they are on the same 
(sogo) domain.


I still think, until the bug #0001029 is not fixed, the two TB profiles 
are the most generic way to circumvent this issue.


Regards,
Peter
--
users@sogo.nu
https://inverse.ca/sogo/lists


[SOGo] Problem using Funambol

2012-03-12 Thread Christian Roessner
Hello,

I have successfully installed SOGo-1.3.12c on Ubuntu 10.04. I also need 
Funambol and therefor I installed the latest version 10.0.3 (even 10.0.0 is 
shown in the admin pane). I followed the instructions found in the SOGo 
installation guide page 39ff.

I installed latest jdbc postgresql jar file and the json-simple stuff. Did 
everything as described, but it does not work.

What works is that I can sync my contacts to Funambol, if I leave the field 
showing card (not changing it to sogo-card). If I do so, Funambol stores 
everything in the hypertonic SQL script file, which I checked afterwards. This 
shows me that Funambol itself seems to be configured correctly. I also used the 
funamboladmin tool and search for my user croessner under Users and found me. 
So I guess, the SOGoOffice stuff worked, too?

I did a tcpdump on port 5432 and saw lots of traffic when trying to sync with 
contact field set to sogo-card in the App. But it fails with error 511.

These are the files I used to try getting Funambol with SOGo together:

funambol-10.0.3-x64.bin
funambol-sogo-1.0.8.s4j
json-simple-1.1.1.jar
postgresql-9.1-901.jdbc4.jar

Is that right?

I also have to notice that my PostgreSQL server is running remote at 
roessner1.roessner-net.de. I therefor changed the settings in funamboladmin to 
match the correct settings. Also another password for the sogo user.

Does someone know, how I can get more debugging information out of tomcat? In 
the file catalina.out there are no errors at all. Or at least I do not 
recognize them as errors ;-)

I am quite unsure, if this list is the right place, but because the problem 
seems to have to do with the sogo interface between Funambol and SOGo, I hope 
someone can point me to the problem.

Thanks a lot in advance.

I attached some log stuff from Catalina.

java.vm.name=Java HotSpot(TM) 64-Bit Server VM
file.encoding=UTF-8
java.specification.version=1.6
javax.net.ssl.trustStore=/opt/Funambol/ds-server/lib/security/...

Starting configuration monitor [funambol-directory-monitor-2bbe2893] on: 
/opt/Funambol/config


Funambol Data Synchronization Server v. 10.0.0 engine started.
Configuration object found.

-- listing properties --
java.vendor=Sun Microsystems Inc.
sun.java.launcher=SUN_STANDARD
catalina.base=/opt/Funambol/tools/tomcat
sun.management.compiler=HotSpot 64-Bit Server Compiler
catalina.useNaming=true
os.name=Linux
sun.boot.class.path=/opt/Funambol/tools/jre-1.6.0/jre/lib...
java.util.logging.config.file=/opt/Funambol/tools/tomcat/conf/loggi...
funambol.home=/opt/Funambol
com.sun.management.jmxremote=
java.vm.specification.vendor=Sun Microsystems Inc.
java.runtime.version=1.6.0_18-b07
user.name=root
shared.loader=
tomcat.util.buf.StringCache.byte.enabled=true
user.language=en
java.naming.factory.initial=org.apache.naming.java.javaURLContext...
sun.boot.library.path=/opt/Funambol/tools/jre-1.6.0/jre/lib...
com.sun.management.jmxremote.port=8101
java.version=1.6.0_18
java.util.logging.manager=org.apache.juli.ClassLoaderLogManager
user.timezone=Europe/Berlin
java.net.preferIPv4Stack=true
sun.arch.data.model=64
java.endorsed.dirs=/opt/Funambol/tools/tomcat/endorsed
java.rmi.server.randomIDs=true
sun.cpu.isalist=
sun.jnu.encoding=UTF-8
file.encoding.pkg=sun.io
package.access=sun.,org.apache.catalina.,org.apache
file.separator=/
java.specification.name=Java Platform API Specification
java.class.version=50.0
user.country=US
java.home=/opt/Funambol/tools/jre-1.6.0/jre
java.vm.info=mixed mode
os.version=2.6.32-39-server
funambol.debug=false
com.sun.management.jmxremote.ssl=false
path.separator=:
java.vm.version=16.0-b13
java.awt.printerjob=sun.print.PSPrinterJob
sun.io.unicode.encoding=UnicodeLittle
com.sun.management.jmxremote.authenticate=false
package.definition=sun.,java.,org.apache.catalina.,org.a...
java.naming.factory.url.pkgs=org.apache.naming
user.home=/root
java.specification.vendor=Sun Microsystems Inc.
java.library.path=/opt/Funambol/ds-server/lib/x86_64
java.vendor.url=http://java.sun.com/
java.vm.vendor=Sun Microsystems Inc.
common.loader=${catalina.home}/lib,${catalina.home}...
java.runtime.name=Java(TM) SE Runtime Environment
java.class.path=:/opt/Funambol/tools/tomcat/bin/boots...
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.version=1.0
catalina.home=/opt/Funambol/tools/tomcat
sun.cpu.endian=little
sun.os.patch.level=unknown
java.awt.headless=true
java.io.tmpdir=/opt/Funambol/tools/tomcat/temp
java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport...
server.loader=
java.rmi.server.hostname=
os.arch=amd64
java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
java.ext.dirs=/opt/Funambol/tools/jre-1.6.0/jre/lib...
user.dir=/opt/Funambol/tools/tomcat/bin
line.separator=

java.vm.name=Java HotSpot(TM) 64-Bit Server VM
file.encoding=UTF-8

Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Michael Gratton

Le 12/03/12 21:09, Christian Mack a écrit :
 
 I hat a similar problem after upgrading.
 The solution was to clear the browser cache.
 
 But I don't think this is related to your problem, as you obviously try
 to set up a fresh SOGo.

Well, it is an old installation, but this problem has persisted across a
number of versions of SOGo now. Although we don't really use the web
interface, it is a rather core function that is broken, so I doubt it's
a bug and that upgrading will help.

More likely it's a configuration issue, but after consulting the
documentation it seems like the instance is configured fine, which is
why I was hoping someone on the list might have some advice.

Cheers,
//Mike

-- 
Michael Gratton mich...@quuxo.com
Quuxo Software http://web.quuxo.com/



signature.asc
Description: OpenPGP digital signature


Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Ludovic Marcotte

On 12/03/12 18:46, Michael Gratton wrote:

Well, it is an old installation, but this problem has persisted across a
number of versions of SOGo now. Although we don't really use the web
interface, it is a rather core function that is broken, so I doubt it's
a bug and that upgrading will help.
Share the part of your sogo.log file when you try to create an event or 
a contact.


--
Ludovic Marcotte
+1.514.755.3630  ::  www.inverse.ca
Inverse inc. :: Leaders behind SOGo (www.sogo.nu) and PacketFence 
(www.packetfence.org)

--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Michael Gratton
Le 13/03/12 09:55, Ludovic Marcotte a écrit :
 On 12/03/12 18:46, Michael Gratton wrote:
 Well, it is an old installation, but this problem has persisted across a
 number of versions of SOGo now. Although we don't really use the web
 interface, it is a rather core function that is broken, so I doubt it's
 a bug and that upgrading will help.
 Share the part of your sogo.log file when you try to create an event or
 a contact.
 

There is no SOGo log entry, because on clicking the Save button for the
event the browser tries to submit to localhost rather than to the SOGo
installation's host.

I.e. The browser sends the request to:

  http://127.0.0.1:2/SOGo/[snip]

Rather than:

  http://collab.internal.xyz.com/[snip]


-- 
Michael Gratton mich...@quuxo.com
Quuxo Software http://web.quuxo.com/



signature.asc
Description: OpenPGP digital signature


Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Ludovic Marcotte

On 12/03/12 19:04, Michael Gratton wrote:

There is no SOGo log entry, because on clicking the Save button for the
event the browser tries to submit to localhost rather than to the SOGo
installation's host.

I.e. The browser sends the request to:

   http://127.0.0.1:2/SOGo/[snip]

Rather than:

   http://collab.internal.xyz.com/[snip]

Instead of :

RequestHeader set x-webobjects-remote-host 127.0.0.1

use:

RequestHeader set x-webobjects-remote-host %{REMOTE_HOST}e 
env=REMOTE_HOST


Also:

BalancerMember http://127.0.0.1:2 retry=1 max=1 timeout=120
BalancerMember http://127.0.0.1:20001 retry=1 max=1 timeout=120

is most likely wrong. I don't recall if v1.3.6 had the master process 
code which is dispatching requests to child processes but you could 
easily verify this by checking if port 20001 is open. If not, the 
following Apache configuration might suit you better and 
mod_proxy_balancer is no longer needed:


...
ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On

ProxyPass /SOGo http://127.0.0.1:2/SOGo retry=0

Proxy http://127.0.0.1:2/SOGo
  RequestHeader set x-webobjects-server-port 80
  RequestHeader set x-webobjects-server-name collab.internal.xyz.com
  RequestHeader set x-webobjects-server-url 
http://collab.internal.xyz.com;


  RequestHeader set x-webobjects-server-protocol HTTP/1.0
  RequestHeader set x-webobjects-remote-host %{REMOTE_HOST}e 
env=REMOTE_HOST


  AddDefaultCharset UTF-8

  Order allow,deny
  Allow from all
/Proxy
...

--
Ludovic Marcotte
+1.514.755.3630  ::  www.inverse.ca
Inverse inc. :: Leaders behind SOGo (www.sogo.nu) and PacketFence 
(www.packetfence.org)

--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] Re: cannot create new contacts or events using web UI

2012-03-12 Thread Michael Gratton

Hi,

Thanks for the suggestions.

Le 13/03/12 10:16, Ludovic Marcotte a écrit :
 Instead of :
 
 RequestHeader set x-webobjects-remote-host 127.0.0.1
 
 use:
 
 RequestHeader set x-webobjects-remote-host %{REMOTE_HOST}e
 env=REMOTE_HOST

I tried that (and with quotes around the value) and had some weird
results when requesting /, but in any case it didn't seem to fix the
problem.

What does the x-webobjects-remote-host header do? If anything, it seems
like it would just inform SOGo of the client's IP address, but I doubt
that it would affect the server's address as generated in the HTML,
which is the problem.

 Also:
 
 BalancerMember http://127.0.0.1:2 retry=1 max=1 timeout=120
 BalancerMember http://127.0.0.1:20001 retry=1 max=1 timeout=120
 
 is most likely wrong. I don't recall if v1.3.6 had the master process
 code which is dispatching requests to child processes but you could
 easily verify this by checking if port 20001 is open.

Thanks, I'll have a a look into this (and the former a bit more) out of
business hours when I can muck around with it more.

//Mike

-- 
Michael Gratton mich...@quuxo.com
Quuxo Software http://web.quuxo.com/



signature.asc
Description: OpenPGP digital signature


[SOGo] BTS activities for Monday, March 12 2012

2012-03-12 Thread SOGo reporter
Title: BTS activities for Monday, March 12 2012





  
BTS Activities

  Home page: http://www.sogo.nu/bugs
  Project: SOGo
  For the period covering: Monday, March 12 2012

  
  
idlast updatestatus (resolution)categorysummary
	
	
	  
	
1668
	2012-03-12 20:04:57
	updated (open)
	GUI
	Missing GUI for users administration
	
	  
	
759
	2012-03-12 05:36:14
	updated (open)
	Web Calendar
	List of accessible shared calendars
	
	  
	
1635
	2012-03-12 05:50:15
	updated (open)
	Web Calendar
	Day long Eventswith caldav Export
	
	  
	
1673
	2012-03-12 08:42:18
	updated (open)
	Web Preferences
	Cannot create Signature in IE
	
	  
	
1675
	2012-03-12 22:40:23
	updated (open)
	with SOGo
	Thunderbird doesn't sync with SOGo
	
	  
	
1674
	2012-03-12 19:34:57
	closed (not a bug)
	SOGo Integrator
	removing calendar thouhgt sogo-integrator