Re: [SOGo] ANN: SOGo v2.0.0

2012-09-27 Thread Aaron C Johnson

On 09/27/2012 04:57 PM, Ludovic Marcotte wrote:
The Inverse Team is pleased to announce the immediate availability of 
SOGo 2.0.0. This is a major release of SOGo which focuses on improved 
stability over previous versions and the addition of native Outlook 
compatibility support! 

Awesome! I can't wait to try it, excellent work Inverse team!

I noticed that the 1.3.x series is apparently being replaced by SOGo 2.0.

Can someone please point me in the right direction for upgrade notes for 
upgrading from SOGo 1.3.x to SOGo 2.0 now that it is officially 
released? Is there official documentation on this (perhaps I missed it)?


Are there any special steps that I need to follow before running apt-get 
dist-upgrade?


--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] Skinable Web UI for SOGo ?

2012-06-18 Thread Aaron C Johnson
I agree that SOGo web interface should be skinable and could use some 
visual improvements, but I actually think that compared to Zimbra and 
other owa clones that SOGo is clean, fast and as a result it is easy to 
figure out. The ability to make changes to colors, icons, and simple css 
tweaks would be nice though in SOGo.


On 06/18/2012 09:38 AM, Federico Alberto Sayd wrote:

On 18/06/12 05:25, Fonzy wrote:

Hi,

I known that the Web UI of SOGo is dedicated to be a clone of 
Thunderbird, but is there a way to make it skinable ?
Imagine SOGo with Outlook compatibility and a beautifull clone of 
Exchange Web UI : The perfect Exchange clone, isn't !


But ok, it's simply an idea (may be bad)

Regards,
Fonzy.


I also think that a skinnable Web UI would be a great idea. May be 
this is not the best argument but some users complain about the look 
of SOGo WebUI, some of them say that compared with Zimbra, SOGo is 
ugly. I see the technical advantages of SOGo (Scalability, 
interoperability with our actual mail infraestructure, standard 
compliant, etc.) but final users focuses on the look and feel, and 
final users sadly includes the boss.


Regards

Federico

--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] iPhone Calendar doesnt see items created on the web interface

2012-06-18 Thread Aaron C Johnson

Did you read the documentation?

On iOS 3.1.2 and later, you must also specify the range of events you 
want to have.


From the Settings menu, choose Mail, Contacts, Calendars
From the Sync menu, choose All Events
_*Note that other options (Events 2 Weeks Back, etc.) do not work right 
now.*_


Does this help?

On 06/18/2012 03:53 PM, Daniel Colchete wrote:

Good day everyone!

I started working with SOGo a few weeks ago here on my company. I love 
it! I love how it is modular, how it scales and I love where it is 
going with 2.0. Right now I'm using 1.3.16.


I'm working with calendars fine. My users are using Thunderbird 13 
with Lightning, the Web Interface and the iPhone with iOS 5.1.1. 
Calendar items created on the iPhone are shown everywhere, items 
created with Thunderbird are shown everywhere (including on the 
iPhone), but calendar items created on the web interface are shown 
only at Thunderbird and at SOGo's web interface, but not on the iPhone.


Since the iPhone is creating calendar entries fine and it can see 
everything I create on Thunderbird fine, I don't think it is an iPhone 
config. issue. I set it to sync everything (not only the last 2 months).


How can I troubleshoot this? My guess is that the CalDAV entry created 
on the web interface is missing something...


Thank you very much.

Best,
Daniel Colchete

--
users@sogo.nu
https://inverse.ca/sogo/lists

Re: [SOGo] iPhone Calendar doesnt see items created on the web interface

2012-06-18 Thread Aaron C Johnson




On 06/18/2012 03:53 PM, Daniel Colchete wrote:

Good day everyone!

I started working with SOGo a few weeks ago here on my company. I 
love it! I love how it is modular, how it scales and I love where it 
is going with 2.0. Right now I'm using 1.3.16.


I'm working with calendars fine. My users are using Thunderbird 13 
with Lightning, the Web Interface and the iPhone with iOS 5.1.1. 
Calendar items created on the iPhone are shown everywhere, items 
created with Thunderbird are shown everywhere (including on the 
iPhone), but calendar items created on the web interface are shown 
only at Thunderbird and at SOGo's web interface, but not on the iPhone.


Since the iPhone is creating calendar entries fine and it can see 
everything I create on Thunderbird fine, I don't think it is an 
iPhone config. issue. *I set it to sync everything (not only the last 
2 months). *
Oops missed that part... I don't have an iPhone and the users that I do 
know that have iPhone don't have this issue, sorry.




How can I troubleshoot this? My guess is that the CalDAV entry 
created on the web interface is missing something...


Thank you very much.

Best,
Daniel Colchete

--
users@sogo.nu
https://inverse.ca/sogo/lists

Re: [SOGo] SOGo doesn't display email anymore

2012-05-22 Thread Aaron C Johnson
So now try clearing your cache, change computers, change browsers. Try 
as many different combinations of different computers and different 
browsers and clearing your cache as you can until you get it to work! If 
it still does not work then I am stumped.


On 05/22/2012 03:20 AM, James James wrote:

I rebooted the entire server but nothing special.

I don't have the error message anymore (unexpected envelope address) 
but the mail tab is always empty.



2012/5/21 Aaron C Johnson acjohn...@pcdomain.com 
mailto:acjohn...@pcdomain.com


James James wrote:

Thanks for your answer Christian,

but� I saw this post and the restart-clear-the-cache action
doesn't work for me. The mail tab is still empty.

Regards

James- Try restarting the entire server if you can. Most likely
you have a stale sogod process hanging around that won't close out
so you might need to reboot.




2012/5/21 Christian Mack christian.m...@uni-konstanz.de
mailto:christian.m...@uni-konstanz.de

Hello James James


On 2012-05-20 23:44, James James wrote:

 since the sogo-1.3.15, my users email cannot been
displayed. The
 calendar works well but no email.
 I've got this error message :

 May 20 21:27:00 sogod [13044]: [WARN]
 0x0x1dbf878[UIxEnvelopeAddressFormatter] unexpected
envelope address:
 0x0x1e7b5e8[NGImap4EnvelopeAddress]:
 May 20 21:30:01 sogod [13044]: [WARN]
 0x0x442dde8[UIxEnvelopeAddressFormatter] unexpected
envelope address:
 0x0x43502d8[NGImap4EnvelopeAddress]:

 Can sombody help me ?


There was a thread about this just 2 days back.

A) You have to stop sogod and start it up again.
Restart is not sufficient.
B) If your users have problems afterwards, they have to clear
their
browser cache.


Kind regards,
Christian Mack

--
Christian Mack
Gruppe Informationsdienste
Rechenzentrum Universit�t Konstanz





--
users@sogo.nu
https://inverse.ca/sogo/lists

Re: [SOGo] SOGo doesn't display email anymore

2012-05-21 Thread Aaron C Johnson

  
  
James James wrote:
Thanks for your answer Christian,
  
  but I saw this post and the restart-clear-the-cache action
  doesn't work for me. The mail tab is still empty.
  
  Regards

James- Try restarting the entire server if you can. Most likely you
have a stale sogod process hanging around that won't close out so
you might need to reboot.


  2012/5/21 Christian Mack christian.m...@uni-konstanz.de
Hello James
  James
  

  
  On 2012-05-20 23:44, James James wrote:
  
   since the sogo-1.3.15, my users email cannot been
  displayed. The
   calendar works well but no email.
   I've got this error message :
  
   May 20 21:27:00 sogod [13044]: [WARN]
   0x0x1dbf878[UIxEnvelopeAddressFormatter]
  unexpected envelope address:
   0x0x1e7b5e8[NGImap4EnvelopeAddress]:
   May 20 21:30:01 sogod [13044]: [WARN]
   0x0x442dde8[UIxEnvelopeAddressFormatter]
  unexpected envelope address:
   0x0x43502d8[NGImap4EnvelopeAddress]:
  
   Can sombody help me ?
  
  

  
  There was a thread about this just 2 days back.
  
  A) You have to stop sogod and start it up again.
  Restart is not sufficient.
  B) If your users have problems afterwards, they have to clear
  their
  browser cache.
  
  
  Kind regards,
  Christian Mack
  
  --
  Christian Mack
  Gruppe Informationsdienste
  Rechenzentrum Universitt Konstanz

  
  

  



Re: Browser cache and upgrades (Was: Re: [SOGo] ANN: SOGo v1.3.15)

2012-05-19 Thread Aaron C Johnson

Romain LE DISEZ wrote:

Hi all,

Le Vendredi 18 Mai 2012 18:40 CEST, Jean Rabyjr...@inverse.ca  a écrit:

However, if SOGo is _not_ restarted after the upgrade, the client will
see a mostly empty page.

sogod should be automatically restarted after an upgrade. That's how packages 
work in RHEL (eg: httpd, postgresql) and Debian.

About that... Both times that I did the upgrade, first to 1.3.15 and 
then to 1.3.15a on debian 6 64-bit, it reported that it restarted the 
service during the installation but it didn't actually kill the old 
sogod process...


I know this because I always tell daemons to restart after an upgrade 
whether apt-get says that they restarted or not (I don't trust it and 
for good reason).


Directly after telling sogod to restart after the upgrade it tells me 
that it's not running and that it is starting sogod. Then I do a 
/etc/init.d/sogod stop and a ps -A | grep sogod and I see that there is 
still a sogod process hanging around.


I have to do a killall -9 sogod to get rid of the stale process and then 
I can start and restart sogod without issue.


--
users@sogo.nu
https://inverse.ca/sogo/lists


Re: [SOGo] ANN: SOGo v1.3.15

2012-05-16 Thread Aaron C Johnson
I had the same problem with all the emails disappearing in the web 
interface. I just rebooted the server and cleared the browser cache and 
all was well :)


Excellent work Inverse Team :)



On 05/16/2012 01:29 AM, Relu Parfene wrote:

On 16.05.2012 02:20, Ludovic Marcotte wrote:

The Inverse Team is pleased to announce the immediate availability of
SOGo 1.3.15. This is a minor release of SOGo which focuses on improved
stability over previous versions.


Hello,

I updated to sogo 1.3.15 and all sope modules. I restarted sogo and
memcached. After these operations in the web interface all mails are
gone (including IMAP folders). I restarted the browser, I re-entered the
web interface. The situation was the same. I did refresh the page (F5)
and everything returned to normal. Awesome. I also noticed that the
annoying card icon following the mouse disappeared in contacts page
(after click on a contact in the shared address book). Absolutely awesome.

Thank you very much for the great work.

--
Relu




--
users@sogo.nu
https://inverse.ca/sogo/lists