Re: [xwiki-users] Xwiki file and attachment storage

2007-08-30 Thread Vincent Massol
On Aug 30, 2007, at 4:44 PM, bjquinn wrote: vmassol wrote: Google is your friend... :) For example, at random: http://www.onjava.com/pub/a/onjava/2006/10/04/what-is-java-content- repository.html -Vincent Sure, Google is my friend. :) What I was wanting to know, though, is

Re: [xwiki-users] Xwiki file and attachment storage

2007-08-30 Thread Vincent Massol
On Aug 30, 2007, at 5:19 PM, bjquinn wrote: http://jackrabbit.apache.org/faq.html#whats-fs wrote: What is a Jackrabbit file system? A Jackrabbbit file system (FS) is an internal component that implements standard file system operations on top of some underlying storage mechanism (a

Re: [xwiki-users] Languages preferences

2007-09-03 Thread Vincent Massol
Hi Marc, On Sep 4, 2007, at 12:23 AM, Marc Lijour wrote: [snip] It would really be helpful if the datamodel were documented somewhere (so that Sergiu could do something else than repeat the same things over and over...). Just my 0.02$. There was a try done there a long time ago:

Re: [xwiki-users] Error

2007-09-05 Thread Vincent Massol
Hi Adel, This is fine and normal. It's not important and it was fixed in 1.1. BTW we recommend migrating to 1.1RC1. Thanks -Vincent On Sep 5, 2007, at 12:20 PM, Adel Aneiba wrote: Dear All, I have just configured xwiki version 1.0 and it seems to me it works fine, but when i looked at

Re: [xwiki-users] PDF on 1.1RC1

2007-09-05 Thread Vincent Massol
-Vincent On Sep 5, 2007, at 9:25 PM, Vincent Massol wrote: Hi Brandon, I was able to get something similar to you by going offline and exporting the Blog.WebHome page in the default XE wiki: 21:18:04,900 WARN P1-19 http://localhost:8080/xwiki/bin/export/ Blog/WebHome?format=pdf

Re: [xwiki-users] PDF on 1.1RC1

2007-09-06 Thread Vincent Massol
Hi Brandon, Could you send us a page that has this problem so that I can try to reproduce it? Thanks -Vincent On Sep 5, 2007, at 10:00 PM, Vincent Massol wrote: My error was slightly different. In my case it's because we don't have the xhtml1-transitional.dtd file locally. Brandon

Re: [xwiki-users] How to add properties to a new class?

2007-09-06 Thread Vincent Massol
Hi Gerard, On Sep 5, 2007, at 10:36 AM, Geert Verhaag wrote: Hoi XWiki Users, Because I couldn't find any clear answer to my problem on www.xwiki.org, I turn to this list! I want to define a new class, and have reached: The first thing to do is to Edit the Class to add properties to it.

Re: [xwiki-users] Backlinks and classes

2007-09-06 Thread Vincent Massol
Hi Marco, On Sep 6, 2007, at 10:23 AM, Marco Polo wrote: Hi, I am a newcomer to Xwiki. I want some page created to be based on a template and so I created class and class sheet. It works, but if I put a link in page A (based on template) to page B, this link is not referenced in backlinks

Re: [xwiki-users] HELP: Cannot save new panel layout and preferences while logged in as Admin

2007-09-06 Thread Vincent Massol
Hi Gerard, On Sep 6, 2007, at 2:52 PM, Geert Verhaag wrote: Hi Vincent, Yes, you're right but according to xwiki-992 at jira.xwiki.org I thought that issue was not completely settled yet. That's why I decided for this new thread. As you can see on

Re: [xwiki-users] Problem with character in search engine (xwiki 1.1RC1 + 1.1M4)

2007-09-06 Thread Vincent Massol
Hi Pascal, This is a know issue. Apparently it's a combination of: FF + Tomcat + GET request. See http://jira.xwiki.org/jira/browse/XWIKI-1449 for more details (Jerome has analyzed the problem and will update the issue with more information soon). We don't have a perfect solution yet and

Re: [xwiki-users] LDAP - importing users

2007-09-14 Thread Vincent Massol
Raff, That looks like a very interesting code snippet to put in the code zone (as a Code Snippet)! -Vincent On Sep 14, 2007, at 10:28 AM, Raffaello Pelagalli wrote: [EMAIL PROTECTED] writes: Is there any way I can import users into XWiki from an LDAP source. I am currently

Re: [xwiki-users] Xwiki OC4J in Oracle App Server 10.1.2.2

2007-09-14 Thread Vincent Massol
PROTECTED] On Behalf Of Vincent Massol Sent: Friday, September 14, 2007 2:15 AM To: XWiki Users Subject: Re: [xwiki-users] Xwiki OC4J in Oracle App Server 10.1.2.2 On Sep 14, 2007, at 2:41 AM, Matthew Huff wrote: Has anyone got any version of Xwiki running under OC4J running on Oracle

[xwiki-users] New performance page in the Admin guide

2007-09-20 Thread Vincent Massol
Hi everyone, FWIW, I've started a new page in the admin guide to track the different ways of improve XWiki's performances. Please feel free to add other solutions in there: http://www.xwiki.org/xwiki/bin/view/AdminGuide/Performances Thanks -Vincent

[xwiki-users] [ANN] XWiki Enterprise Manager 1.0 Milestone 1 Released

2007-09-20 Thread Vincent Massol
The XWiki development team is pleased to announce the release of XWiki Enterprise Manager (XEM) 1.0 Milestone 1. XEM is a special wiki (based on XWiki Enterprise) used to manage a farm of sub-wikis. It has an interface to create new sub-wikis from templates, delete wikis, view all created

Re: [xwiki-users] xwiki and mysql5 fails

2007-09-20 Thread Vincent Massol
Hi ossi, Why don't you check the Installation guide on xwiki.org? :) http://www.xwiki.org/xwiki/bin/view/AdminGuide/Installation You'll see that it has a section about MySQL: http://www.xwiki.org/xwiki/bin/view/AdminGuide/InstallationMySQL The dialect there is different from the one you used.

Re: [xwiki-users] xwiki and mysql5 fails

2007-09-21 Thread Vincent Massol
ossi Vincent Massol schrieb: Hi ossi, Why don't you check the Installation guide on xwiki.org? :) http://www.xwiki.org/xwiki/bin/view/AdminGuide/Installation You'll see that it has a section about MySQL: http://www.xwiki.org/xwiki/bin/view/AdminGuide/InstallationMySQL The dialect

Re: [xwiki-users] xwiki and mysql5 fails

2007-09-21 Thread Vincent Massol
that installation wizard. I have created this jira issue: http://jira.xwiki.org/jira/browse/XWIKI-1761 Thanks for this feedback! -Vincent Vincent Massol schrieb: Hi ossi, On Sep 21, 2007, at 12:48 AM, ossi petz wrote: Hallo I did read those pages. I promise! Really! I mean it! Initially it didnt

Re: [xwiki-users] [ANN] XWiki Enterprise Manager 1.0 Milestone 1Released

2007-09-21 Thread Vincent Massol
Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Vincent Massol Sent: 20 September 2007 17:03 To: XWiki Developers; XWiki Users Subject: [xwiki-users] [ANN] XWiki Enterprise Manager 1.0 Milestone 1Released The XWiki development team is pleased to announce the release

Re: [xwiki-users] HTML tags and blog macro can destroy HTML formatting of the page

2007-09-23 Thread Vincent Massol
Hi Guido, Looks like you're talking about this one: http://jira.xwiki.org/jira/browse/XE-50 The current solution is to use the extract field manually. Thanks -Vincent On Sep 23, 2007, at 1:26 AM, G.Schoepp wrote: Hi, there is a problem with the blog macro (Blog.Macros) when content

Re: [xwiki-users] Problems with Panels

2007-09-24 Thread Vincent Massol
On Sep 24, 2007, at 12:07 PM, Vincent Massol wrote: Hi Dennis, I've confirmed the problem and created a jira issue: http://jira.xwiki.org/jira/browse/XAPANELS-35 While waiting for this bug to be fixed I think there's a workaround. Try Importing the Panels XAR (or the full XE XAR

Re: [xwiki-users] Problems with Panels

2007-09-24 Thread Vincent Massol
to edit a table! Regards, -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Behalf Of Dennis Rasey Sent: 24 September 2007 14:13 To: XWiki Users Subject: Re: [xwiki-users] Problems with Panels Vincent Massol wrote: On Sep 24, 2007, at 12:07 PM, Vincent

Re: [xwiki-users] When adding a new page, can a standard template be used?

2007-09-26 Thread Vincent Massol
Hi Sheila, On Sep 26, 2007, at 3:15 PM, Sheila Hobeck wrote: Ok, so I figured it out. The tutorial should be updated for the latest release. It doesn't describe the process to associate the object very well. Anyhow, thanks just the same. Since you figured it out, could you please

Re: [xwiki-users] Include of Sections

2007-09-27 Thread Vincent Massol
Hi SJB, Ok, I've checked the source code and I see it's not fully supported as an API. However it's possible to do but it requires to have programming rights. There's a method in XWikiDocument: public String getContentOfSection(int sectionNumber) throws XWikiException So calling the

Re: [xwiki-users] xwiki experience

2007-09-27 Thread Vincent Massol
Hi Juri, On Sep 27, 2007, at 7:46 PM, Artamonov, Juri wrote: HI All, just would like to share my first week usage experience with xwiki. That's great tool and helped me at work but what I see I need to know it better and deeper. This is not easy to follow WYSIWYG editor since its

Re: [xwiki-users] Can I setup XWiki as a windows service?

2007-09-28 Thread Vincent Massol
Hi Sheila, On Sep 28, 2007, at 3:43 PM, Sheila Hobeck wrote: Is there a batch file that can do this for me? And yes I wish we were using a non-Windows server, however... XWiki is running in the servlet container you've chosen to use. Check the documentation for that servlet container and

Re: [xwiki-users] Can I setup XWiki as a windows service?

2007-09-28 Thread Vincent Massol
to the installation notes? I'd add it in the AdminGuide somewhere but yes that'd be great if you could add it when you get it working. Thanks! -Vincent On 9/28/07, Vincent Massol [EMAIL PROTECTED] wrote: Hi Sheila, On Sep 28, 2007, at 3:43 PM, Sheila Hobeck wrote: Is there a batch file that can do

Re: [xwiki-users] Xwiki database scripts. Xwiki offline documentation

2007-09-28 Thread Vincent Massol
Hi Ian, On Sep 28, 2007, at 2:22 PM, Ian Berry wrote: Hi, I am having trouble finding database scripts to generate the XWiki database. Where are these located? All the installation docs are available here: http://www.xwiki.org/xwiki/bin/view/AdminGuide/Installation Check the part that

Re: [xwiki-users] xwiki experience

2007-09-28 Thread Vincent Massol
PROTECTED] On Behalf Of Vincent Massol Sent: Thursday, September 27, 2007 9:34 PM To: XWiki Users Subject: Re: [xwiki-users] xwiki experience Hi Juri, On Sep 27, 2007, at 7:46 PM, Artamonov, Juri wrote: HI All, just would like to share my first week usage experience with xwiki

Re: [xwiki-users] Backlinks in XWiki 1.1

2007-09-28 Thread Vincent Massol
Hi Marco, I don't recall if I answered this email. I was wrong and you were right. Backlinks were indeed broken in 1.1 (they've been broken since 1.1RC2). I've fixed them in 1.1.1 which will be released in the coming few days. Thanks -Vincent On Sep 20, 2007, at 9:56 AM, Marco Polo wrote:

Re: [xwiki-users] migration from old XWiki to XWiki new

2007-09-28 Thread Vincent Massol
Hi Bikram, On Sep 28, 2007, at 8:39 PM, BIKRAMJIT SINGH wrote: my company is running XWiki old and using databse MYSql... they want me to migrate it to new XWikican you please suggest how to accomplish it Could you try following the information in the release notes and see if you

[xwiki-users] [ANN] XWiki Enterprise 1.1.1

2007-09-29 Thread Vincent Massol
The XWiki development team is pleased to announce the release of XWiki Enterprise 1.1.1. This is a bug fix release. It's a stable release. Everyone using XWiki Enterprise 1.1 should upgrade to it. Bugs fixed in 1.1.1: * Fullscreen doesn't work on IE6 or IE7 * Cache issue on new

Re: [xwiki-users] How to include content from HTTP response

2007-10-03 Thread Vincent Massol
Hi, On Oct 3, 2007, at 3:25 PM, Robin François-Xavier wrote: Hi, I've got a CVS repository with a web frontend. I can access the source codes (java) via URL. I found the {code} macro but it only displays embedded code. How can I include my remote code using HTTP ? See

[xwiki-users] [ANN] XWiki Enterprise 1.2M1 Released

2007-10-03 Thread Vincent Massol
The XWiki development team is pleased to announce the release of XWiki Enterprise 1.2 Milestone 1. Go grab it at http://www.xwiki.org/xwiki/bin/view/Main/Download Main changes from 1.1.1: * Document history is now kept in a separate table in the database which means that Document load

Re: [xwiki-users] Create external hyperlinks?

2007-10-04 Thread Vincent Massol
Hi Hande, On Oct 4, 2007, at 2:25 PM, Hande Aksac wrote: If there any way that you create an external hyperlink without using the WYSIWYG editor? http://www.xwiki.org/xwiki/bin/view/UserGuide/XWikiSyntax Thanks -Vincent On 10/4/07, Esbach, Brandon [EMAIL PROTECTED] wrote: If you just

Re: [xwiki-users] [xwiki-devs] Meetup in Silicon Valley in October

2007-10-04 Thread Vincent Massol
. Here's the address: Terracotta Inc. 650 Townsend St. Suite 325 San Francisco, CA 94103 USA +1 415 738 4059 I hope to see a lot of you there! Thanks -Vincent On Oct 1, 2007, at 4:12 PM, Vincent Massol wrote: Hi there, I'm pinging again as the date is approaching. So far we have 2 people who

Re: [xwiki-users] [ANN] XWiki Enterprise 1.2M1 Released

2007-10-05 Thread Vincent Massol
. Simply don't use it in production :) thanks -Vincent -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Behalf Of Vincent Massol Sent: 04 October 2007 17:38 To: XWiki Users Subject: Re: [xwiki-users] [ANN] XWiki Enterprise 1.2M1 Released On Oct 4, 2007, at 6:21

Re: [xwiki-users] error while parsing velocity page

2007-10-06 Thread Vincent Massol
Hi Ericka, We would need more information in order to be able to help you. For example could you send the full stack trace? (click on the link in the error below and you'll get the full stack trace) Thanks -Vincent On Oct 4, 2007, at 5:35 PM, Ericka Overgard wrote: Just started

Re: [xwiki-users] New Pages - Tags with multiwords

2007-10-07 Thread Vincent Massol
Hi Josh, On Oct 7, 2007, at 4:18 PM, Josh Joy wrote: Hi, When I create a new page, I am given the option to create tags to help annotate the document. However, my question is, how can I create multiword tags? For instance, I would like a tag as San Diego. What xwiki does is break the tag

Re: [xwiki-users] Page preferences

2007-10-16 Thread Vincent Massol
Hi, On Oct 16, 2007, at 8:11 AM, V. Harikrishnan Nair wrote: Hi all, I am able to change preferences of the entire wiki and a space. Can I make preference changes to a specific page ? For example, if I do not want the comments and attachments boxes to appear in some pages, the

Re: [xwiki-users] More on upgrade from 0.9

2007-10-16 Thread Vincent Massol
Hi Victor, On Oct 16, 2007, at 5:23 PM, Víctor A. Rodríguez wrote: Hi all, as anyone can see there's a first attempt to upgrade from v0.9 in http://www.xwiki.org/xwiki/bin/view/AdminGuide/ Installation#HUpgradinganXWikiv09Installation The problem with this approach is that it just

Re: [xwiki-users] Panel Wizard

2007-10-22 Thread Vincent Massol
On Oct 23, 2007, at 6:44 AM, V. Harikrishnan Nair wrote: Hi all. My Panel wizard is not working properly. I tried to drag and drop my panel items and it could not be done. The item which when I click upon, does not move with the mouse pointer. It goes elsewhere. Nobody has

Re: [xwiki-users] Shifting to a new computer

2007-10-24 Thread Vincent Massol
Hi Hari, As suggested just export and re-import from the Administration page. Someone mentioned that the export feature is broken. I haven't found so. I think this person meant that it's not working only when trying to import an old XWiki 0.9 version in a new 1.1 version. AFAIK it's not

Re: [xwiki-users] About LDAP patch XWIKI-1079

2007-10-24 Thread Vincent Massol
Hi Tobias, On Oct 24, 2007, at 10:39 AM, [EMAIL PROTECTED] wrote: Hi The patch mentioned in the subject has been in Jira since April 2007. What is the status of this? I have seen http://www.xwiki.org/xwiki/bin/view/Design/ FilteringLDAPauthenticatedUsers and it looks like everything

Re: [xwiki-users] Change Admin password errors

2007-10-24 Thread Vincent Massol
Hi Israa, Could you show us the full strack trace you get? What version of XWiki are you using? Thanks -Vincent On Oct 24, 2007, at 5:35 PM, Israa Taha wrote: Every time I try to change the Admin password, I get an error (Exceptions occuring when loading and updating XWiki.Admin).

Re: [xwiki-users] Shifting to a new computer

2007-10-24 Thread Vincent Massol
On Oct 24, 2007, at 5:24 PM, Víctor A. Rodríguez wrote: Hi Vincent, Vincent Massol wrote: Hi Hari, As suggested just export and re-import from the Administration page. Someone mentioned that the export feature is broken. I haven't found so. I think this person meant that it's

Re: [xwiki-users] Shifting to a new computer

2007-10-24 Thread Vincent Massol
On Oct 24, 2007, at 7:28 PM, Víctor A. Rodríguez wrote: Vincent Massol wrote: On Oct 24, 2007, at 5:24 PM, Víctor A. Rodríguez wrote: Hi Vincent, Vincent Massol wrote: Hi Hari, As suggested just export and re-import from the Administration page. Someone mentioned that the export

Re: [xwiki-users] Change Admin password errors

2007-10-25 Thread Vincent Massol
/24/07, Vincent Massol [EMAIL PROTECTED] wrote: Hi, Have you moved from an older version to 1.1.1 or is this a fresh install? The error seems to be: Exception while manipulating the archive for doc Wrapped Exception: Parse error at line 1, column 101. Encountered: Taha So it looks like

Re: [xwiki-users] ccomo me conecto a la base de datos

2007-10-25 Thread Vincent Massol
Hey guys, while it's fun to have some exotic languages here, it's not really nice to the XWiki community since most people can't 1) help and 2) benefit from the question and answers. Could you please revert to english since this is an english speaking mailing list? :) Muchas gracias

Re: [xwiki-users] Shifting to a new computer

2007-10-25 Thread Vincent Massol
On Oct 25, 2007, at 11:41 AM, V. Harikrishnan Nair wrote: vmassol wrote: Re HSQLDB yes, you can also very simply copy the $XWIKINSTALLDIR/ database/ directory to the new computer too but the import/export will work between any databases and should be preferred. Sorry for 'turning a blind

Re: [xwiki-users] Live bookmark...

2007-10-29 Thread Vincent Massol
On Oct 29, 2007, at 2:02 PM, V. Harikrishnan Nair wrote: Oh great ! Will there be a notice on this forum ? Yes. Should be released in 1 or 2 days. -Vincent Guillaume Lerouge wrote: Hi, you will probably find a satisfying solution to this problem by using the watchlist feature that

Re: [xwiki-users] Editing breaks out of frames

2007-10-29 Thread Vincent Massol
Hi Andrew, We do have a JIRA issue opened for this at http://jira.xwiki.org/jira/browse/XWIKI-1072 Now all we need is a patch to fix it ;) Thanks -Vincent On Oct 29, 2007, at 12:50 PM, Andrew Saunders wrote: I have xwiki running within an existing frames-based system. Love them or hate

Re: [xwiki-users] Sample Groovy Code

2007-10-30 Thread Vincent Massol
Hi, Don't call the database directly. XWiki offers API for doing this. What tutorial are you referring to? Thanks -Vincent On Oct 30, 2007, at 11:53 AM, V. Harikrishnan Nair wrote: Hi all... I am learning how to read from the default xwiki database xwiki_db using groovy. This is the

Re: [xwiki-users] Xwiki file and attachment storage

2007-10-30 Thread Vincent Massol
Hi, On Oct 30, 2007, at 9:03 PM, bjquinn wrote: Is that what you mean? And is this Jackrabbit stuff ready by v1.1? Nope. This is 1.2 stuff. Well, 1.2 is almost here... is the jackrabbit stuff ready, and can I store attachments in files?? Sorry but no. The scope for 1.2 was changed

Re: [xwiki-users] Adding a document in XWiki.org

2007-10-31 Thread Vincent Massol
On Oct 31, 2007, at 7:57 AM, V. Harikrishnan Nair wrote: Hello... I've been able to read and enter data into my personal MySQL database (after a very long night, finally!) and I think this should be added into the documentation for XWiki.org but first, I want to get data from a

Re: [xwiki-users] Sample Groovy Code

2007-10-31 Thread Vincent Massol
First, you need to tell us what's your use case. What information do you wish to get from the database? Thanks -Vincent On Oct 31, 2007, at 6:19 AM, V. Harikrishnan Nair wrote: Hello Vincent, I've found out QueryPluginApi from the docs. But even if this is the API you meant, why is

Re: [xwiki-users] Adding a document in XWiki.org

2007-10-31 Thread Vincent Massol
for doing this in XWiki is to create an Object and let XWiki save that Object to the database. Hope it makes sense, -Vincent On Oct 31, 2007, at 9:21 AM, Your XEN ICT Team - Ricardo Rodriguez wrote: Vincent Massol wrote: You're the first one I see to have this need so I'm curious

Re: [xwiki-users] Adding a document in XWiki.org

2007-10-31 Thread Vincent Massol
) I hope this is clear enough... :-) Xwiki is serving its purpose but I guess just wanted to bend it a bit too much ! Harikrishnan Ricardo Rodríguez wrote: Vincent Massol wrote: Since I was probably not clear let me try to rephrase what I meant: 1) If what you to manipulate is data

Re: [xwiki-users] Adding a document in XWiki.org

2007-10-31 Thread Vincent Massol
Guys, this looks like a good topic for adding to the API guide at http://www.xwiki.org/xwiki/bin/view/DevGuide/APIGuide It should be mentioned in #warning() box that this is ONLY for data outside of XWiki's control. In addition we should also look at finding out how custom mapping works in

[xwiki-users] Custom mapping doc (was Re: Adding a document in XWiki.org)

2007-10-31 Thread Vincent Massol
On Oct 31, 2007, at 11:49 AM, Vincent Massol wrote: On Oct 31, 2007, at 11:35 AM, V. Harikrishnan Nair wrote: Gosh ! I didn't realise that I could create such an uproar ! :-)) The uproar was caused by the fact that you asked for help without explaining what you wanted to do... If you

Re: [xwiki-users] Class property deletion

2007-11-02 Thread Vincent Massol
... Today's Topics: 1. Re: Porblem Installing w/Oracle (Vincent Massol) 2. Class attributes (goldring, richard) 3. Re: Adding a document in XWiki.org (Esbach, Brandon) 4. Access rights on XWiki space (Marie Sauvage [EBM WebSourcing]) 5. Re: Access rights on XWiki space (Esbach

Re: [xwiki-users] Cannot translate page in xwiki-1.1.1

2007-11-04 Thread Vincent Massol
AFAIK this was fixed for 1.2M2 and 1.1.2. Would be good if one of you could verify it works fine in the new version to be released. You can find nightly builds at http://maven.xwiki.org/releases/. I've also added more detailed links on the download page at:

Re: [xwiki-users] Cannot translate page in xwiki-1.1.1

2007-11-04 Thread Vincent Massol
On Nov 4, 2007, at 10:39 PM, Your XEN ICT Team - Ricardo Rodriguez wrote: Vincent Massol wrote: AFAIK this was fixed for 1.2M2 and 1.1.2. Would be good if one of you could verify it works fine in the new version to be released. You can find nightly builds at http://maven.xwiki.org

Re: [xwiki-users] Disable and hide comments

2007-11-06 Thread Vincent Massol
Would be great if you guys could summarize all this on xwiki.org. I'd put it in the existing configuration guide (in the Admin space). WDYT? Any volunteer? Thanks -Vincent On Nov 6, 2007, at 11:37 AM, V. Harikrishnan Nair wrote: Just for your information - After following Sergiu's steps,

Re: [xwiki-users] Building XWiki from source

2007-11-07 Thread Vincent Massol
On Nov 7, 2007, at 3:59 PM, [EMAIL PROTECTED] wrote: Hi I am attempting to build XWiki from source with the end goal of using a debugger on it and face the following problem: After a successful build with maven, when I deploy the war archive and browse to xwiki, I get the following

Re: [xwiki-users] Cannot undeploy in JBoss

2007-11-09 Thread Vincent Massol
Not sure but what I know is that in 1.1 branch we have an issue with the Lucene plugin since we don't have a shutdown hook for it so when you stop XWiki there might be the Lucene index thread which isn't stopped. Could this be it? Now there seems to be some AWT related issue in the stack

Re: [xwiki-users] SQL files

2007-11-09 Thread Vincent Massol
On Nov 9, 2007, at 5:56 PM, [EMAIL PROTECTED] wrote: Hi David, All tables are created automatically, you just need to create the correct empty shema/database (by default xwiki). For MSSQL to work I had to create my own xwiki.hbm.xml, the default one didn't work. would be nice if you

Re: [xwiki-users] SQL files

2007-11-09 Thread Vincent Massol
On Nov 9, 2007, at 6:09 PM, [EMAIL PROTECTED] wrote: On Nov 9, 2007, at 5:56 PM, [EMAIL PROTECTED] wrote: Hi David, All tables are created automatically, you just need to create the correct empty shema/database (by default xwiki). For MSSQL to work I had to create my own xwiki.hbm.xml,

Re: [xwiki-users] [xwiki-devs] [ANN] XWiki Enterprise 1.1.2 Released

2007-11-11 Thread Vincent Massol
On Nov 11, 2007, at 12:57 PM, Thomas Mortagne wrote: The XWiki development team is pleased to announce the release of XWiki Enterprise 1.1.2. This is a bug fix release following the release of XWiki Platform 1.1.2. This release also introduce experimental new rights management system (not

Re: [xwiki-users] [xwiki-devs] [ANN] XWiki Enterprise 1.1.2 Released

2007-11-11 Thread Vincent Massol
Well done Thomas for your first release! :) -Vincent On Nov 11, 2007, at 12:57 PM, Thomas Mortagne wrote: The XWiki development team is pleased to announce the release of XWiki Enterprise 1.1.2. This is a bug fix release following the release of XWiki Platform 1.1.2. This release also

Re: [xwiki-users] [xwiki-devs] [ANN] XWiki Enterprise 1.1.2 Released

2007-11-11 Thread Vincent Massol
. Thanks -Vincent On Nov 11, 2007, at 1:18 PM, Vincent Massol wrote: On Nov 11, 2007, at 12:57 PM, Thomas Mortagne wrote: The XWiki development team is pleased to announce the release of XWiki Enterprise 1.1.2. This is a bug fix release following the release of XWiki Platform 1.1.2

Re: [xwiki-users] Install problem

2007-11-15 Thread Vincent Massol
Hi Fabian, What version of Java are you running? Thanks -Vincent On Nov 15, 2007, at 8:51 AM, FabianC wrote: Hi! I am trying to get XWiki running on WAS CE 2.0x. I have downloaded the latest version of XWiki and imported the war file into eclipse where I made some needed changes to the

Re: [xwiki-users] How to escape a dot in a link

2007-11-16 Thread Vincent Massol
On Nov 16, 2007, at 10:56 AM, [EMAIL PROTECTED] wrote: Hi, To generate attachment link you can use : {attach:settings.xml} 2007/11/16, [EMAIL PROTECTED] [EMAIL PROTECTED]: Hi I have attached a file named settings.xml and I now want to link to it. How do I do that? [settings.xml]

Re: [xwiki-users] Load balancing XWiki

2007-11-16 Thread Vincent Massol
Hi Ben, On Nov 14, 2007, at 10:40 PM, Ben Vitale wrote: I'm considering replicating XWiki across multiple Tomcat instances, and load balancing them with Apache. Has anyone ever attempted this? I found assorted messages on this forum from ~2005 indicating that XWiki wasn't clusterable,

Re: [xwiki-users] How to escape a dot in a link

2007-11-16 Thread Vincent Massol
Hi Tobias, See the attach macro in the Code zone on xwiki.org Thanks -Vincent On Nov 16, 2007, at 10:48 AM, [EMAIL PROTECTED] wrote: Hi I have attached a file named settings.xml and I now want to link to it. How do I do that? [settings.xml] doesn't work, neither does [settings\.xml]

Re: [xwiki-users] escaping almost everything

2007-11-16 Thread Vincent Massol
Hi Paul, On Nov 16, 2007, at 5:20 PM, Paul Grodt wrote: With the exception of backslashing individual characters, is there any way I could prevent wiki syntax rendering, and Groovy/Velocity rendering? To put it another way, is there any way I can prevent rendering of everything BUT HTML?

Re: [xwiki-users] code macro

2007-11-16 Thread Vincent Massol
Hi Vito, That bug was fixed some time ago in 1.1.1 if my memory is good. -Vincent On Nov 16, 2007, at 2:20 PM, Vitantonio Messa wrote: Hi all, If I wrote this in a wiki page: {code}code1{code} some text {code}code2{code} When the page is displayed, there aren't two code section, but

Re: [xwiki-users] escaping almost everything

2007-11-16 Thread Vincent Massol
On Nov 16, 2007, at 6:11 PM, Paul Grodt wrote: -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Vincent Massol Sent: Friday, November 16, 2007 11:33 AM To: XWiki Users Subject: Re: [xwiki-users] escaping almost everything Hi Paul, On Nov 16

Re: [xwiki-users] XWiki scripting for end user (not Groovy)

2007-11-16 Thread Vincent Massol
On Nov 16, 2007, at 6:03 PM, Paul Grodt wrote: Hi, First: I am rather new to XWiki. I am checking XWiki's scripting capabilities. The possibility of using Groovy and Velocity directly within pages is a nice feature. But I was wondering if there was an easier way to integrate dynamic

Re: [xwiki-users] Xwiki file and attachment storage

2007-11-16 Thread Vincent Massol
Just to be clear. We're all in favor of having the ability to store attachments using webdav. It'll happen eventually. the only thing lacking right now is manpower. Thanks -Vincent On Nov 16, 2007, at 8:47 PM, Pavel wrote: One more upside is that with filesystem attachments you can easily

Re: [xwiki-users] Back-links for custom class instance properties? More general back-link functionality

2007-11-16 Thread Vincent Massol
Hi Andreas, On Nov 17, 2007, at 12:49 AM, Andreas wrote: Is there a way to get the back-links for properties of a custom class instances? This is a current limitation. In the future we'd like to implement renaming of object properties too. See http://jira.xwiki.org/jira/browse/XWIKI-1341

[xwiki-users] [ANN] XWiki Enterprise 1.2M2 Released

2007-11-18 Thread Vincent Massol
The XWiki development team is pleased to announce the release of XWiki Enterprise 1.2 Milestone 2. Go grab it at http://www.xwiki.org/xwiki/bin/view/Main/Download This is the last milestone release for the 1.2 version. It's packed with new features and improvements. The next version will be

Re: [xwiki-users] [ANN] XWiki Enterprise 1.2M2 Released

2007-11-19 Thread Vincent Massol
? If so it should remove the complete XWiki Enterprise directory. Thanks -Vincent After complete folder uninstall, now it works well, thanks ! Regards, Jeremie From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Vincent Massol Sent: lundi 19 novembre 2007 10:39 To: XWiki Users

Re: [xwiki-users] linking an image thumbnail to the original file

2007-11-20 Thread Vincent Massol
On Nov 20, 2007, at 9:55 AM, Your XEN ICT Team - Ricardo Rodriguez wrote: Vincent Massol wrote: Yes, see http://www.xwiki.org/xwiki/bin/view/Code/ImageMacro -Vincent Thanks, Vincent. I'd misread the link= option. Sorry about that. Could it be possible to open it in a new window? Some

Re: [xwiki-users] Camel Case

2007-11-20 Thread Vincent Massol
On Nov 20, 2007, at 9:06 PM, Paul Grodt wrote: What bit of code is inserting spaces into my CamelCase links by default? Is there any easy way to deactivate this? Where is this happening? What are you doing exactly? Thanks -Vincent ___ users

Re: [xwiki-users] Creating Class Error

2007-11-20 Thread Vincent Massol
Looks like there's a bug in your XWiki.Server document. -Vincent On Nov 20, 2007, at 8:39 PM, Campbell, Timothy D wrote: Hello, For the past week and a half I have encountered the same error when I needed to create a class. (below) I only received this error this year because of my

Re: [xwiki-users] Camel Case

2007-11-20 Thread Vincent Massol
On Nov 20, 2007, at 9:48 PM, Paul Grodt wrote: What bit of code is inserting spaces into my CamelCase links by default? Is there any easy way to deactivate this? Where is this happening? What are you doing exactly? Thanks -Vincent I create a page called Main/SamplePage. In

Re: [xwiki-users] Export/Import/Backups

2007-11-21 Thread Vincent Massol
Hi Richard, On Nov 21, 2007, at 4:56 PM, goldring, richard wrote: Hi, I had a problem with importing an XAR running xwiki-enterprise-1.1- milestone-3 and my WinZip program didn't recognise the XAR as zipped file like other XAR files. Is this a known problem? You say you have a XAR that you

Re: [xwiki-users] HSQLDB

2007-11-21 Thread Vincent Massol
On Nov 21, 2007, at 5:02 PM, goldring, richard wrote: Hi, I had my xwiki linux pc crash on me during a powercut and the HSQLDB database seemed to revert to content that was on the xwiki several weeks ago. What's happened? Does hsqldb store data in memory and that is why the data has got

Re: [xwiki-users] Sort error in tags

2007-11-21 Thread Vincent Massol
On Nov 21, 2007, at 6:33 PM, Benoit Hug wrote: Hi, I have the same trouble. I find out that Documents saved with Admin works fine, Documents saved with classic user makes this problem ... How should i do ? It must be using some privileged api which require programming rights. So

Re: [xwiki-users] Why do version numbers increment when nothing has changed in a save?

2007-11-21 Thread Vincent Massol
On Nov 21, 2007, at 8:43 PM, Andreas wrote: Hi, When I click edit on a XWiki page and Save and View or Save and Continue, without making any changes, a new version number is created. This is contrary to existing conventions in SVN, which will intelligently check whether there are any

Re: [xwiki-users] Why do version numbers increment when nothing has changed in a save?

2007-11-22 Thread Vincent Massol
On Nov 22, 2007, at 8:55 AM, William Lesguillier wrote: When I click edit on a XWiki page and Save and View or Save and Continue, without making any changes, a new version number is created. This is contrary to existing conventions in SVN, which will intelligently check whether there are

Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Vincent Massol
On Nov 22, 2007, at 3:51 PM, goldring, richard wrote: Thanks. I'll try the newer version of Eclipse. you can also use the RCP application of course. -Vincent -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Behalf Of Vincent Massol Sent: 22 November 2007 14

Re: [xwiki-users] Improve spanish translation

2007-11-23 Thread Vincent Massol
Hi William, I've answered in the jira issue itself. Thanks -Vinent On Nov 23, 2007, at 9:40 AM, William Lesguillier wrote: Hi, I created a JIRA issue on this: http://jira.xwiki.org/jira/browse/XE-149 and uploaded a new translation as an attachment. Please tell me if the file format is

Re: [xwiki-users] Improve spanish translation

2007-11-23 Thread Vincent Massol
On Nov 23, 2007, at 11:20 AM, William Lesguillier wrote: Hi Vincent, I'm currently using XWiki 1.1.2, the latest stable version. I used the windows installer. I cannot locate the translation files. Is 1.1.2 differing from 1.2 at this level? Are those files from trunk useful to me or should

Re: [xwiki-users] search when not logged in

2007-11-24 Thread Vincent Massol
Hi Josh, On Nov 24, 2007, at 5:27 PM, Josh Joy wrote: Hi, If I search when I log in (as Admin), when I search I receive results back. However, if I log out and repeat the exact same search, the results page is empty. What can I configure to allow people who have not registered to

Re: [xwiki-users] search when not logged in

2007-11-24 Thread Vincent Massol
Actually I've checked further and the Main space isn't excluded so all looks fine to me. -Vincent On Nov 24, 2007, at 5:55 PM, Vincent Massol wrote: Hi Josh, On Nov 24, 2007, at 5:27 PM, Josh Joy wrote: Hi, If I search when I log in (as Admin), when I search I receive results back

Re: [xwiki-users] WebSearch works only for admins

2007-11-24 Thread Vincent Massol
Hi Adoro, On Nov 23, 2007, at 3:30 PM, adoro wrote: Hi, I have the following problem with WebSearch: for some reason users without admin rights cannot see the results of WebSearch. The error message appears on the search page: Topic XWiki.WebSearchCode does not exist Topic

Re: [xwiki-users] search when not logged in

2007-11-24 Thread Vincent Massol
that's causing the issue. Thanks -Vincent On 11/24/07, Vincent Massol [EMAIL PROTECTED] wrote: Actually I've checked further and the Main space isn't excluded so all looks fine to me. -Vincent On Nov 24, 2007, at 5:55 PM, Vincent Massol wrote: Hi Josh, On Nov 24, 2007, at 5:27 PM, Josh Joy

Re: [xwiki-users] search when not logged in

2007-11-24 Thread Vincent Massol
it earlier today. Thanks -Vincent On 11/24/07, Vincent Massol [EMAIL PROTECTED] wrote: On Nov 24, 2007, at 6:23 PM, Josh Joy wrote: Thanks Vincent. I set the WebSearchCode Access Rights to view for XWikiGuest, though still no luck searching if I'm logged out. I can view the pages I'm

Re: [xwiki-users] Newbie to Xwiki

2007-11-26 Thread Vincent Massol
On Nov 26, 2007, at 12:11 AM, Your XEN ICT Team - Ricardo Rodriguez wrote: Robert Hercz wrote: Hi, We are trying out XWiki, TWiki, DokuWiki and MediaWiki, to see which will fit best in our organization as a general collaboration and information tool, for both ever changing project

  1   2   3   4   5   6   7   8   9   10   >