Am Donnerstag, 15. Februar 2018 11:54:12 UTC+1 schrieb PMario: > > I'm not really happy with that name: uniq. IMO uniq has a completely > different meaning > <https://www.google.com/url?q=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FUniq&sa=D&sntz=1&usg=AFQjCNGM8axI8g-3Y7OkL939mkmkDhuURQ>. > > It removes existing duplicates. >
Okay… uniq is for adjacent identical lines. I'm happy to use the name "unique" > ... I think tw each operator already does this! > Please follow the discussion. "each" does this plus a bit more. This "a bit more" is the main reason for "uniq(ue)" > For me the each-operator is similar to the js-function forEach. eg: ["a", > "b", "c"].forEach() ... > For me - not ;) > So my proposal would be a new operator named: foreach > No. Absolutely no. Because "foreach" implies that you want to do some common operation with each input element. That's not the case here. > c) I'm happy to do b) ;) > > I'd be happy to test it. > Already did, But it's still called "uniq". -- You received this message because you are subscribed to the Google Groups "TiddlyWikiDev" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To post to this group, send email to [email protected]. Visit this group at https://groups.google.com/group/tiddlywikidev. To view this discussion on the web visit https://groups.google.com/d/msgid/tiddlywikidev/610a5466-610f-4938-8b19-c257d9ce5ef1%40googlegroups.com. For more options, visit https://groups.google.com/d/optout.
