On Mon, 7 Aug 2017 16:08:00 +0200
"yayo (j)" <jag...@gmail.com> wrote:

> >
> > This is the problem!
> >
> > I looked at the packages for conflict and figured the issue is in gnpug.
> > Zentyal repository contains gnupg version 2.1.15-1ubuntu6 which breaks
> > python-apt <= 1.1.0~beta4.
> >
> >  
> Ok, thank you! Any workaround (something like packege pinning?) to fix this
> problem?

Package pinning is probably not a good idea. I've noticed that there are
some libraries that require gnupg >= 2.x and you would not be able to
install those. They came from Zentyal repo so I assume they might be
essential for some features.

Better workaround is to download newer python-apt from here [1] and
install it manually with dpkg. The guest agent seems to work OK with it.
There's much less chance of breaking something else, also newer
python-apt will be picked-up automatically on upgrades.

    Tomas


[1] https://packages.ubuntu.com/yakkety/python-apt

-- 
Tomáš Golembiovský <tgole...@redhat.com>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to