I just tried that with development version of Zentyal and it works for
> me. Well, there are some caveats, see below.
Please provide steps not just "works for me" ... Thank you

> > Just wanted to add my input.  I just recently noticed the same thing.
> > Luckily i was just testing Zentyal, but when I installed python-apt after
> > reading the error message, apt seemed to completely break.  I would be
> > curious on a workaround/fix for this as well.
> Could you be more specific? What was the problem? Was it problem with
> python-apt per-se or with ovirt-guest-agent using python-apt?
In the past with Zentyal 5 Dev Edition I had the same error: Added
suggested repository that want install "python-apt" and remove "apt-get"
(because conflicts)

> >
> >
> > On Fri, Aug 4, 2017 at 9:28 AM, yayo (j) <jag...@gmail.com> wrote:
> >
> > > Hi all,
> > >
> > > I have this problem: I'm tring to install the guest tools following
> this
> > > guide: https://www.ovirt.org/documentation/how-to/guest-
> > > agent/install-the-guest-agent-in-ubuntu/#for-ubuntu-1604
> I've noticed that the ovirt-guest-agent package available in the
> repository mentioned on the oVirt site is missing dependency on
> qemu-guest-agent. You have to install it additionally for oVirt to work
> properly.

*Steps with repository:*


root@vmdczen01:~# apt-get update
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:2 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Get:3 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:4 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
Hit:5 http://archive.zentyal.org/zentyal 5.0 InRelease
Fetched 306 kB in 0s (325 kB/s)
Reading package lists... Done

*Tring to install:*

root@vmdczen01:~# apt-get install ovirt-guest-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ovirt-guest-agent : Depends: python-apt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

*Zentyal version is: *5.0.8

So, this repository is *totally broken*

> If you, however, instal the ovirt-guest-agent from official Ubuntu
> repository there is different issue. There is this unresolved bug:
> https://bugs.launchpad.net/ubuntu/+source/ovirt-guest-agent/+bug/1609130
> You have to fix permissions on /var/log/ovirt-guest-agent as mentioned
> in the bug report.

The problem is the same, if you remove the extra repisotory and then try to
use the "main" repository, you have the problem with python-apt

Extra tests:

I have tried to install "python-apt" directly and I can reproduce the
problem mentioned by Stewart:

Update (Check that extra repository is commented out):

root@vmdczen01:~# apt-get update
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:2 http://archive.zentyal.org/zentyal 5.0 InRelease [4,887 B]
Get:3 http://it.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:4 http://archive.zentyal.org/zentyal 5.0/main amd64 Packages [28.1 kB]
Get:5 http://archive.zentyal.org/zentyal 5.0/main i386 Packages [6,218 B]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
[325 kB]
Get:7 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:8 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102
Get:9 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201
Get:10 http://it.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196
Get:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
[306 kB]
Get:12 http://it.archive.ubuntu.com/ubuntu xenial/main Translation-en [568
Get:13 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
[7,532 kB]
Get:14 http://it.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
[7,512 kB]
Get:15 http://it.archive.ubuntu.com/ubuntu xenial/universe Translation-en
[4,354 kB]
Get:16 http://it.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
[144 kB]
Get:17 http://it.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages
[140 kB]
Get:18 http://it.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en
[106 kB]
Get:19 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64
Packages [599 kB]
Get:20 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386
Packages [577 kB]
Get:21 http://it.archive.ubuntu.com/ubuntu xenial-updates/main
Translation-en [242 kB]
Get:22 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64
Packages [512 kB]
Get:23 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe i386
Packages [494 kB]
Get:24 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe
Translation-en [199 kB]
Get:25 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64
Packages [15.5 kB]
Get:26 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386
Packages [14.6 kB]
Get:27 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse
Translation-en [7,540 B]
Get:28 http://it.archive.ubuntu.com/ubuntu xenial-backports/main amd64
Packages [4,680 B]
Get:29 http://it.archive.ubuntu.com/ubuntu xenial-backports/main i386
Packages [4,688 B]
Get:30 http://it.archive.ubuntu.com/ubuntu xenial-backports/main
Translation-en [3,216 B]
Get:31 http://it.archive.ubuntu.com/ubuntu xenial-backports/universe amd64
Packages [5,800 B]
Get:32 http://it.archive.ubuntu.com/ubuntu xenial-backports/universe i386
Packages [5,800 B]
Get:33 http://it.archive.ubuntu.com/ubuntu xenial-backports/universe
Translation-en [3,004 B]
Get:34 http://security.ubuntu.com/ubuntu xenial-security/main
Translation-en [138 kB]
Get:35 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64
Packages [7,420 B]
Get:36 http://security.ubuntu.com/ubuntu xenial-security/restricted i386
Packages [7,420 B]
Get:37 http://security.ubuntu.com/ubuntu xenial-security/restricted
Translation-en [2,428 B]
Get:38 http://security.ubuntu.com/ubuntu xenial-security/universe amd64
Packages [152 kB]
Get:39 http://security.ubuntu.com/ubuntu xenial-security/universe i386
Packages [135 kB]
Get:40 http://security.ubuntu.com/ubuntu xenial-security/universe
Translation-en [77.9 kB]
Get:41 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64
Packages [2,748 B]
Get:42 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386
Packages [2,908 B]
Get:43 http://security.ubuntu.com/ubuntu xenial-security/multiverse
Translation-en [1,232 B]
Fetched 27.2 MB in 7s (3,642 kB/s)
Reading package lists... Done

Now, try to install "python-apt":

root@vmdczen01:~# apt-get install python-apt
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
  acl apache2-utils auth-client-config heimdal-clients krb5-config
ldb-tools libapr1 libaprutil1 libassuan0 libauthen-krb5-easy-perl
libdata-hexdumper-perl libfile-libmagic-perl libhdb9-heimdal
  libkadm5srv8-heimdal libkafs0-heimdal libksba8 libldb1
libmodule-pluggable-perl libnet-dns-perl libnet-ntp-perl libnpth0
libnss-winbind libotp0-heimdal libpam-pwquality libpam-winbind
libpwquality-common libpwquality1
  libpython2.7 libquota-perl libreadline7 libsl0-heimdal
libsys-filesystem-perl libtalloc2 libtdb1 libtevent0 libtirpc1 libuuid-perl
libwbclient0 linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic
  linux-image-4.4.0-83-generic linux-image-extra-4.4.0-83-generic ntpdate
python-crypto python-dnspython python-ldb python-samba python-talloc
python-tdb quota rsync samba samba-common samba-common-bin samba-libs
  samba-vfs-modules tdb-tools update-inetd winbind zentyal-ntp
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  python-apt-dbg python-apt-doc
Recommended packages:
*The following packages will be REMOVED:*
*  apt apt-utils gnupg gnupg-agent libgpgme11 pinentry-curses
samba-dsdb-modules ubuntu-minimal zentyal-samba*
The following NEW packages will be installed:
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt gnupg (due to apt)
0 upgraded, 1 newly installed, 9 to remove and 2 not upgraded.
Need to get 139 kB of archives.
After this operation, 8,747 kB disk space will be freed.
*You are about to do something potentially harmful.*
*To continue type in the phrase 'Yes, do as I say!'*
* ?] n*


And this is a BIG problem ... Can I open a bug ? Where?

> Did you run 'apt-get update' to synchronize the repository content?
Yes (see above)
Users mailing list

Reply via email to