On Tue, 2003-03-11 at 15:08, Wil Hatfield - HVHM Customer Care wrote:
> Jason,
> 
> > is in the default domain.  The reason it was failing was because I was
> > not using authvchkpwd...  I was using authmysql...  (and here I thought
> > I was being all cool because I could get it running..)
> 
> Could you elaborate on this segment a bit. I wasn't around for your initial
> post. Are you speaking of installing Vpopmail with authmysql? What was the
> configure parameter for that, --enable-mysql?

Sure...   I initially configured vpopmail to use mysql vith the
--enable-mysql flag...  I then used authmysql (with authdaemon) for
courier...  I turned off all other authentications within courier.

> Reason I ask is because I have installed Vpopmail with mysql and it seems to
> work ok. Everything goes in the table as desired.  But when I get to
> Courier-IMAP I get authentication errors. And before you ask, no I am not
> trying to get it to work with username only. user%virtualdomain.com is how I
> am attempting authentication.

I never tried user%domain.com ... I always used [EMAIL PROTECTED] ... 
Maybe the @ works and the % doesn't?  It's possible that when you use
authvchkpw it properly handles the conversion from % to @ ... I believe
@ is what's in the database...  Might want to give that a whirl...  :)

Actually, reading more it appears that you are using authvchkpw... 
Hrm... curious...

Aha...  I think I found your problem...  Explicitly indicate
--without-authmysql or else it will compile it in because the mysql
libraries are present.  It looks like you're using authdaemon as
well...  I'm told that authdaemon is buggy ...  never encountered that,
but...  *shrug*

Best way to configure courier from what I've seen is to explicitly state
which modules you don't want...  In your case, it looks like you don't
want to use anything except authvchkpw ...

Try that and see what happens..  :)

> Configure History:
> 
> Vpopmail
> ./configure --enable-mysql=y --enable-roaming-users=y --enable-relay-clear-m
> inutes=120 --enable-logging=y --enable-defaultquota=10000000 --enable-softqu
> ota=9000000 --enable-ip-alias-domains=y --enable-tcpserver-file=/sites/home/
> vpopmail/etc/tcp.smtp
> 
> Courier-IMAP
> ./configure --prefix=/usr/local --exec-prefix=/usr/local --without-authldap 
> --without-authshadow --with-authvchkpw --without-authcram --sysconfdir=/usr/
> local/etc/courier-imap --datadir=/usr/local/share/courier-imap --libexecdir=
> /usr/local/libexec/courier-imap --enable-workarounds-for-imap-client-bugs --
> disable-root-check --without-authdaemon
> 
> I copied the config files for courier-imap as shown in the toaster-setup.pl
> script. I didn't install with the toaster script, just looked to it for
> insight. http://matt.simerson.net/computing/mail/toaster/toaster_setup.pl

I gave up on toaster setups...  Gonna write my own with details as to
why I chose each item ...  :P

> If anybody sees any conflicts in the way the two apps were configured your
> help is most appreciated. I get the feeling there is something there I am
> not seeing but for the life of me can't tell what it is.

I hope this helps!

> TIA
> 
> Wil
> 
> 
> 
-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[EMAIL PROTECTED]
RedHat Certified - RHCE # 807302349405893
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to