| /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox

.. which is think is what it's supposed to be set at, no?

On Jun 15, 2004, at 2:46 PM, Alastair Battrick wrote:

Hi James

What is in the .qmail-default for the domain?


James Taylor wrote:
Hi everyone, running vpopmail 5.4 compiled with MySQL (Everything else via Bill's Qmail Toaster) and everything was working just fine until today when I tried to add a domain. Existing domains seem to be working just fine, you can add/delete users fine, information is stored in MySQL and it all looks good. Now though, when I go to add a new domain, just for instance say
./vadddomain testdomain.com testpw
It appears to have added the directory - it creates the domain directory as well as the postmaster maildir, and adds the testdomain_com table to MySQL with the postmaster user. It also adds the testdomain_com information to the dir_control table. However, if I try to send mail to postmaster:
telnet localhost 25
mail from: [EMAIL PROTECTED]
550 sorry, no mailbox here by that name (#5.1.1 - chkusr)
./vuserinfo [EMAIL PROTECTED]
name: postmaster
passwd: $1$YnGeWacE$YYLUcT0Gw.te3HGkRa9lD.
clear passwd: testpw
uid: 0
gid: 0
flags: 0
gecos: Postmaster
limits: No user limits set.
dir: /home/vpopmail/domains/testdomain.com/postmaster
quota: NOQUOTA
usage: NOQUOTA
account created: Tue Jun 15 14:28:53 2004
last auth: Never logged in
Same information listed in the MySQL row.
./vadduser [EMAIL PROTECTED] testpw
...... same results with that user as with postmaster, everything LOOKS good, but nothing works
Looking though the other directories of domains that DO work, I'm noticing they have a file called vpasswd. I've had trouble getting MySQL to completely work, I thought I had it before but now it's acting funky again with this issue. I think what's happening is Vpopmail is using MySQL to store the information, but then it's not using MySQL to retrieve. The weird thing about it though is that I can add users to other domains, make changes to existing domains, and it all takes just fine. It makes the changes in the MySQL DB, and it READS those changes, it's just new domains aren't wanting to work anymore. I tried doing ./vconvert -m -c to see if it was using CDB to store all the user info instead of mysql for some reason, but it still doesn't pick up the user information when trying to send them mail. Gives the same as above.
If anyone could point me in the right direction I'd appreciate it, I've been pulling my hair out for the past couple hours now.

Reply via email to