This is not strange, as you are disabling chkuser.

You have a misconfiguration. You must modify your qmail Makefile, and recompile it, with the lastest vpopmail library you are using.


At 16/06/2004 16/06/2004 -0700, you wrote:
Actually, strangely enough, this DID fix the problem so mail is at least working, but I'm going to have to try to figure out how to get everything else going.

On Jun 16, 2004, at 2:10 AM, Alastair Battrick wrote:

Hi James

I ask because I am having a problem with bounce-no-mailbox. Every domain
(about 6 of them) that had bounce-no-mailbox set, was bouncing everything
including messages to postmaster.

If you could change bounce-no-mailbox to
(ie set the domain to catch all mail to postmaster) and see if that fixes
(albeit temporarily) your problem, it most likely means that we are having
the same problem, and I would like to know why too :)


James Taylor said:
| /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox

.. which is think is what it's supposed to be set at, no?

On Jun 15, 2004, at 2:46 PM, Alastair Battrick wrote:

Hi James

What is in the .qmail-default for the domain?


James Taylor wrote:
Hi everyone, running vpopmail 5.4 compiled with MySQL (Everything
else via Bill's Qmail Toaster) and everything was working just fine
until today when I tried to add a domain.  Existing domains seem to
be working just fine, you can add/delete users fine, information is
stored in MySQL and it all looks good.  Now though, when I go to add
a new domain, just for instance say
./vadddomain testpw
It appears to have added the directory - it creates the domain
directory as well as the postmaster maildir, and adds the
testdomain_com table to MySQL with the postmaster user.  It also adds
the testdomain_com information to the dir_control table.  However, if
I try to send mail to postmaster:
telnet localhost 25
mail from: [EMAIL PROTECTED]
550 sorry, no mailbox here by that name (#5.1.1 - chkusr)
./vuserinfo [EMAIL PROTECTED]
name:   postmaster
passwd: $1$YnGeWacE$YYLUcT0Gw.te3HGkRa9lD.
clear passwd: testpw
uid:    0
gid:    0
flags:  0
gecos: Postmaster
limits: No user limits set.
dir:       /home/vpopmail/domains/
quota:     NOQUOTA
usage:     NOQUOTA
account created: Tue Jun 15 14:28:53 2004
last auth: Never logged in
Same information listed in the MySQL row.
./vadduser [EMAIL PROTECTED] testpw
...... same results with that user as with postmaster, everything
LOOKS good, but nothing works
Looking though the other directories of domains that DO work, I'm
noticing they have a file called vpasswd.  I've had trouble getting
MySQL to completely work, I thought I had it before but now it's
acting funky again with this issue.  I think what's happening is
Vpopmail is using MySQL to store the information, but then it's not
using MySQL to retrieve.  The weird thing about it though is that I
can add users to other domains, make changes to existing domains, and
it all takes just fine.  It makes the changes in the MySQL DB, and it
READS those changes, it's just new domains aren't wanting to work
anymore.  I tried doing ./vconvert -m -c to see if it was using CDB
to store all the user info instead of mysql for some reason, but it
still doesn't pick up the user information when trying to send them
mail.  Gives the same as above.
If anyone could point me in the right direction I'd appreciate it,
I've been pulling my hair out for the past couple hours now.

------------------------------------------------------------ [EMAIL PROTECTED] Interazioni di Antonio Nati [EMAIL PROTECTED] ------------------------------------------------------------

Reply via email to