Hi Pavel
thanks for replying. i want to explain
my whole scenario so that it will be easier to suggest what should i
firstly i configured qmail server and
qmail-pop3d with Maildir format. it was working fine. and than i need
to set user quotas so i googled  and found vpopmail.
i installed it and created new domain,
user and set user quota.
but i was getting error in running
vusaged (/vusaged: error while loading shared libraries: libev.so.3:
cannot open shared object file: No such file or directory)
so i commented out Listen line in
vusaged.conf file than i got this:
config: using /home/vpopmail/etc/vusaged.conf
socket: listening on /tmp/vusaged.sock
vusaged: begin
controller: stage one
controller: stage two
so i think it is working fine now.

but now my problem is in log file i am
getting this error:
delivery 13: success:
and in mailbox also, i get an empty mail without any to: from:
subject and content.
vdominfo is working fine but in vuserinfo i get the same error
client_connect: connect failed: 13
i dont know what should i do....... i
am configuring mail server for the first time and i am not so clear
about the internal processes.... so if anyone can help me in
understanding what vusaged and vusagec do (any link which have all
the explanation) and what should i do to get my mails with all
attributes rather than a blank mail....
hoping to get any solution to my

--- On Wed, 11/25/09, Pavel V. Yanchenko <bal...@msmu.ru> wrote:

From: Pavel V. Yanchenko <bal...@msmu.ru>
Subject: Re[6]: [vchkpw] Issues with vpopmail
To: "abc Xyz" <a_xy...@yahoo.com>
Date: Wednesday, November 25, 2009, 12:00 PM


That's the same location :)

As I understand, client_connect: connect failed message means that
vusage client was not able to connect to vusaged daemon. 
Check your daemon and client config - is client using the same socket as daemon 
does, /tmp/vusaged.sock ?
Is vuserinfo reporting quota usage without error?
However, I must warn that my knowledge is purely theoretical in this field - I 
use maildir-file quota, not vusaged.

  But this errors are not critical - your message got delivered
into mailbox. Now you should check your pop3 or imap software if
mail client is not displaying messages.

Wednesday, November 25, 2009, 2:33:08 PM, you wrote:


No i dont have ~vpopmail/etc/vusagec.conf. i have only domains directory in 
/home/vpopmail~vpopmail directory.
vusaged.conf and vusagec.conf are present in /home/vpopmail/etc directory

>Do you have ~vpopmail/etc/vusagec.conf ?

Wednesday, November 25, 2009, 1:46:48 PM, you wrote:


thanks for the solution. i tried to run the vusaged by commenting out listen 
line in vusaged.conf and now i think i can run it
config: using /home/vpopmail/etc/vusaged.conf
socket: listening on /tmp/vusaged.sock
vusaged: begin
controller: stage one
controller: stage two

 but i m not getting the mails in my
outlook or evolution mail box. i got mail in
directory but not reflecting the same in my graphical mail box.
i am getting error in log file saying:
delivery 13: success:
any suggestions......

--- On Wed, 11/25/09, Pavel V. Yanchenko <bal...@msmu.ru> wrote:

From: Pavel V. Yanchenko <bal...@msmu.ru>
Subject: Re[2]: [vchkpw] Issues with vpopmail
To: "abc Xyz" <vchkpw@inter7.com>
Date: Wednesday, November 25, 2009, 8:16 AM


I guess you should use either 
Filename = 
Listen =
directives in vusaged.conf.
Try, for example, commenting out line with "listen" by putting // in the 
//   Listen =;


Wednesday, November 25, 2009, 9:56:37 AM, you wrote:


i hav given the following commands:
# ln /usr/local/lib/libev.so.3.0.0 /lib/libev.so.3
# ldconfig /lib/
# ldconfig /lib/libev.so.3
 Now i hav libev.so.3 in both /usr/local/lib and /lib
than i tried to run vusaged command without any reinstall or service restart
and i am getting this error:
# ./vusaged
config: using /home/vpopmail/etc/vusaged.conf
socket_init: invalid configuration: Can't use both Socket::Filename and 
socket_init failed

Can u help me in doing proper configuration. any help will be appreciated 

--- On Wed, 11/25/09, Remo Mattei <r...@italy1.com> wrote:

From: Remo Mattei <r...@italy1.com>
Subject: Re: [vchkpw] Issues with vpopmail
To: vchkpw@inter7.com, m...@inter7.com
Date: Wednesday, November 25, 2009, 5:43 AM

Did you try to add the link into the library ldconfig?

Looks like ld does not know where the library
is.. I would add the path and then try to reinstall vpopmail to make
sure just rerun it on top..

Just my 2 cents.


On 11/24/09 10:33 PM, "abc Xyz" <a_xy...@yahoo.com> wrote:

Thanks for the replying Matt but i have already tried it but i am getting the 
same error again. so any other suggestions.

--- On Tue, 11/24/09, Matt Brookings <m...@inter7.com> wrote:

From: Matt Brookings <m...@inter7.com>
Subject: Re: [vchkpw] Issues with vpopmail
To: vchkpw@inter7.com
Date: Tuesday, November 24, 2009, 4:16 PM

Hash: SHA1

abc Xyz wrote:
> i am having a problem with vpopmail server. when i try to run vusaged
> iget the folloeing error.
> #./vusaged
> ./vusaged: error while loading shared libraries: libev.so.3: cannot open
> shared object file: No such file or directory

Try running /sbin/ldconfig.  The ev library needs to be in the dynamic linkers 
- --
    Matt Brookings <m...@inter7.com
</mc/compose?to=m...@inter7.com> >       GnuPG
Key FAE0672C
   Software developer                    Systems technician
    Inter7 Internet Technologies, Inc.     (815)776-9465
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org




Best regards,

Best regards,
 Pavel                            mailto:bal...@msmu.ru

Best regards,
 Pavel                            mailto:bal...@msmu.ru



Reply via email to