Did you check your ~/.bashrc or ~/.cshrc to see if the DISPLAY variable is 
getting unset somewhere....Check /etc/bashrc and /etc/cshrc too depending on 
the shell that is associated with root user.

The config file looks ok.. I mean nothing jumps out as being wrong.

Glad to hear that your edit setting problem got resolved. (Is there anything we 
can do to improve doc, so other users do not run in to similar problem)

/Jd


--- On Thu, 9/4/08, Marco Strullato <[EMAIL PROTECTED]> wrote:

> From: Marco Strullato <[EMAIL PROTECTED]>
> Subject: Re: [convirt-users] edit remote vm files and vnc console
> To: [EMAIL PROTECTED]
> Cc: xenman-users@lists.sourceforge.net
> Date: Thursday, September 4, 2008, 8:02 AM
> Hi
> 
> 
> > Can you do :
> > ssh -p 24 -X
> > And then echo $DISPLAY.
> >
> > Please check your login scripts for the root user too
> see it eh DISPLAY is getting unset.
> If I do ssh -p 24 -X hyp03 from the console machine to a
> hypervisor I
> get an emply DISPLAY variable
> 
> Exactly I get
> 
> 
> Warning: No xauth data; using fake authentication data for
> X11 forwarding.
> 
> VNC Viewer Free Edition 4.1.2 for X - built Mar 14 2007
> 23:13:57
> Copyright (C) 2002-2005 RealVNC Ltd.
> See http://www.realvnc.com for information on VNC.
> vncviewer: unable to open display ""
> 
> You can find logs but I believe they will be unuseful..
> 
> I believe it could be a problem of my xen hvm configuration
> file. What
> do you think?
> 
> kernel = "/usr/lib/xen/boot/hvmloader"
> builder='hvm'
> memory =2048
> shadow_memory = 8
> name = "servername"
> vcpus=2
> #pae=0
> acpi=0
> apic=0
> disk = [ 'phy:/dev/HYP11VM/SERVER,ioemu:hda,w']
> device_model = '/usr/lib64/xen/bin/qemu-dm'
> boot="c"
> #snapshot=1
> sdl=0
> vnc=1
> vncviewer=1
> vnclisten="0.0.0.0"
> #vncconsole=1
> #vncpasswd='abc123'
> #stdvga=1
> #serial='pty'
> #localtime=1
> vif = [ 'type=ioemu, bridge=eth0']
> ne2000=0
> 
> 
> 
> 
> >> > -- When you select a VM and choose Edit
> Settings..
> >> what happens.
> >>
> >> If I select edit It happens anything but if I
> select chenge
> >> a pop up
> >> windows opens.
> >>
> >
> > Bit unclear on when you dont get anything and when
> does a pop up window open. What does open window look like
> (title, contents..) ?
> 
> About this this is a mine mistake. It works
> 
> 
> 
> > Can you please check the convirt.log and send me
> errors/Exception.
> 
> 
> 
> Regards,
> 
> Marco Strullato
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move
> Developer's challenge
> Build the coolest Linux based applications with Moblin SDK
> & win great prizes
> Grand prize is a trip for two to an Open Source event
> anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/_______________________________________________
> XenMan-Users mailing list
> XenMan-Users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/xenman-users


      

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
XenMan-Users mailing list
XenMan-Users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xenman-users

Reply via email to