On 08/02/13 08:14:55 +0100, Sebastian Ramacher wrote:
> On 2013-02-08 19:04:41, Ignas Anikevičius wrote:
> > Just checked it, only glib 2.32 onwards is supported according to the
> > README [1]. So is the if block really necessary? The same is for
> > master. [2]
> Neither the code nor the build system enforce glib >= 2.32. I'm not
> going to break compatibility with older glib versions just because of a
> call to a deprecated function that's a no-op in newer versions of glib.
> Regards
> -- 
> Sebastian Ramacher

Don't get me wrong, I also think, that it would be silly to break it
because of only one call, but maybe the README file should be updated,
so that people know what is the _lowest_ supported version.

Also, as you can see on the glib docs [1], the muttex changes, which I
have done also are for glib >=2.32. I do not know though if zathura
breaks with earlier versions of glib, but, for example, g_mutex_init()
function is not present in glib versions prior to 2.32. 

Also, there were some changes to render.c file previously by Moritz [2],
which also change the mutex stuff in a similar way. There would be less
confusion if there is no check for glib 2.31 and people with old glib
versions (2.32 was tagged about 11 months ago [3]) shouldn't use zathura
development version either way.

However, I will respect any decision you take, but as far as I can see,
having a check for glib 2.31 together with some other code in render.c
and page-widget.c is rather strange.

[1] - 
[2] - 
[3] - http://git.gnome.org/browse/glib/tag/?id=2.32.0

Anyway, I'll respect any decision.

All the best,


P.S. Ubuntu 12.04 LTS has glib 2.32 as well as debian testing, although
it is not in debian stable. Arch has already switched to 2.34.
zathura mailing list

Reply via email to