Mayne wrote:
On Sun, 14 May 2006, Jan Henrik Sylvester wrote:
zd1211: Unknown symbol usb_unlock_device
zd1211: Unknown symbol usb_lock_device_for_reset


Try the patch attached.

Thanks for that suggestion. In the meantime, I already tried almost the same modification but without
+        usb_reset_device(interface_to_usbdev(interface));
for r76. I have retried with that line for r74 and r76. All with the same result:

The driver compiles and loads, but wpa_supplicant fails:
# wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Trying to associate with 00:04:0e:59:70:3d (SSID='sylvester' freq=2412 MHz)
ioctl[SIOCSIWFREQ]: Invalid argument
Association request to the driver failed
Authentication with 00:00:00:00:00:00 timed out.

I have had a connection to that access point with ndiswrapper 1.15 and a different kind of WLAN-USB-stick that I had borrowed (with '-Dndiswrapper'). Thus, the configuration of wpa_supplicant should be fine. (ndiswrapper 1.15 does not load the Windows zd1211u driver and ndiswrapper 1.16 does not compile on my gcc 3.3.5 any more.)

Any further thoughts on how to get wpa_supplicant working with this modified r76?

Regards
Jan Henrik


-------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to