Ok. I tried, apparantly modprobe.conf is deprecated. So, I created 
/etc/modprobe.d/mac80211.conf with:

    options mac80211 ieee80211_default_rc_algo=pid

but that doesn't work; dmesg still shows minstrel is used.

Putting the same line in modprobe.conf gives the same result; minstrel is 
still used.

Bit of a newbie here; never changed modprobe.conf, so I am unsure whether 
adding anything to that file still works since it is deprecated and if not 
what the filename in /etc/modprobe.d/ should be...

Perhaps it helps to know that the iwconfig output is also rather minimal:

wlan0     IEEE 802.11bg  ESSID: [esside deleted]
          Mode:Managed  Frequency:2.437 GHz  Access Point: [mac address 
          Bit Rate=1 Mb/s   Tx-Power=20 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key: [key deleted]
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

So no link quality, signal level and noise level indicated and the Bit Rate 
is not correct; I get speeds that fit with 24 Mb/s or higher...

So something weird is happening with this setup here.

Relevant part of dmesg (mac address of AP masked):

usb 1-1: reset high speed USB device using ehci_hcd and address 2
phy0: Selected rate control algorithm 'minstrel'
zd1211rw 1-1:1.0: phy0
usbcore: registered new interface driver zd1211rw
usb 1-1: firmware: requesting zd1211/zd1211b_ub
usb 1-1: firmware: requesting zd1211/zd1211b_uphr
zd1211rw 1-1:1.0: firmware version 4725
zd1211rw 1-1:1.0: zd1211b chip 0ace:1215 v4810 high 00-25-86 MAXIM_NEW_RF 
pa0 -7---
cfg80211: Calling CRDA for country: DE
wlan0: direct probe to AP --:--:--:--:--:-- (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP --:--:--:--:--:-- (try 1)
wlan0: authenticated
wlan0: associate with AP --:--:--:--:--:-- (try 1)
wlan0: RX AssocResp from --:--:--:--:--:-- (capab=0x411 status=0 aid=4)
wlan0: associated

Any clues?



----- Original Message ----- 
From: "Hin-Tak Leung" <hintak_le...@yahoo.co.uk>
To: <zd1211-devs@lists.sourceforge.net>; "Ernst J. Oud" 
Sent: Saturday, February 13, 2010 9:47 PM
Subject: Re: [zd1211-devs] Problem with MTU > 500

Hmm, the default(?) is 1500 - MTU=500 is way too low for normal usage.

since zd1211rw is also a mac80211 driver, can you give the pid modprobe.conf 
a try to see if it helps? See 

--- On Sat, 13/2/10, Ernst J. Oud <ernst...@euronet.nl> wrote:

> L.S.
> I am running Slackware 13.0 (kernel 2.6.32) on an RDC
> (=i486 compatible)
> small embedded system and using a ZD1211b usb stick for
> wlan (client) access
> using the standard zd1211rw (module). Firmware version is
> 1.4
> This works fine as long as I specify an MTU
> smaller than 500 for
> wlan0.
> With a larger MTU the connection aborts when sending
> larger amounts of
> information, for instance in a telnet session doing an ls
> of a large directory.
> I can log in and I can do an ls on a small
> directory...
> This is not an USB WLAN stick problem; I tried three
> separate sticks from
> different vendors and they all exhibit this problem.
> With an MTU of say 448, wlan speed is half of what it
> could be so any help
> would be appreciated.
> Ernst

SOLARIS 10 is the OS for Data Centers - provides features such as DTrace,
Predictive Self Healing and Award Winning ZFS. Get Solaris 10 NOW
Zd1211-devs mailing list - http://zd1211.wiki.sourceforge.net/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to