From: "Andreas Jung" <[EMAIL PROTECTED]>
> When I look through the Zope HEAD code then you are using e.g.
> 'zodb.conn' or 'zodb.storage' but also 'Zope' as loggername. Do we
> have to agree on some common usage of the logger names?
> E.g. for logging calls in the reST package....better using 'Zope' or
'reST' I guess is the onbious one. I would like to see something like this:
For Zope core core:
Zope.subsystem. i.e. 'Zope.Accesscontrol', 'Zope.OFS'.
For the default lib/python/Product stuff:
Either Zope.Product or just Product, ie 'MailHost' or 'Zope.MailHost'. Which
I don't care, makes no matter for me, but consistency would be good.
For other Products: Just the product name. In the case of CMF and CPS and
other things, you could possibly decide to use 'CMF.Core' and 'CMF.Default'
instead of 'CMFCore' and 'CMFDefault' by that also seems kinda silly.
Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists -