--On Mittwoch, 14. April 2004 16:45 Uhr +0200 Andreas Jung <[EMAIL PROTECTED]> wrote:
--On Mittwoch, 14. April 2004 10:57 Uhr +0200 Lennart Regebro <[EMAIL PROTECTED]> wrote:
From: "Andreas Jung" <[EMAIL PROTECTED]>'reST'?When I look through the Zope HEAD code then you are using e.g. 'zodb.conn' or 'zodb.storage' but also 'Zope' as loggername. Do we have to agree on some common usage of the logger names? E.g. for logging calls in the reST package....better using 'Zope' or
'reST' I guess is the onbious one. I would like to see something like this:
For Zope core core: Zope.subsystem. i.e. 'Zope.Accesscontrol', 'Zope.OFS'.
For the default lib/python/Product stuff: Either Zope.Product or just Product, ie 'MailHost' or 'Zope.MailHost'. Which I don't care, makes no matter for me, but consistency would be good.
For consitency: Zope.Products.XXXX For lazy writers: Zope. XXXXX
I prefer the second solution...everyone should know what are products and what are packages. In fact the name does not matter because you can see in the traceback where the error occurs. You don't get this information from the name directly.
Of course this applies only if you have an error :-) Anyway....names should be
kept as short as possible.
Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce